Support » Allgemeine Fragen » Website öffnet sich nicht ohne www

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Da du keine vorhandene Domain angegeben hast, ist das etwas schwierig nachzuvollziehen. Ich vermute, dass die Einstellungen im Kundenmenü bei Strato nicht richtig sind oder widersprüchliche Einstellungen in Kundemenü und einer eigenen .htaccess-Datei bestehen. Schau als erstes mal ins Strato-Menü „Sicherheit → STRATO SSL → SSL erzwingen → aktivieren“ und ob bei „Domain-Einstellungen“ eine Umleitung eingegeben wurde. Prüf dann auch mal in WordPress unter Einstellungen > Allgemein, welche URLs dort eingegeben sind. Die Website-URL sollte dem Schema https://example.com entsprechen (wenn du kein www verwenden möchtest), die WordPress-URL verweist auf das Verzeichnis, im dem die WordPress-Dateien liegen – das ist in den meisten Fällen die gleiche URL wie die Website-URL, kann aber auch etwas wie z.B. https://example.com/wordpress_02 sein (wenn die WordPress-Dateien in einem Unterverzeichnis wordpress_02 liegen.

    Hallo Bego,
    vielen Dank für deine Antwort und erstmal entschuldige bitte, daß ich mehr als einmal gepostet habe, einmal war es der berühmte „dicke Finger“ und einmal weil ich mich gewundert habe, das mein Posting anscheinend nicht verschickt und ersichtlich war…und sorry, das ich diese Beispiel-sites genommen habe, ich hatte da mal schlechte Erfahrungen gemacht…
    Hier der richtige Name: https://www.icea-germany.com

    Aber zum Thema: Bei STRATO ist SSL eingericht und „erzwungen“ und die 301-Weiterleitung aktiviert. Der Domain ist intern auf / umgeleitet (und es gibt noch ’ne zweite Möglichkeit einzustellen auf /wordpress7/).

    Bei WP Einstellungen-Allgemein ist die WP-URL auf https://www.icea-germany.com/wordpress7 gestellt und die URL auf https://www.icea-germany.com

    Die .htaccess-Datei ist vom System automatisch eingerichtet und es wurde auch nichts daran geändert…

    Ich möchte nur erreichen, daß der Besucher die Website immer erreicht, egal in welche Kombination er die Adresse eingibt, sowie ich das kenne von allen anderen Websites. (Wg. Google muss es dann natürlich nur auf eine Adresse enden z.B. https://www. …. aber das ist eine spätere Sache).

     

    Moderationshinweis: Ich habe diesmal deinen Beitrag unter diesem Benutzer-Account nochmal freigegeben. Bitte benutze künftig dein zuerst angelegtes Account @jaz1950. Bego

    Bei Eingabe der URL ohne www wird nur ein leeres Browserfenster angezeigt. Statt dessen soll wohl auf die URL mit www umgeleitet werden. Dazu stimmt scheinbar der Eintrag im Strato-Kundenmenü nicht.
    Die Weiterleitung von http auf https scheint zu funktionieren.
    Einige Bilder sind unter der URL ohne www hochgeladen worden, was Probleme bereiten könnte. Du kannst das z.B. mit dem Plugin Better Search Replace korrigieren, in dem du https://example.com mit https://www.example.com ersetzen lässt (natürlich mit deiner URL). Vorher Backup machen.

    Nachtrag, jetzt öffnet die Website sich nur OHNE www

    • Diese Antwort wurde geändert vor 11 Monaten, 3 Wochen von hz50.
    • Diese Antwort wurde geändert vor 11 Monaten, 3 Wochen von hz50.

    @hz50 / @jaz1950

    Nochmal, ein letztes Mal, der Hinweis:
    doppelte Anmeldungen (so genannte Sock-Puppet-Accounts) sind hier unerwünscht. Das Benutzerkonto mit dem Profilnamen @hz50 wurde markiert und Beiträge dieses Accounts werden künftig einfach gelöscht. Bitte verwende dein zuerst eingerichtetes Account mit dem Benutzernamen @jaz1950.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Website öffnet sich nicht ohne www“ ist für neue Antworten geschlossen.