Support » Allgemeine Fragen » Website-URL der als Homepage definierten Seite endet immer mit /wordpress

  • Gelöst Brigitte Richner

    (@brigitrichner)


    Hallo ihr lieben WordPress-Profis 😊

    Ich habe mit meiner WordPress-Webseite ein Problem: Unter Einstellungen / Allgemein im Dashboard habe ich die Webseiten-URL geändert:

    Alt: http://www.ihre-katzenpsychologin.ch/wordpress
    Neu: http://www.ihre-katzenpsychologin.ch.

    Die WordPress-URL habe ich so stehen lassen, wie sie war, also mit …/wordpress am Ende.

    Bis zu einem gewissen Grad habe ich dadurch erreicht, was ich erreichen wollte – nämlich dass meine Seite unter der neuen URL erreichbar ist. Allerdings trifft das nur auf die Unterseiten zu – auf die unter Einstellungen / Lesen als Homepage definierte Seite nicht. Egal, welche Seite ich da auswähle, diese jeweilige Seite hat dann am Ende immer das Anhängsel …/wordpress, wenn ich sie in der Adresszeile im Browser eingebe. Es leuchtet mir zwar ein, dass so die Seite nicht gefunden wird, aber wie kann ich denn das anpassen? Dazu wurde ich im Forum nicht fündig, aber vielleicht habe ich einfach falsch gesucht? 

    Zusätzlich habe ich noch das Problem, dass es nach jeder Umstellung den Style durcheinanderbringt – aber ich habe die Forenregeln gelesen, und werde dafür eine separate Frage posten, sobald das Problem mit dem Link gelöst ist. 🙂

    Ganz herzlichen Dank schon mal im Voraus!

    Liebe Grüsse

    Brigitte

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Thread-Starter Brigitte Richner

    (@brigitrichner)

    Also, sie ist da, und auch der WordPress-Ordner…

    Ich glaube, ich spiele wohl am besten mal das Back-Up drauf…

    Klingt vernünftig.

    Danach, wenn du die Dateien im Verzeichnis wordpress hast, die index.php im Web-Stammverzeichnis anlegen wie oben angegeben. Dann kannst du unter Einstellungen > Allgemein die Website-URL ohne und die WordPress-URL mit /wordpress setzen.

    Thread-Starter Brigitte Richner

    (@brigitrichner)

    Also, nach dem Wiederherstellen hab ich mir nun heute Vormittag in aller Frische jeden einzelnen Punkt angeschaut und angepasst. Dies hat zuerst nicht das gebracht, was ich wollte – d.h., das Problem mit der Startseite war nach wie vor da. Ich habe dann den Browser-Verlauf gelöscht. aber das hatte nichts geholfen. Dann musste ich eine rund 30-minütige „Zwangspause“ einlegen, und danach war dann (fast) alles so, wie ich es möchte…

    Eine Kleinigkeit finde ich allerdings jetzt eigenartig: Die Permalinks sind jetzt nicht mehr alle gleich – bei manchen nimmt es den Beitragsnamen,, so wie ich das eigentlich definiert habe in den Einstellungen, bei anderen die page-ID. Es scheint so, dass ich diese neu einzeln neu definieren muss. Das ist aber letztlich eine Nebensache, wenn es sein muss, dann soll es eben so sein… Hauptsache ist, meine Seite ist jetzt so erreichbar, wie ich es möchte 🙂

    Ich danke dir herzlich für deine Mühen und deine Unterstützung

    Liebe Grüsse

    Brigitte

    Hm, so ganz rund ist das aber noch nicht? Rufe ich die URL https://www.ihr…gin.ch/ auf, werde ich nach https://www.ihr…gin.ch/wordpress umgeleitet, wo aber keine Seite gefunden wird. Klicke ich auf den Link zum Impressum, wird die Seute geöffnet, wobei nun alle Seiten unter https://www.ihre-katzenpsychologin.ch/wordpress/?page_id=13 erreichbar sind.

    Du wolltest doch, dass die Dateien unter /wordpress liegen, die Seiten aber z.B. als https://www.ihr…gin.ch/medical-training-und-tierarzt-training gefunden wird?

    Was steht denn aktuell in der index.php im Web-Stammverzeichnis?
    Was steht in der index.php im Verzeichnis wordpress?

    Ruf bitte auch nochmal Einstellungen > Permalinks auf. Ist die Einstellung „Beitragsname“ gewählt?

    Thread-Starter Brigitte Richner

    (@brigitrichner)

    Hm… das Problem, das du beschreibst, ist genau das, was ich auch hatte. Jetzt ist es bei mir aber in Ordnung. Also, wenn ich http://www.ihr…gin.ch eingebe oder auch, wenn ich http://www.ihr…gin.ch/ eingeben, kommt bei mir die Seite, die ich als Homepage definiert habe.

    Und ja, so wie du es schreibst, möchte ich es gerne – also so, wie es bei mir jetzt zu funktionieren scheint.

    Also: Unter Einstellungen > Permalinks ist der Beitragsname angewählt. Dies funktioniert bei mir auch für die Links im „offiziellen“ Menü, nicht aber bei den Links im Inhalt… Das ist das, wo ich meinte, dass ich diese wohl manuell anpassen müsse.

    In der index.php im Stammverzeichnis ist der folgende Inhalt:

    <?php
    define( 'WP_USE_THEMES', true );
    require DIR . '/wordpress/wp-blog-header.php';

    Inzwischen wird mir die Webseite auch korrekt angezeigt.

    Wenn du intern Seiten verlinkt und dabei Links mit der Datenbank-ID verwendet hast, werden sie von einer Änderung der Permalinks nicht erfasst. Sie funktionieren dann zwar, sehen aber blöd aus. Also ist es besser, die Links manuell anzupassen.

    Thread-Starter Brigitte Richner

    (@brigitrichner)

    Da bin ich jetzt erleichtert, dass es bei dir auch korrekt angezeigt wird! Nochmals herzlichen Dank für deinen Einsatz und einen schönen Sonntagnachmittag!

    Danke, gleichfalls und viel Erfolg mit der Website.

    Thread-Starter Brigitte Richner

    (@brigitrichner)

    Danke ! 🙂

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Das Thema „Website-URL der als Homepage definierten Seite endet immer mit /wordpress“ ist für neue Antworten geschlossen.