Support » Plugins » Weiße Seite nach Update woocommerce

  • elomim

    (@elomim)


    Hallo,
    habe das Plugin woocommerce auf Version 2.3.9 geupdated. Jetzt wird aber nur noch eine weiße Seite angezeigt wenn ich die Domain aufrufe. Im Admin-Bereich kann ich zwar ein neues Produkt zufügen allerdings wenn ich auf Produkte klicke passiert nicht bzw. wird wieder eine weiße Seite angezeigt.
    Deaktiviere ich das Plugin, funktioniert alles einwandfrei.

    Bitte um Hilfe.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Edi

    (@psychosopher)

    Das kann auch an einem anderen Plugin, das sich nicht mit WooCommerce 2.3.9 verträgt, oder am Theme liegen.

    Hast Du folgendes versucht:

    1) Alle Plugins ausser WooCommerce deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.

    2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Weiße Seite bedeutet meistens, dass ein PHP-Fehler auftritt, also Debug-Mode temporär aktivieren und schauen:
    http://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

    Gruß, Torsten

    Thread-Starter elomim

    (@elomim)

    Vielen Dank für die Hilfe.

    1) habe ich gemacht und so auch fest gestellt dass es woocommerce ist der mir da Probleme macht. Jetzt noch mal alles deaktiviert und nur woocommerce aktiviert, leider ohne Erfolg.

    2) habe ich gemacht auch hier habe ich das gleiche Problem, die Productseite im Admin-Bereich wird nicht geöffnet.

    Was könnte es noch sein?

    Thread-Starter elomim

    (@elomim)

    Ich hatte vorher das Problem mit der weißen Site behoben nach dem ich die Datei pluggable.php in themes geändert habe.
    Die Zeile 1193 bis 1199 habe ich ausgeblendet:

    /**

    if ( !$is_IIS && PHP_SAPI != ‚cgi-fcgi‘ )
    status_header($status); // This causes problems on IIS and some FastCGI setups

    header(„Location: $location“, true, $status);
    */

    Damit war das Problem mit der weißen Site behoben, allerdings habe ich immer noch das Problem dass ich die Productsite in Admin-Bereich nicht öffnen kann.

    Edi

    (@psychosopher)

    Läuft die Installation auf einem Windows Server?

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Änderungen an Core-Dateien sind nie eine gute Idee.

    Gruß, Torsten

    Thread-Starter elomim

    (@elomim)

    Ja, ich weiß, mir blieb aber erstmal gar nichts anders übrig.

    Thread-Starter elomim

    (@elomim)

    Nein, die Installation läuft bei Alfahosting und die setzten linux-Server ein.

    Edi

    (@psychosopher)

    Dann macht es auch keinen Sinn, Zeilen in der Datei pluggable.php auszublenden. 😉

    Nächste Schritte:

    1) Weisst der Debug-Mode, auf den Torsten aufmerksam gemacht hat, auf einen Fehler hin?

    2) Welche PHP-Version wird verwendet?

    3) Reicht das Memory Limit?

    Thread-Starter elomim

    (@elomim)

    Der Debug-Mode sagt:

    Notice: Undefined index: woocommerce_archives_fullwidth in /wp-content/themes/mystile/includes/theme-woocommerce.php on line 276

    Notice: Undefined index: woocommerce_products_fullwidth in /wp-content/themes/mystile/includes/theme-woocommerce.php on line 280
    class=“home blog logged-in admin-bar no-customize-support safari alt-style-default layout-right-content „>

    PHP-Version: PHP-5.4
    The settings of memory are:
    PHP Version : 5.4.38 / 64Bit OS

    Memory limit : 128 MB
    Memory usage : 37.24 MB

    WordPress 4.2.2
    Woocommerce Version 2.3.9
    MystileVersion: 1.3.4

    Ich hoffe dies hilft weiter

    Edi

    (@psychosopher)

    Aktualisiere einmal das Theme auf die aktuelle Version 1.3.5. Und schaue, dass die neueste Version des WooFrameworks installiert ist.

    Thread-Starter elomim

    (@elomim)

    Bekomme auch noch die Meldung:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 72 bytes) in /wp-includes/taxonomy.php on line 4023

    Ich habe den Memory Limit schon auf 128 MB hochgesetzt, müsste doch eigentlich reichen oder?

    Edi

    (@psychosopher)

    128 MB ist zwar hoch, scheint aber in Deinem Fall nicht zu reichen.

    Beziehungsweise: Prüfe noch einmal, ob das Memory Limit tatsächlich auf 128 MB gesetzt ist.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Ich habe den Memory Limit schon auf 128 MB hochgesetzt, müsste doch eigentlich reichen oder?

    Das waren leider 72 Byte zuwenig. 😉

    Ich würde mir allerdings Gedanken über dein Setup machen, wenn du >128 MB Speicher benötigst. O_o

    Gruß, Torsten

    Thread-Starter elomim

    (@elomim)

    Habe mich auch gewundert dass 128 MB nicht reicht, bin aber leider kein Profi, was könnte ich beim Setup ändern damit mein Speicher reichen wird?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Das Thema „Weiße Seite nach Update woocommerce“ ist für neue Antworten geschlossen.