Support » Installation » Weiße Seite – statt Installationsroutine

  • Ich versuche nun schon mehrere Tage, WordPress auf unserem Sever zu Installieren. Aus erhofften 5 Minuten sind mehrere Arbeitstage geworden.

    Ich bin Hiwi in einem Institut und soll die Homepage neu entwickeln. Da es sich um keine sonderlich Komplexe Seite handelt. Will ich diese mit WordPress umsetzten.

    Ich habe WordPress diverse mal neu auf den FTP geladen. (Ältere & Neuere Versionen)

    Habe die Config.php manuell und über die Browserkonfiguration eingestellt.

    Die Manuell eingestellte Config.php ist in Ordnung, habe sie ausführlich mehrmals kontrolliert. (Leerzeichen/UTF-8/ANIS ect.)

    Über „DEEP-links“ sind diverse WordPress Seiten wie beispielsweise „lies mich“ erreichbar. Also die Daten liegen definitiv ordnungsgemäß auf dem FTP.

    Trotz alledem, bekomme ich immer nur eine weiße Seite, sobald ich eine Manuell eingestellte config.php hochlade.Lösche ich diese und lasse die PHP automatisch erzeugen , entsteht eine WordPress Fehlermeldung.

    Wo Fragen wie , ist der Benutzername richtig, das Passwort, funktioniert der Server, gefragt werden. Ich selber bekomme die MySQL host Daten von dem IT Consulting Büro des Instituts und habe leider selber keinen Zugriff.

    Unser webhoster ist netcup.net und ich denke er gewährleistet die WordPress Anfordrungen :

    PHP 5.2.4 oder höher
    MySQL 5.0 oder höher
    mod_rewrite-Modul des Apache-Webservers

    Falls Irgendjmd Ideen hat was ich noch testen / probieren könnte bitte teil es mit mir. Meine Motivation stößt an ihre Grenzen. Wenn ein eigentlich so simpler Vorgang wie die Installation von WordPress. Derartige Ausmaße annimmt.

    besten Gruß

    David

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Also zuerst einmal heißt die Datei wp-config.php, falls das irgendetwas zur Lösung beitragen könnte. Die Datenbank wurde zuvor erstellt?

    PHP 5.2 ist schon arg niedrig, soll aber laut dieser Seite aber gerade noch so eben im grünen Bereich liegen:
    https://wordpress.org/about/requirements/

    Welche Fehlermeldung erscheint denn?

    Die Datei ist mit wp-config.php benannt.
    Die Anforderungen waren nur die mindesten Anforderungen die ich online gefunden habe. Der netcup server hat PHP5.4 iwas..

    Die Headline der Fehlermeldung ist :

    Fehler beim Aufbau der Datenbank-Verbindung

    Leider ist alle was mit der Datenbank und dem MYSQL zutun hat nicht in meiner Erreichbarkeit. Ich besitze keinerlei Wissen über MYSQL. Und der Server wird extern verwaltet. Was mir meine Arbeit nicht erleichtert.

    Die Fehlermeldung klingt so, als ob die eingetragenen Daten (Datenbank, Host, DB-User, Passwort <- irgendetwas davon) nicht stimmen.

    siehe
    http://www.netcup-wiki.de/wiki/Websites#Datenbanken

    Vielleicht benötigst du die IP-Adresse des Datenbankservers
    um diese unter Host einzutragen. (Normalerweise ist Host = localhost).

    Vielleicht hast die private IP-Adresse erhalten und benötigst die externe oder vice versa.

    In der Übersicht sehen Sie die IP-Adressen des Datenbank-Servers. Dieses sind private IP-Adressen aus dem Netz 10.35.0.0/16. Für eine sichere und besonders schnelle Kommunikation zwischen Ihrem Webspace und dem Datenbankserver verwenden Sie bitte die privaten IP-Adressen. Möchten Sie doch einmal von extern auf die Datenbanken zugreifen, rechnen Sie bitte die private IP-Adresse nach folgendem Schema um:

    Interne IP-Adresse: 10.35.x.y (x.y steht für den Hostbereich der IP-Adresse des Datenbankservers)
    Öffentliche IP-Adresse: 46.38.x.y (x.y bleibt hier gleich. Es ändert sich nur der Netzbereich der IP-Adresse)

    Vielleicht habt ihr aber auch ein anderes Hostingpaket bei netcup … Einfach mal dort anrufen und nach dem Host fragen.

    hey, danke! hat leider nicht geklappt. Als host angabe habe ich folgende bekommen :

    /** Ersetze localhost mit der MySQL-Serveradresse */
    define(‚DB_HOST‘, ‚wf72d.netcup.net‘);

    Ich habe mittlerweile zugriff auf die phpmyadmin seite, dort kann ich aber keine neue datenbank anlegen da schon zwei angelegt sind und benutzt werden, aber es dürfte so weit ich weiß kein problem sein die datenbanken doppelt zu benutzen, quasie unter dem suffix wp_

    Teste doch einmal ob die Verbindung stimmt. Dafür den nachfolgenden Code mit Notepad++ oder vergleichbarem Editor (nicht Notepad von Windows!) als test.php speichern. Die test.php ins root-verzeichnis deiner geplanten WordPress-Installation hochladen und aufrufen:

    <?php
    // Verbindungs-Objekt samt Zugangsdaten festlegen
    @$db = new mysqli("wf72d.netcup.net", "DB-USER", "DB-PASSWORT", "DB-TABELLENNAME");
    
    // Verbindung überprüfen
    if (mysqli_connect_errno()) {
      printf("Verbindung fehlgeschlagen: %s\n", mysqli_connect_error());
      exit();
    }
    
    // SQL-Befehl ausführen
    $befehl = $db->query("SELECT version() AS version");
    
    // Antwort der Datenbank in ein Objekt übergeben
    $resultat = $befehl->fetch_object();
    
    // MySQL-Version aus dem Resultat-Objekt auslesen
    echo "Wir arbeiten mit MySQL-Version {$resultat->version}";
    
    // Verbindung zum Datenbankserver beenden
    $db->Close();
    ?>

    Quelle

    Natürlich musst du vorher noch in der dritten Zeile DB-User, DB-Passwort und DB-Tabellenname mit den richtigen Daten ersetzen.

    Nachdem du http://deinedomain.de/test.php aufgerufen hast, erscheint eine Meldung.

    Verbindung ohne Fehler:
    „Wir arbeiten mit MySQL-Version …“

    Ansonsten kommt:
    „Verbindung fehlgeschlagen: …“

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Weiße Seite – statt Installationsroutine“ ist für neue Antworten geschlossen.