Support » Allgemeine Fragen » Weiße Seiten nach Umzug auf Strato

  • Gelöst bhoegerl

    (@bhoegerl)


    Hallo zusammen,

    ich habe jetzt so einige Beiträge in diesem Forum und überall im www gelesen, aber kein Problem ist wie meins. Daher habe ich mich dazu entschlossen, sich einen eigenen (meinen ersten) Post zu schreiben.

    Ich habe eine neue Homepage auf meine Laptop auf dem localhost erstellt. Ich nutze das Theme „Impreza“ und ein paar Plugins.

    Nun wollte ich die Homepage auf den Strato-Server transferieren.
    1. Also Daten des WP-Ordners per FTP übertragen,
    2. DB erstellt und per Export/Import auf Strato eingespielt. Ich habe nach dem Export per Suchen/Ersetzen mein localhost-Verzeichnis auf die Domain von Strato geändert. (Ja, mittlerweile weiß ich, dass durch die nicht serialisierte Übertragung Einstellungen innerhalb des Themes verloren gehen. Die hätte ich manuell nachgezogen.)
    3. Dann per FileZilla die .htaccess gelöscht und die wp-config auf meine Datenbank editiert.

    Zunächst konnte ich mich auf wp-admin einloggen. Wenn ich auf die Adresse der Homepage gewechselt bin, habe ich aber immer nur weiße Seiten erhalten.

    Ich habe dann den Debug Modus aktiviert. Es wurde mir ein Fehler in der Datei …/wp-content/themes/Impreza/framework/functions/header.php in der Zeile 20 angezeigt.
    Inhalt dieser Zeile: return isset( $us_header_settings[ $state ][‚options‘][ $name ] ) ? $us_header_settings[ $state ][‚options‘][ $name ] : $default;

    Damit konnte ich erstmal wenig anfangen, ich habe dann versucht, das Theme zu deaktivieren/reaktivieren. –> Keine Auswirkung

    Nach einiger Überprüfung und dem erneuten Beschreiben der .htaccess kann ich aber mittlerweile auch nicht mehr in meinen wp-Admin-Bereich. Es wird immer nur eine weiße Seite angezeigt.

    Auch das Umbenennen der plugin- und theme-Ordner bringt mich nicht wieder ins Backend.

    Mittlerweile bin ich mit meinem Latein am Ende. Ich hoffe, dass jemand ein paar Ideen für mich hat, die ich ausprobieren kann.
    Oder hilft mir nur ein kompletter Neuanfang zum Beispiel mit der Beschreibung von Bego Mario Garde? (Duplicator)

    Danke und viele Grüße,
    Bernhard

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Vielleicht noch als Zusatzinfo. Bei Strato liegen zwei Homepages.
    Diese sind aber eigentlich klar getrennt, jede hat ihre eigene Datenbank. Die Seite B funktioniert ja auch wunderbar.
    Seite A (siehe oben) ist auf mit der korrekten Domain auf das interne WP-Stammverzeichnis verlinkt.
    (Sonst hätte ich ja anfangs nicht auf die wp-admin Seite kommen können oder?)

    Hat keiner eine Idee?

    Welche PHP-Version ist denn eingestellt?
    Funktioniert die WordPress-Installation, wenn du im Backend ein Standard-Theme aktivierst?

    Zu gekauften Themes können wir keine Auskunft geben, weil wir uns erst einmal das Theme selber kaufen müssten, um die dann kostenlos den Support zu geben, für den du jemand anders bezahlt hast. Aber das steht ja auch in der Foren-Beschreibung und unseren FAQ, hast du sicher gelesen.

    Ja, ich möchte auch keine Theme-Problematik lösen. Bis jetzt weiß ich ja auch noch nicht, ob es eine solche ist. Mir ist natürlich bewusst, dass mir bei einem Theme-Problem keiner helfen kann.

    Ich schreibe ja oben, dass ich auch nach Umbenennung der Ordner „themes“ und „plugins“ per FTP noch immer einen weißen Bildschirm habe. Damit dürfte dann ja die Theme-Problematik aus dem Spiel sein oder nicht?

    PHP-My-Admin sagt 4.2.12.

    Ich komme ja nicht ins Backend, weil ich einen weißen Bildschirm bekomme. Wie kann ich denn sonst darauf zugreifen?

    Es war ja nur ein Hinweis, dass wir zu gekauften Themes nur sehr eingeschränkt weiterhelfen können. Alles gut … 🙂

    Bitte nicht das Verzeichnis wp-content/themes umbenennen. Du kannst per FTP das Theme Impreza verschieben, aber WordPress muss schon noch auf ein Theme zugreifen können.

    Die Version, die du in phpMyAdmin abgelesen hast, bezieht sich vermutlich auf phpMyAdmin selbst, nicht aber auf die PHP-Version. Du könntest im Web-Stammverzeichnis eine Datei info.php anlegen mit folgendem Inhalt:
    <?php phpinfo();
    Dann im Browser http://deinedomain.de/info.php aufrufen. Hier solltest du die PHP-Version sehen. Ist sie unter PHP 5.6, solltest du im Kundenmenü deines Webhoster eine höhere Version auswählen.
    Bitte anschließend die Datei info.php wieder löschen, damit potentiellen Angreifern nicht unnötig viele Informationen auf dem Silbertablett geliefert werden.

    Für den „White Screen of Death“ gibt es noch andere mögliche Ursachen – z.B. falsche Zugangsdaten für die Datenbank. Stimmen die Einstellungen für den Datenbank-Host?

    Sorry, sollte auch nicht pampig klingen!
    Ich überlege mir normalerweise sehr genau, wann ich ein Forum befrage. Und wenn, dann habe ich bereits gesucht und hab ein noch nicht bekanntes Problem, daher habe ich auch keine Information ausgelassen. Das schließt die Verwendung von Themes mit ein.

    Ich habe nun alle von mir verwendeten Themes mit der Endung „-temp“ im Ordnernamen ergänzt. Das gleiche habe ich mit allen verwendeten Plugins gemacht. Die Überordner heißen wieder wie gewohnt. –> White Page bleibt.
    Nimmt WP dann eines der Standard-Themes 201x?

    Ich habe die Login-Daten nochmal überprüft. Stimmt alles. Auch die Anführungszeichen sind korrekt, das hatte ich ein paar mal als Stolperfalle.
    Ist der Standard-Server bei Strato wirklich http://rdbms.strato.de?
    –> White Page bleibt.

    Stimmt. Die Version habe ich wie von dir beschrieben mit der info.php abgefragt und ist die 5.3.29.
    In Strato steht allerdings 5.6.36.
    Mein ursprüngliche Datenbank auf dem localhost (Export) ist aber 5.6.24.
    Daher könnte das Problem stammen. aber wie ist das möglich? Und wie kann ich die Versionen gleichziehen?

    • Diese Antwort wurde geändert vor 3 Jahre, 7 Monaten von bhoegerl.

    Der Datenbank-Host ist bei Strato rdbms.strato.de – ohne http://. Daran könnte es liegen.

    PHP 5.3.29 ist veraltet, müsste aber grundsätzlich ausreichen. Die PHP-Version wird im Kundenmenü festgelegt, allerdings ist auch eine „manuelle“ Anpassung per .htaccessmöglich (wird hier beschrieben).

    Ah das http:// wurde bei der Verlinkung automatisch hinzugefügt. In meiner wp-config steht es ohne. Sollte also passen.

    Ich habe nun die PHP Version auf 5.6 eingestellt. Danach nochmal mit Duplicate alles neu übertragen und siehe da:
    ES KLAPPT!

    Das muss es gewesen sein. Ich bedanke mich tausend mal und werde jetzt alles mal ordentlich durchchecken.

    Viele Grüße!

    Nachtrag:

    Ja, es hat wohl wirklich an der PHP-Version gelegen.

    Ich hab zusätzlich den Boost aktiviert und bemerke, dass die Seite deutlich schneller aufbaut, als ohne Boost.

    Nochmal danke, Bego Mario Garde!!

    Gerne. 😊

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Weiße Seiten nach Umzug auf Strato“ ist für neue Antworten geschlossen.