Support » Themes » Weißer Spalt im obersten Bereich

  • Gelöst sergen93

    (@sergen93)


    Liebe Forum Mitglieder,

    ich habe mir vor einigen Tagen meine Webseite angelegt und bin momentan dabei, diese zu bearbeiten.

    Ich verwende Oceans Wp.

    Mein Problem ist nun folgender:

    Mein Theme streckt sich nicht bis auf den oberen Rand der Webseite. Wenn man sich die Homepage ansieht, ist oben vor dem Menü immer ein weißer Balken/Spalt. Ich habe wirklich so einige Stunden dafür geopfert und weiß einfach nicht, wie ich das entfernen kann :/

    Nun habe ich diesen Forum gefunden und wäre für Eure Unterstützung sehr dankbar.

    Beste Grüße
    Seyma

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Hallo,
    ich vermute, dass das Problem mit deinen Einstellungen im Header bei OceanWP und/oder Elementor zusammenhängt. Da ich allerdings Elementor und OceanWP nicht verwende, kann ich dir leider nicht sagen, wie und an welcher Stelle du das über die Einstellungen ändern kannst.

    In Elementor hast du wohl im Content-Bereich ein Background Video eingefügt. Und da befindet sich auch das Menü, das aber (genau wie ein evtl. Logo) normalerweise im Header sein sollte, der in dem Fall leer ist.

    In OceanWP ist vermutlich die Einstellung „Deine Anpassungen für“ ▸ Leiste – ganz oben
    Allgemein eingeschaltet. Diese Leiste könntest du ggfs. mal an der Stelle deaktivieren. Das findest du unter Design > Customizer

    Weiter solltest du die Einstellungen unter „Deine Anpassungen für“ ▸ Header
    Allgemein prüfen.

    Als Workaround kannst du die folgende CSS-Regel unter Design > Customizer > Individuelles CSS einfügen. Das ist allerdings keine gute Lösung, weil das Menü in die Bereiche hingehört, die durch diese Regeln ausgeblendet werden:

    header#site-header {
        display: none;
    }
    div#top-bar-wrap {
        display: none;
    }

    Viele Grüße
    Hans-Gerd

    Thread-Starter sergen93

    (@sergen93)

    Vielen Dank für die schnelle Rückmeldung.

    Ich habe es tatsächlich folgendermaßen lösen können:

    Bei WordPress auf „Seiten“ gehen. Bei der jeweiligen Seite auf „Bearbeiten“ gehen. Dort ist die Bearbeitung von WordPress.

    Anschließend auf „Header“ und dann beide Einstellungen auf „Disabled“ stellen.

    Beste Grüße
    Seyma

    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

    Anschließend auf „Header“ und dann beide Einstellungen auf „Disabled“ stellen.

    Das hört sich etwas aufwendig an. Ich vermute mal, dass es dafür eine globale Einstellung gibt.
    Aber wenn es so funktioniert, ist ja erst mal alles gut.

    Thread-Starter sergen93

    (@sergen93)

    Ja tatsächlich 😂 Vor allem, wenn man sich noch nicht ausreichend auskennt, ist das sehr überfordernd.

    Vielleicht findet man im Laufe der Zeit eine globale Einstellung, nachdem man sich mehr mit dem Programm auseinandergesetzt hat 🙏🏼

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)