Support » WooCommerce » White Screen bei Plugin Costumer Cancel Order

  • nadi86

    (@nadi86)


    Hallo ,

    ich benötige dringend eine Hilfestellung.
    Ich habe vor kurzem einen Webshop mit WooCoomerce aufgebaut.
    Nun habe ich das Plugin costumer Cancel Order von WooCommerce gekauft und installiert. Sobald ich das Plugin aber aktiviere habe ich einen WhiteScreen, aber nur auf der Mein Konto und Meine Bestellungen Seite.
    Ich habe vieles ausprobiert aber ich habe keine Ahnung wo ich da ansetzen kann.
    Wenn ich das Plugin deaktiviere ist die Mein Konto Seite und Meine Bestellungen Seite wieder ganz normal sichtbar.

    Ich würde mich total über Hilfe und Rückmeldungen freuen.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator espiat

    (@espiat)

    Hi.

    Falls es ein Shop ist der schon Live ist:
    Staging Umgebung anlegen.

    Dann:
    WP Debug anschalten:
    https://wordpress.org/support/article/debugging-in-wordpress/

    Plugin aktivieren.
    Fehler erneut verursachen und im Log schauen.
    Dann wirst du jedenfalls schonmal den genauen Fehler haben.

    Kannst du dann hier posten.

    Thread-Ersteller nadi86

    (@nadi86)

    super danke erst mal für den Hinweis. Ich hatte den Wp Debug Modus aktiviert und der Log sieht so aus :

    fatal-errors-2022-04-28-65aaa0fe71b75d897e8397e151919c02.log

    2022-04-28T19:10:45+00:00 CRITICAL Cannot redeclare filter_created_pages() (previously declared in /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-update-functions.php:2281) in /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-update-functions.php in Zeile 2281
    
    2022-04-28T19:10:51+00:00 CRITICAL Cannot redeclare filter_created_pages() (previously declared in /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-update-functions.php:2281) in /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes
    /wc-update-functions.php in Zeile 2281

    aber hierbei handelt es sich um ältere Log Einträge. Ich habe diese mal geslöscht und dann das Plugi aktiviert. Es wird kein Log Eintrag erzeugt beim aktivieren des Plugins. Vielleicht stehe uch gerade auf dm Schlauch aber ich komme da nicht weiter.

    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von nadi86.
    Moderator espiat

    (@espiat)

    Hallo.

    Nachdem du den log aktiviert hast, bitte einmal den Fehler auslösen.
    Also dann einmal den Whitescreen erwzingen.

    Dann müsste was im log stehen.
    Ansonsten den PHP log beim Hoster anschauen.

    Zudem kannst hier einmal den Site Health Bericht einstellen.

    Thread-Ersteller nadi86

    (@nadi86)

    Ich habe den log aktiviert und das Plugin aktiviert. Es wird kein Log Eintrag erzeugt. White Screen sofort bei Aktivierung da aber nur bei den Seiten Mein Konto und meine Bestellungen. Der Log Eintrag bei dem Hoster den habe ich auch aktiviert da steht das :

    2022/05/16 09:57:02 [error] 13947#13947: *101969 FastCGI sent in stderr: "PHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/home/wp/disk/wp-config-sample.php) is not within the allowed path(s): (/tmp:/dev/urandom:/home/wp/rbsh/conf/RAIDBOXES:/home/wp/tmp/limit-login:/home/wp/tmp/multisite:/home/wp/disk/wordpress) in /home/wp/disk/wordpress/wp-admin/setup-config.php on line 46" while reading response header from upstream, client: 40.114.25.67, server: frauen-u-unternehmen.de, request: "GET /wp-admin/setup-config.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/wordpress.php-fpm.sock:", host: "frauen-u-unternehmen.de"
    2022/05/16 08:50:02 [crit] 13948#13948: *100399 SSL_do_handshake() failed (SSL: error:141CF06C:SSL routines:tls_parse_ctos_key_share:bad key share) while SSL handshaking, client: 64.62.197.212, server: 10.14.4.202:443
    2022/05/16 08:19:46 [error] 13947#13947: *100021 directory index of "/home/wp/disk/wordpress/wp-admin/css/" is forbidden, client: 45.133.1.73, server: frauen-u-unternehmen.de, request: "GET /wp-admin/css/ HTTP/1.1", host: "frauen-u-unternehmen.de", referrer: "binance.com"
    2022/05/16 08:05:49 [error] 13948#13948: *99867 FastCGI sent in stderr: "PHP message: PHP Warning: sizeof(): Parameter must be an array or an object that implements Countable in /home/wp/disk/wordpress/wp-content/themes/econature/woocommerce/single-product/meta.php on line 18" while reading response header from upstream, client: 185.191.171.10, server: frauen-u-unternehmen.de, request: "GET /produkt/betriebsbesichtigung-cibaria/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/wordpress.php-fpm.sock:", host: "frauen-u-unternehmen.de"
    2022/05/16 06:37:41 [error] 13947#13947: *98869 directory index of "/home/wp/disk/wordpress/wp-content/uploads/" is forbidden, client: 176.53.62.93, server: frauen-u-unternehmen.de, request: "GET /wp-content/uploads/ HTTP/1.1", host: "frauen-u-unternehmen.de", referrer: "https://frauen-u-unternehmen.de/wp-content/uploads"
    2022/05/16 05:45:37 [error] 13948#13948: *98324 FastCGI sent in stderr: "PHP message: PHP Warning: php_uname() has been disabled for security reasons in /home/wp/disk/wordpress/wp-content/plugins/worker/src/MMB/Stats.php on line 406" while reading response header from upstream, client: 54.191.137.17, server: frauen-u-unternehmen.de, request: "POST /wp-load.php?mwprid=6281c5dfb8cca3.54218553 HTTP/1.1", upstream: "fastcgi://unix:/var/run/wordpress.php-fpm.sock:", host: "frauen-u-unternehmen.de", referrer: "https://frauen-u-unternehmen.de/"
    2022/05/16 04:13:02 [error] 13948#13948: *97419 access forbidden by rule, client: 103.133.107.210, server: frauen-u-unternehmen.de, request: "GET //wp-login.php HTTP/1.1", host: "frauen-u-unternehmen.de"
    2022/05/16 01:36:35 [error] 13948#13948: *95896 FastCGI sent in stderr: "PHP message: PHP Warning: php_uname() has been disabled for security reasons in /home/wp/disk/wordpress/wp-content/plugins/worker/src/MMB/Stats.php on line 406" while reading response header from upstream, client: 54.191.137.17, server: frauen-u-unternehmen.de, request: "POST /wp-load.php?mwprid=62818e77c83140.91837769 HTTP/1.1", upstream: "fastcgi://unix:/var/run/wordpress.php-fpm.sock:", host: "frauen-u-unternehmen.de", referrer: "https://frauen-u-unternehmen.de/"
    thrown in /home/wp/disk/wordpress/wp-content/themes/econature/index.php on line 13" while reading response header from upstream, client: 3.92.128.229, server: frauen-u-unternehmen.de, request: "GET /wp-content/themes/econature/ HTTP/2.0", upstream: "fastcgi://unix:/var/run/wordpress.php-fpm.sock:", host: "frauen-u-unternehmen.de", referrer: "http://sucuri.net"
    #0 {main}
    Stack trace:
    2022/05/16 01:36:22 [error] 13947#13947: *95872 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to undefined function get_header() in /home/wp/disk/wordpress/wp-content/themes/econature/index.php:13

    ich habe das mal in der Live Seite aktiviert dann kommt das :

    78.49.72.197 - rb [16/May/2022:10:27:59 +0200] "GET /wp-json/jetpack/v4/jitm?message_path=wp%3Aplugins%3Aadmin_notices&query=activate%253Dtrue%252Cplugin_status%253Dall%252Cpaged%253D1%252Cs%253D&full_jp_logo_exists=false&_wpnonce=410073aaab HTTP/2.0" 200 6 "https://frauen-u-unternehmen.de/wp-admin/plugins.php?plugin_status=all&paged=1&s" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0" 0.770 0 NGINX - "" pc
    78.49.72.197 - rb [16/May/2022:10:27:58 +0200] "GET /wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s= HTTP/2.0" 200 72294 "https://frauen-u-unternehmen.de/wp-admin/plugins.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0" 2.105 0 NGINX - "" pc
    78.49.72.197 - rb [16/May/2022:10:27:55 +0200] "GET /wp-admin/plugins.php?action=activate&plugin=customer-order-cancellation-for-woocommerce%2FCustomer-Order-Cancellation-for-WooCommerce.php&plugin_status=all&paged=1&s&_wpnonce=da595a0dd3 HTTP/2.0" 302 0 "https://frauen-u-unternehmen.de/wp-admin/plugins.php" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0" 12.735 0 NGINX - "" pc
    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von nadi86.
    Moderator espiat

    (@espiat)

    Soweit ich das sehe, läuft das auf RAIDBOXES und mit nginx.

    Da wende dich mal an Raidboxes, damit erstmal die Konfigarationsfehler weg sind.

    Thread-Ersteller nadi86

    (@nadi86)

    Ok, aber wie kann das sein das alles läuft und sobald ich das Plugin aktiviere wird nur die MeinKonto Seite und die Seite Bestellungen als WhiteScreen dargestellt. Das hat doch weniger mot Raidboxes zu tun, oder?

    Im log stehen zeitstempel. Kannst du das Plugin mal aktivieren und dann den Fehler provozieren? Und dann exakt auf 10 Sekunden genau die log zeilen hier posten?

    Desweiteren handelt es sich um ein Bezahltes plugin. Ich würde mich direkt an den Hersteller wenden..

    • Diese Antwort wurde geändert vor 1 Woche, 3 Tage von Michi91.
Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)