Support » Allgemeine Fragen » [Gelöst] Widget löscht Daten nach speichern.

  • Gelöst DerNordfriese

    (@dernordfriese)


    Guten Abend,
    Ich habe eine Problem mit mit der Website unserer Jugendfeuerwehr die ich verwalte. Wir nutzen WordPress 3.6.

    Folgendes:
    Ich erstelle ein „Text-Widget“ in der ersten Zeile schreibe ich „<h3><div>Dienstplan</div></h3>“ (ohne Anführungszeichen) wenn ich dies speicher gibt es kein Problem, und alles wird richtig angezeigt.
    Nun wollte ich einen Html Code eines Google-Kalender in die zweite Zeile einfügen (copy & paste) um diesen einzubetten. Anfangs steht der eingefügte Code auch noch da, nachdem ich aber gespeichert habe verschwindet der Code des Google Kalenders (Die Überschrift nicht)

    Ich habe dies mehrfach wiederholt, hatte aber immer wieder dieses Problem.

    Mit freundlichen Grüßen

    DerNordfriese

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moin, moin!

    Hast Du vielleicht ein WordPress.COM-Blog?

    Dann wärst Du im falschen Forum.
    Siehe: http://de.support.wordpress.com/com-vs-org/

    In Zukunft dann im richtigen Forum schreiben:
    http://de.forums.wordpress.com/

    Über diesen Weg sollte es gehen:
    http://en.support.wordpress.com/google-calendar/

    Gruß, Torsten

    Thread-Ersteller DerNordfriese

    (@dernordfriese)

    Moin,

    Nein wir nutzen WordPress.org und wir hosten von unserem eigenen Server.

    Ich habe mir deine Anleitung mal angeschaut und hatte dasselbe Problem beim Editor während des erstellens einer Seite/Beitrags wie beim Widget. Ich füge den HTML Code des Kalenders ein und nach dem Speichern ist er weg…

    Grüße

    DerNordfriese

    Moderator espiat

    (@espiat)

    Hast du das Problem auch bei anderen iframe Einbindungen (z.B. Youtube)?

    Wenn ja- hast du ein Plugin was die Einbindung von HTML Code eventuell unterbindet?

    Bist du Admin?

    Bist du Admin?

    Müsste er eigentlich (bei unverändertem WP), denn Widgets siehst Du nur mit edit_theme_options Capability und die hat nur der Admin …

    Daher würde ich auch auf ein Plugin tippen, der an den Filtern spielt.

    Mal schrittweise alle Plugins deaktiviert und geschaut, ob das Problem immer noch auftaucht?

    Gruß, Torsten

    Thread-Ersteller DerNordfriese

    (@dernordfriese)

    Okay danke, ich probiere das heute abend mal und melde mich aufjedenfall zurück!

    Grüße
    DerNordfriese

    Thread-Ersteller DerNordfriese

    (@dernordfriese)

    Also das Problem ist gefunden, wir nutzen WordPress als Netzwerk System, also wir nutzen Word Press für 2 seperate Websiten die auf einem Server laufen. Ich bin zwar Admin meiner Seite aber nicht „Netzwerkadminstrator“ unser Netzwerk admin konnte das Widget ohne Probleme bearbeiten und auch speichern.

    Grüße

    DerNordfriese

    Moderator espiat

    (@espiat)

    Ha – Hatte ich doch den richtigen Riecher.

    😉

    Thread ist dann also gelöst.

    Hier ist der Codex leider etwas ungenau (in der Liste fehlt das explizite Erwähnen der Widgets neben Seiten, Beiträgen und Kommentaren):

    unfiltered_html
    […]
    Allows user to post HTML markup or even JavaScript code in pages, posts, and comments. […]
    Note: In WordPress Multisite, only Super Admins have the unfiltered_html capability.

    http://codex.wordpress.org/Roles_and_Capabilities#unfiltered_html

    Gruß, Torsten

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „[Gelöst] Widget löscht Daten nach speichern.“ ist für neue Antworten geschlossen.