Support » WooCommerce » WooCommerce auf Artikelseite keine Preise mehr

  • Gelöst bertix

    (@bertix)


    Hallo Zusammen, ich arbeite mit twenty-twenty-three und WooCommerce und Germanized. Ich sehe nun auf WooCommerce Artikel Seite keine Preise mehr. Stelle ich um auf Astra funktioniert es.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Beim Aufruf der Seite gibt es mehrere JavaScript-Fehler in Bezug auf die WooCommerce-Blöcke. Hast Du von WooCommerce die aktuellste Version installiert? Wenn ja, liegt der Fehler vermutlich in dieser.

    Eine Möglichkeit wäre das WooCommerce Blöcke Entwicklungsplugin testweise zu installieren: https://de.wordpress.org/plugins/woo-gutenberg-products-block/ – dadurch könnten aber auch noch andere Änderungen dazukommen. Oder du meldest das Problem im WooCommerce-Supportforum und wartest auf eine Korrektur: https://wordpress.org/support/plugin/woocommerce/

    Thread-Starter bertix

    (@bertix)

    Vielen Dank für die Antwort. Ja, es ist alles auf dem neuesten Stand. Habe auch überlegt das Problem vielleicht über CSS in den Griff zu bekommen?? Mittlerweile habe ich Germanized deaktiviert aber auch dies bringt keine Resultate.

    CSS wird hier gar nicht helfen. Es liegt wie gesagt an den JavaScript-Fehlern. Hast Du es mal mit dem WooCommerce Blöcke Plugin probiert?

    Thread-Starter bertix

    (@bertix)

    OK, hatte an CSS gedacht, weil ich die Annahme hatte, das der Preis vielleicht irgendwo auf hidden konfiguriert ist. Das WooCommerce Block Plugin werde ich nächste Woche einmal ausprobieren. Ich werde erst einmal warten, ob das WooCommerce-Supportforum eine Lösung weiß.

    Hi.

    Du hast da einige Fehler in der Konsole.

    Staging Seite:
    Standard Theme aktivieren und alle Plugins aus ausser Woo.
    Wenn es dann geht, dann wiesst du dass es an einem Plugin liegt.

    Dann die Plugins nach und nach aktivieren und schauen, welches den Fehler behebt.

    Thread-Starter bertix

    (@bertix)

    Hallo Marcus, vielen Dank für den Tipp. Ja, das habe ich alles schon probiert, hat nicht funktioniert. Zur Zeit suche ich folgenden Fehler zu lösen, weiß aber nicht wie:

    TypeError: wp.i18n is undefined

        <anonymous> ../product/blechschild-katzen-und-wein/:541

        <anonymous> ../product/blechschild-katzen-und-wein/:542

    hi.

    wenn du nur das Standard Theme aktiviert hast und nur woocommerce und immer noch keine preise anzeigt, dann checke mal die console, wohlmöglich ist die woo installation nicht korrekt, weil js dateien fehlen oder du hast eine einstellung in woo übersehen.

    ich weiß ja, dass der preis mit standard theme und woo angezeogt wird.
    benutzt du blocks? wenn ja, dann mal ein default classic theme nehmen.

    Thread-Starter bertix

    (@bertix)

    Ja, habe ich auch schon probiert: WooCommerce deaktiviert und gelöscht und danach neu aufgespielt. Ich benutze Twenty-Twenty-Three und arbeite mit Full Site Editing, also den hauseigenen Blöcken.

    ich habe hier lokal eine WP install mit blöcken und woo und da geht das.
    deine blockdateien scheinen nicht komplett zu sein.

    stelle mal auf englische sprache und schaue dann. kann sein, dass ein spezielles sprachpaket für deutsch Du / Sie nicht vorhanden ist.

    in der div
    <div data-block-name=“woocommerce/product-price“

    ist der preis und ist bei dir leer, weil class=“is-loading“

    Thread-Starter bertix

    (@bertix)

    Ja, es ist eigenartig, bein WooCommerce in den Einstellungen unter Allgemein gibt es keine Ländereinstellungen.

    1. Stelle Sprache in den WordPress Settings ein.
    2. Hast du Verkaufsland korrekt eingetragen in Woo?
    Thread-Starter bertix

    (@bertix)

    Ich sehe hier keine Spracheinstellungen.

    woo:

    wp:

    Thread-Starter bertix

    (@bertix)

    Vielen Dank für den Hinweis. Die Sprachumstellung auf englisch hat aber leider auch kein Ergebnis erzielt

    hast du nach umstellung auch die neuen sprachdateien heruntergeladen?

    es hat definitiv was mit den sprachpaketen zu tun, die nicht vorhanden sind.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)