Support » WooCommerce » WooCommerce auf Artikelseite keine Preise mehr

  • Gelöst bertix

    (@bertix)


    Hallo Zusammen, ich arbeite mit twenty-twenty-three und WooCommerce und Germanized. Ich sehe nun auf WooCommerce Artikel Seite keine Preise mehr. Stelle ich um auf Astra funktioniert es.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Thread-Starter bertix

    (@bertix)

    Wo finde ich denn die neuen Sprachdateien, wie heißen sie und in welchen Ordner gehören sie?

    Die werden durch WordPress selbst runtergeladen sobald Du eine Sprache aktivierst. WordPress speichert sie dann in wp-content/languages/. Du selbst hast darauf keinen Einfluss. Wenn bei dir der Download von diesen Sprachdateien nicht klappt, beeinflusst irgendein von dir genutztes Plugin deren Download. Deaktiviere alle Plugins und schau, ob du unter Aktualisieren dann „Übersetzungen laden“ kannst oder WordPress das für dich bereits macht. Testweise kannst Du auch mal auf eine andere Sprache wechseln die du bisher nicht hattest, z.B. „Deutsch (Österreich)“.

    Thread-Starter bertix

    (@bertix)

    Hallo Thready, ja, ich habe Deinen Vorschlag nun durchgeführt, alle Plugins deaktiviert, dann WordPress aktualisiert. Das Sprachpaket Österreich gibt es nun im Language Ordner aber leider immer noch keine Preisdarstellung.

    Dann ist es das nicht.

    Ich frage mich schon seit deiner ersten Frage dazu wieso du diesen Block, in dessen JavaScript das Problem entsteht, in deiner Ausgabe hast. Dessen Name scheint „wc-product-rating-block“ zu sein. Ich kann den aber weder in WooCommerce noch irgendeinem anderen Plugin im WordPress-Repository finden. Es muss ja etwas mit Bewertungen zu tun haben. Wenn Du keinerlei andere Plugins mehr aktiviert hast, woher kommt dann diese Ausgabe?

    Ich habe eben auch mal in einem Testsystem das aufgebaut was Du hier hast. TwentyTwentyThree als Theme, WooCommerce in der aktuellsten Version 8.4.0 – nichts anderes. Und ich habe ebenfalls nicht das bei dir entstehende Problem. Hast Du irgendetwas an den Templates bearbeitet?

    Thread-Starter bertix

    (@bertix)

    Du siehst also bei Dir einen Preis bei Deiner Konfiguration auf der Artikelseite? Ich habe ein Child theme von Twenty-Twenty-Three in Verwendung mit einer functions.php. Aber auch wenn ich auf das normale Twenty-Twenty-Three oder auch Four switche, besteht das Problem. Nur wenn ich auf Astra gehe, sehe ich den Preis.

    Ja, ich sehe ihn bei TwentyTwentyThree. Auf Grund deiner Beschreibung vermute ich einen Fehler in deinem Template für „Einzelne Produkte“, welche in TwentyTwentyThree vermutlich individuell gespeichert ist.

    Geh mal auf Design > Website-Editor > Templates > Alle Templates verwalten und klicke bei „Einzelnes Produkt“ rechts auf die 3 Punkte. Dort kannst Du individuelle Anpassungen zurücksetzen, wenn solche an dem Template vorhanden sind. Klick das an. Danach sollten die Preise wieder angezeigt werden.

    Thread-Starter bertix

    (@bertix)

    Ja Threadi, das ist ja der Hammer, dieser Lösungsvorschlag hat funktioniert. Was denkst Du wie es hierzu kommen konnte? Und kannst Du mir sagen wie ich aus dem Language Ordner die AT files wieder rausbekomme? Oder beeinflusst das meine Ladegeschwindigkeit garnicht. Vielen Dank für Deinen hilfreichen Input und noch einen angenehmen Abend!

    Da ich die Historie deines Projektes nicht kenne, hab ich keine Ahnung wie es dazu kommen konnte.

    Die Sprachdateien kannst Du per FTP aus wp-content/languages/ löschen. Das müssten die de_AT.mo und de_AT.po sein. Wenn sie vorhanden sind behindern sie dein Projekt jedoch in keiner Weise.

    Gerne kannst Du das Topic hier noch auf gelöst setzen.

    Thread-Starter bertix

    (@bertix)

    Ja, nochmals vielen Dank für Deine Hilfe.Ich setze den Thread jetzt auf gelöst.

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)