Support » WooCommerce » Woocommerce Euro als code dargestellt

  • Hey zusammen,

    woocommerce zeigt meine Angebotspreise als & euro; und nicht als € an.
    Wo lässt sich das korrigieren?

    Viele Grüße

    • Dieses Thema wurde geändert vor 9 Monaten, 4 Wochen von mindyoursoul.
    • Dieses Thema wurde geändert vor 9 Monaten, 4 Wochen von mindyoursoul.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Bitte lies dir diesen Beitrag nochmal durch:

    Warum ein Link zu deiner Website wichtig ist

    Thread-Ersteller mindyoursoul

    (@mindyoursoul)

    Teste doch bitte mal, was sich ändert, wenn du das Instagram-Plugin deaktivierst.

    Wenn sich damit nichts ändert, bräuchten wir mehr Informationen zur Website. Geh dazu bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen.

    Thread-Ersteller mindyoursoul

    (@mindyoursoul)

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app
    wordpress_size: 47,01 MB (49295070 bytes)
    uploads_path: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content/uploads
    uploads_size: 125,72 MB (131828184 bytes)
    themes_path: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content/themes
    themes_size: 9,72 MB (10194370 bytes)
    plugins_path: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content/plugins
    plugins_size: 56,47 MB (59216656 bytes)
    database_size: 5,58 MB (5849088 bytes)
    total_size: 244,51 MB (256383368 bytes)
    
    ### wp-active-theme ###
    
    name: Neve (neve)
    version: 2.8.1
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: core-block-patterns, hfg_support, post-thumbnails, title-tag, automatic-feed-links, custom-logo, html5, customize-selective-refresh-widgets, custom-background, align-wide, editor-color-palette, fl-theme-builder-headers, fl-theme-builder-footers, header-footer-elementor, lifterlms-sidebars, lifterlms, service_worker, menus, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content/themes/neve
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.7, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.4, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.5, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (8) ###
    
    Germanized for WooCommerce: version: 3.2.1, author: vendidero, Automatische Aktualisierungen deaktiviert
    Klarna Payments for WooCommerce: version: 2.1.2, author: krokedil, klarna, automattic, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts Reloaded: version: 2.15.2, author: WPChef, Automatische Aktualisierungen deaktiviert
    Simple Custom CSS: version: 4.0.4, author: John Regan, Danny Van Kooten, Automatische Aktualisierungen deaktiviert
    StoreCustomizer: version: 2.2.0, author: Kaira, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 4.5.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce PayPal Checkout Gateway: version: 2.0.3, author: WooCommerce, Automatische Aktualisierungen deaktiviert
    WP Maintenance Mode: version: 2.2.4, author: Designmodo, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Antispam Bee: version: 2.9.2, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Smash Balloon Instagram Feed: version: 2.4.7, author: Smash Balloon, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-47 Q16 x86_64 2019-05-28 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 76M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 512 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 512 GB
    	imagick::RESOURCETYPE_MEMORY: 256 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.3.22
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content
    WP_PLUGIN_DIR: /mnt/web516/c2/72/510782772/htdocs/STRATO-apps/wordpress_02/app/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Die Zeitzone sollte unter Einstellungen > Allgemein noch auf Berlin gesetzt werden, aber das hat natürlich nichts mit dem Fehler zu tun. Sonst fällt mir in den Angaben zur Website soweit nichts auf. Es kann aber gut sein, dass ein anderes Plugin Probleme bereitet.

    Installier doch mal das Plugin Health Check, geh auf Werkzeuge > Website-Zustand > Problembehandlungsmodus. Bei Aktivieren werden die Plugins alle deaktiviert und ein Standard-Theme aktiviert. Aktiviere dann über die Admin-Leiste WooCommerce und kontrolliere, ob sich an der Darstellung etwas ändert. Falls die Anzeige des Euro-Symbols hier richtig erscheint, kannst du das bisher verwendete Theme Neve wieder aktivieren und die Plugins nacheinander wieder aktivieren. Ziel ist, die Fehlerursache einzugrenzen.

    Thread-Ersteller mindyoursoul

    (@mindyoursoul)

    Der Fehler bleibt bestehen, auch wenn ich nur woocommerce reaktiviere. Auch in woocommerce im dashboard tritt der Fehler beim Gesamtumsatz auf.

    • Diese Antwort wurde geändert vor 9 Monaten, 4 Wochen von mindyoursoul.

    Wo kommt denn überhaupt & euro; her? Das schreibt doch kein Mensch mehr mit UTF-8 Zeichensatz.

    • Diese Antwort wurde geändert vor 9 Monaten, 4 Wochen von bscu.
    Thread-Ersteller mindyoursoul

    (@mindyoursoul)

    @pixolin @bscu Habt Ihr noch Lösungsvorschläge?

    Thread-Ersteller mindyoursoul

    (@mindyoursoul)

    push

    Moderationshinweis: Bitte lies dir nochmal die Forenregeln durch: Das Pushen von Nachrichten ist hier unerwünscht. Wenn bisher niemand mehr geantwortet hat, hatte vielleicht keiner Zeit oder eine passende Lösung. Manchmal braucht man auch etwas länger, um sich ein Problem genauer anzuschauen und wir müssen alle irgendwie schauen, wie wir das in unserer freien Zeit unterbringen können. Wenn du jetzt sofort, ganz dringend Hilfe benötigst, beauftrage bitte einen Dienstleister.
    Im Wiederholungsfall werden wir das Thema schließen.

    Bei mir ist besteht das gleiche Problem auf zwei völlig unterschiedlichen Websites mit zwei unterschiedlichen Themes: windjana.de und manugrafie.de
    Alle Plugins sind deaktiviert bis auf Woocommerce

    Hier der Bericht einer Website nachdem alle Plugins deaktiviert wurden:

    ### wp-core ###

    version: 5.6
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: undefined
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /mnt/web321/a1/08/53848808/htdocs
    wordpress_size: 63,66 MB (66753229 bytes)
    uploads_path: /mnt/web321/a1/08/53848808/htdocs/wp-content/uploads
    uploads_size: 10,55 MB (11067046 bytes)
    themes_path: /mnt/web321/a1/08/53848808/htdocs/wp-content/themes
    themes_size: 25,51 MB (26744061 bytes)
    plugins_path: /mnt/web321/a1/08/53848808/htdocs/wp-content/plugins
    plugins_size: 93,43 MB (97971651 bytes)
    database_size: 3,53 MB (3702784 bytes)
    total_size: 196,68 MB (206238771 bytes)

    ### wp-active-theme ###

    name: OceanWP (oceanwp)
    version: 2.0.2
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /mnt/web321/a1/08/53848808/htdocs/wp-content/themes/oceanwp
    auto_update: Deaktiviert

    ### wp-themes-inactive (5) ###

    Activello: version: 1.4.2, author: Colorlib, Automatische Aktualisierungen deaktiviert
    Hello Elementor: version: 2.3.1, author: Elementor Team, Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert

    ### wp-plugins-active (1) ###

    WooCommerce: version: 4.8.0, author: Automattic, Automatische Aktualisierungen deaktiviert

    ### wp-plugins-inactive (12) ###

    Akismet Anti-Spam: version: 4.1.7, author: Automattic, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.0.15, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Facebook for WooCommerce: version: 2.2.0, author: Facebook, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Mailchimp for WooCommerce: version: 2.5.0, author: Mailchimp, Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 1.6.9, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Ocean Posts Slider: version: 1.1.0, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Ocean Social Sharing: version: 1.1.0, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Widget Importer & Exporter: version: 1.6, author: ChurchThemes.com, Automatische Aktualisierungen deaktiviert
    WordPress Importer: version: 0.7, author: wordpressdotorg, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.6.4.1, author: WPForms, Automatische Aktualisierungen deaktiviert
    WP Reset: version: 1.82, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-39 Q16 x86_64 2020-12-11 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 76M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 765 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 192
    imagick::RESOURCETYPE_MAP: 765 GB
    imagick::RESOURCETYPE_MEMORY: 383 GB
    imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available

    ### wp-server ###

    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.3.25
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 76M
    curl_version: 7.73.0 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false

    ### wp-database ###

    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54

    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web321/a1/08/53848808/htdocs/wp-content
    WP_PLUGIN_DIR: /mnt/web321/a1/08/53848808/htdocs/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Hat jemand eine Idee, woran es liegen könnte?

    Danke und Gruß
    Manuel

    @invad0r Häng deine Frage bitte nicht an einen älteren, unbeantworteten Thread an. Die Wahrscheinlichkeit, dass du das gleiche Problem hast, ist bei Verwendung eines anderen Theme und anderer Plugins eher unwahrscheinlich. Da du wahrscheinlich auch nicht mit Pauschalantworten zufrieden bist, starte bitte einen neuen Thread. (Ob du dann mit Bick auf die geringen Teilnehmerzahlen überhaupt hier eine Antwort bekommst, ist ein anderes Thema.)

    Alles klar. Danke für die Info:)
    Gruß!

    Hallo, ich habe zwar nicht die Lösung zu dem Problem, aber einen Weg, ihn kurzzeitig zu beheben:

    In der Datei wc-core-functions.php in Plugins/WooCommerce/includes ist hinterlegt, wie das Währungssymbol angezeigt werden soll. Hier findest du mit STRG bzw. CMD + F und den Suchbegriff „euro“ die gewünschte Stelle und kannst das korrekte €-Symbol einsetzen. Lass die Anführungszeichen stehen.

    Die Datei kannst du über Plugins – Plugin-Editor bearbeiten und speichern.

    Diese Änderung kann allerdings durch ein Update von WooCommerce wieder überschrieben werden. Ob das der Fall ist, weiß ich aktuell noch nicht.

    Moderator espiat

    (@espiat)

    Checke mal deinen HTML header, was da drin steht.

    Ausserdem unter WOO Einstellungen einmal schauen, was als Währungssysmbol eingetragen ist. Da einfach nochmal das Euro Symbol vernünftig reinschreiben und speichern.

    Dann hat deine DB:

    DB_CHARSET: utf8mb4

    Auch hier mal einen Abgleich machen ob in der wp-config.php ein extra charset angegeben ist.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Woocommerce Euro als code dargestellt“ ist für neue Antworten geschlossen.