Support » Plugins » woocommerce germanized CSS bearbeiten

  • Gelöst KarenKoehler

    (@karenkoehler)


    Einen schönen guten Abend,

    ich suche ziemlich verzweifelt, die Stelle, wo ich das CSS bei woocommerce germanized ändern kann. Die checkout-Nachrichten auf der „Kasse“-Seite sind nämlich mit „Du“ formuliert. Ich möchte das gern mit „Sie ersetzen“.

    Wäre super, wenn mir da jemand helfen könnte.
    Vielen Dank und einen schönen Abend.
    Karen

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 47)
  • Das ist eigentlich keine Aufgabe für CSS, sondern hängt davon ab, welche Sprache du unter Einstellungen > Allgemein ausgewählt hast. Hier solltest du bei „Sprache der Website“ statt „Deutsch“ die formelle Variante „Deutsch (Sie)“ auswählen.

    Es kann natürlich vorkommen, dass Sprachdateien fehlerhaft sind und ein Übersetzer die formelle und informelle Anrede durcheinandergebracht hat. Du kannst dir dann zwar mit jQuery behelfen, aber besser wäre eine Korrektur der Sprachdatei.

    Übrigens wäre es toll, wenn du uns ein paar weitere Informationen zu deiner Website lieferst – z.B. einen Link zur Webseite, auf der wir uns das anschauen können.

    Hallo Karen und Bego,

    da ich selbst WooCommerce nicht nutze, hab ich mir mal ein virtuelles Produkt angelegt und es in den Warenkorb gelegt. Ebenso in Karens Shop.

    Bei Karen heißt es dann an der Kasse:
    „Hast du einen Gutschein? Klicke hier, um deinen Gutschein-Code einzugeben.“
    bei mir hingegen (wie gewünscht, entsprechend der formellen Variante Deutsch (Sie):
    „Haben Sie einen Gutschein? Klicken Sie hier, um Ihren Gutschein-Code einzugeben.“

    Das heißt für mich, dass die aktuelle WooCommerce-Sprachdatei an dieser Stelle korrekt übersetzt ist, bei Karen aber, obwohl sie anscheinend ebenfalls die formelle Deutsch-Variante eingestellt hat (sonst würde sie sich wohl nicht an der Kasse über das „Du“ wundern, denke ich mal), offenbar die informelle Übersetzungsdatei geladen wird.

    Ich habe mal das Plugin „Query Monitor“ aktiviert und demnach sieht es so aus, dass für die fragliche deutsche (formelle) Übersetzung die Datei
    wp-content/languages/plugins/woocommerce-de_DE_formal.mo
    geladen wird. Dort steht die gewünschte Übersetzung.

    An Karens Stelle würde ich jetzt mal als erstes überprüfen, ob die Datei
    woocommerce-de_DE_formal.mo
    und ihr Pendant
    woocommerce-de_DE_formal.po
    denn bei ihr auch in dem genannten Pfad
    wp-content/languages/plugins/woocommerce-de_DE_formal.mo bzw.
    wp-content/languages/plugins/woocommerce-de_DE_formal.po
    zu finden sind.

    Falls nicht, würde ich die beiden genannten Dateien mal an diese Stelle (also in den Ordner wp-content/languages/plugins schieben und die Seite aktualisieren. Falls das nichts bringt, muss man mal weitersehen.

    • Diese Antwort wurde geändert vor 3 Jahre, 5 Monate von Flower33. Grund: Tippfehler

    … sonst würde sie sich wohl nicht an der Kasse über das „Du“ wundern, denke ich mal …

    Das ist sehr hypothetisch. 😉

    Hallo Bego und flower33,

    vorab natürlich viele superherzliche Danke-Schön.
    Ihr seid meine wordpress-Helden :-))
    Die Seite, um die es geht und die ich heute online stelle – wenn alles gut geht –
    lautet http://www.nicecards.masterspot.de. Wenn sie online ist, wird sie nur http://www.nicecards.de heißen.
    Und nun werde ich eure Anleitungen Schritt für Schritt durchgehen.
    Ich bin ja nicht so richtig die wordpress-Heldin ;-).
    Was könnte ich denn als Danke-Schön für euch tun? Es ist ja heute nicht mehr selbstverständlich, dass Menschen Ihre Zeit für andere spendieren.

    Ich melde mich noch einmal, ob es klappt oder ich es hingekriegt habe.
    Viele liebe Grüße
    Karen

    Also,
    ich habe unter Einstellungen > Allgemein die „Sie“-Variante ausgewählt. Jetzt ist alles englisch außer der Anrede.
    Und es wird folgende Meldung angezeigt:

    „Hinweis: Die Konstante WPLANG in Ihrer Datei wp-config.php wird nicht länger benötigt.

    Notice: define() wurde mit einem Parameter oder Argument aufgerufen, der seit Version 4.0.0 veraltet ist! Die Konstante WPLANG in Ihrer Datei wp-config.php wird nicht länger benötigt. in /www/htdocs/w0081ecb/www.masterspot.de/wp/wp-includes/functions.php on line 3891“.

    Ich habe genau diese line aufgerufen, finde dort aber in meiner Datei in dieser Zeile folgedes:
    „trigger_error( sprintf( __(‚%1$s was called with an argument that is deprecated since version %2$s! %3$s‘), $function, $version, $message ) );“

    Ist es das, was ich entfernen soll? Oder habe ich irgendetwas falsch gemacht?

    Vielen Dank noch einmal für eure Hilfe.
    Karen

    Moderator espiat

    (@espiat)

    NICHTS in der wp-includes/functions.php ändern. Das ist eine Coredatei. Die wird eh beim kommenden update überschrieben. Ich glaube flower33 weiß jetzt genau, was zu tun ist und er darf die Belohnung einstreichen.

    Hallo flower33,

    erst mal vielen Dank und hier meine Anerkungen:

    „An Karens Stelle würde ich jetzt mal als erstes überprüfen, ob die Datei
    woocommerce-de_DE_formal.mo
    und ihr Pendant
    woocommerce-de_DE_formal.po
    denn bei ihr auch in dem genannten Pfad
    wp-content/languages/plugins/woocommerce-de_DE_formal.mo bzw.
    wp-content/languages/plugins/woocommerce-de_DE_formal.po
    zu finden sind.

    Die Dateien habe ich nicht gefunden.

    Falls nicht, würde ich die beiden genannten Dateien mal an diese Stelle (also in den Ordner wp-content/languages/plugins schieben und die Seite aktualisieren. Falls das nichts bringt, muss man mal weitersehen.

    Wenn die beiden Dateien also nicht dort sind, wo sind sie dann? Denn um sie zu verschieben, müssen sie ja irgendwo sein.

    Danke dir noch einmal für deine Hilfe.
    Viele Grüße
    Karen

    Vielen Dank espiat; ich lasse also meine Finger davon und habe gerade auch eine Antwort an flower33 bezüglich seiner Empfehlung geschrieben.

    Liebe Grüße
    Karen

    ich habe unter Einstellungen > Allgemein die „Sie“-Variante ausgewählt. Jetzt ist alles englisch außer der Anrede.

    Da sind die Sprachdateien wahrscheinlich noch nicht geladen. Geh mal auf Aktualisierungen und schau, ob da neue Übersetzungsdateien angeboten werden.

    Manchmal gibt es auch das Problem, dass Plugins nur informell übersetzt wurden. Damit dann nicht Englisch als Rückfall-Wert angezeigt wird, könntest du das Plugin von Bernhard installieren:

    https://wordpress.org/plugins/language-fallback/

    „Hinweis: Die Konstante WPLANG in Ihrer Datei wp-config.php wird nicht länger benötigt.

    Das ist nur ein Hinweis (steht ja auch da 😀 ). Du kannst die Zeile define('WP_LANG'.'de_DE'); löschen oder mit zwei vorangestellten Backslash \\ auskommentieren. (Bitte einen gescheiten Editor wie z.B. Atom Editor – nicht Notepad – verwenden.)

    Hi Bego,

    super, das hat geklappt mit dem plugin. Vielen vielen Dank.
    Und jetzt funktioniert es auch. 🙂

    Zwei Fragen hätte ich noch: die language fallback settings unter Allgemein sind auf englisch gesetzt. Kann ich sie auf deutsch setzen?

    Und dann ist der Hinweis natürlich „nur“ ein Hinweis (ich wittere gleich immer etwas zu tun ;-)). Nichtsdestotrotz habe ich die entsprechende line nicht gefunden.
    Einen Editor brauche ich eigentlich nicht, weil ich das direkt über ftp bei allinkl mache.

    Danek dir noch einmal. Und auch für den Tipp für den Editor. Ich habe sciptly. Schaue aber noch einmal nach dem Atom Editor.

    Viele Grüße
    Karen

    Beim Plugin Language Fallback stellst du ein, auf welche Sprache WordPress zurückgreifen soll, wenn es keine Übersetzung findet. Statt English wählst du dann das informelle „Deutsch“.

    Hallo zusammen,

    sorry, komme erst jetzt dazu, hier wieder reinzuschauen.

    Karen,

    könntest du bitte im Dienste der Wissenschaft 🙂 testweise das Plugin „Language Fallback“ mal für ein paar Minuten deaktivieren und die Website aktualisieren? Ist dann die formelle (Sie) Übersetzung an der Kasse wieder weg oder ist sie weiterhin da?

    Hallo Bego,

    danke dir, das mache ich dann so. :-))

    Hallo flower33.

    Da ich ja sonst nix tun kann, weil wordpress-Grundschüler mache ich das natürlich gerne.
    Allerdings habe ich gerade eine Email an einen größeren Verteiler geschickt, und über meine Seite informiert. Dann muss ich gleich auf einen Job: ergo. Das schaffe ich erst morgen, mache ich aber auf jeden Fall und lasse diesen case deshalb noch offen.

    Viele Grüße
    Karen

    Hallo Karen,

    keine Eile, Hauptsache, du meldest dich noch mal mit dem Ergebnis. 🙂
    Ich werde im Laufe des Tages oder Abends auch noch ein paar Anmerkungen bzw. Überlegungen zusammenstellen, die mir fürs allgemeine Verständnis dieses Threads (auch für spätere Ankömmlinge hier) noch nötig erscheinen und die meine Rückfrage bzgl. des Plugins erklären.

    :-))

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 47)
  • Das Thema „woocommerce germanized CSS bearbeiten“ ist für neue Antworten geschlossen.