Support » Installation » WordPress mit woocommerce nach Domainumzug weiterverwenden

  • Gelöst haiflosse2

    (@haiflosse2)


    Hallo!
    Ich hatte eine wordpress Seite mit woocommerce verwendet.
    Die Domain dieser Seite ist aber zu einen anderen Provider zu einem magento shop umgezogen.
    Die WordPress Seite habe ich in einem Unterordner erstellt.
    Daher wollte ich fragen, wie ich meine WordPress Seite wieder verwenden kann.
    Wie ich meine Unterseite jetzt öffne: hochl-it.at/agoshop oder das Backend hochl-it.at/agoshop/wp-admin dann erhalte ich folgende Meldung:

    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

    Erfahre mehr über die Fehlerbehebung in WordPress.

    Die Seite hat früher auch eine ssl Verschlüsselung verwendet. D.h. die url lautete https://xxxx
    Diese ssl Verschlüsselung habe ich aber auf der Unterseite hochl-it.at/agoshop nicht mehr.

    Hoffe es kann mir jemand weiterhelfen.
    Vielen Dank

    • Dieses Thema wurde geändert vor 5 Monaten von haiflosse2.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Moderator Bego Mario Garde

    (@pixolin)

    Welche URL ist denn in der Datenbanktabelle wp_options als siteurl und home eingetragen? Rufe ich unter der angegebenen URL wp-json auf, sehe ich eine Website, die mit Dreamweaver erstellt wurde. Vielleicht stimmen auch die Pfade der aktuell zugewiesenen Domain nicht? (Im Kundenmenü des Webhosters prüfen.)

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Hallo!
    Danke für die Antwort.
    Ich habe nun die siteurl und home auf agoshop.hochl-it.at.
    die Seite wird nun wieder aufgerufen. Nur passt da meiner Meinung nach das css bzw. das Template noch nicht ganz.

    Auch das Backend kann er noch nicht finden.
    Beim Aufruf von agoshop.hochl-it.at/wp-admin erhalte ich:
    Die Seite konnte leider nicht gefunden werden

    Hoffe es kann mir hier nochmals jemand weiterhelfen.
    Vielen Dank

    Moderator Bego Mario Garde

    (@pixolin)

    Ich würde als erstes den Cache leeren.

    Auch das Backend kann er noch nicht finden.

    Die Adresse http://agoshop.hochl-it.at/wp-login.php wird aber erkannt.
    Sofern noch eine .htaccess vorhanden ist, solltest du die löschen. Gut möglich, dass dein Cache-Plugin dort Weiterleitungsregeln eingetragen hat, die einiges Durcheinander verursachen. So ein Cache-Plugin solltest du immer deaktivieren, bevor du eine Website umziehst.

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke für die Antwort.
    Ich konnte mich dort auch anmelden.
    Das Problem ist im Backend aber das selbe wie im Frontent, dass das css bzw. das Template nicht erkannt wird.
    Ich habe dort nur eine Textseite ohne Grafische Darstellung.
    Was konnte da noch die Ursache sein?
    Hoffe es kann mir jemand nochmals weiterehelfen.
    Vielen Dank

    Hallo,
    deine Webseite hat z. Zt. keine SSL-Verschlüsselung. Das solltest du mit deinem Hoster besprechen und ein SSL-Zertifikat einrichten.
    Wenn du in die developer console (F12 bei Chrome) schaust und auf das Register network gehst und anschließend die die Seite noch mal lädst, dann kannst du sehen, dass viele Dateien im Ordner .../wp-content/cache/wpfc-minified liegen. Ich habe den Eindruck, dass du noch WP Fastest Cache aktiviert hast. Deaktiviere doch mal dieses Plugin und teste das dann noch mal.
    Sollte das Problem weiterhin auftreten, lösche bitte nach einer Sicherung der Datenbank bei deaktiviertem WP Fastest Cache auch den Ordner .../wp-content/cache/ (also nur den Unterordner „cache“).
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Ich bekomme in der Konsole der Entwickler-Tools angezeigt:

    Die Ressource von "https://agoshop.at/wp-content/cache/wpfc-minified/eus8d6gt/44d71.css" wurde wegen eines MIME-Typ-Konfliktes ("text/html") blockiert (X-Content-Type-Options: nosniff)

    Die Website versucht also mit einer verschlüsselten Verbindung auf eine im Cache vorgegebene CSS-Datei zuzugreifen, die es vermutlich an dieser Stelle nach der Einrichtung der Subdomain gar nicht mehr gibt.

    Wie Hans-Gerd schon geschrieben hat: Cache entfernen. Notfalls manuell. Also …

    • Backup von Dateien und Datenbank erstellen
    • Verzeichnis wp-content/plugins/wp-fastest-cache löschen
    • Verzeichnis wp-content/cache löschen
    • in .htaccess den Block, der mit # BEGIN WpFastestCache beginnt und mit # END WpFastestCache endet, löschen.

    Außerdem auch den Browser-Cache leeren, Cookie löschen.

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke für die Antworten.
    Das Plugin kann ich nicht deinstallieren bzw. deaktivieren, da im Browser es nicht möglich ist den Menüpunkt Chache aktivieren zu deaktivieren.

    Ich habe dann alle Verzeichnisse gelöscht und den Eintrag in der Datei .htaccess herausgelöscht.

    Auch habe ich im Browser den Chache und Cookies gelöscht.
    Leider hat sich aber nichts geändert.
    Hoffe es hat noch jemand eine Idee dazu.
    Danke

    Hallo,
    ich verstehe nicht was du meinst: du kannst doch über das Dashboard das Plugin deaktivieren.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke für die Antwort.
    Leider habe ich im Dashboard keine Menüstruktur mehr.
    Mein Dashboard sieht z.B. wie folgt aus:
    https://www.dropbox.com/s/1djyg17fe68r1u9/dashboard.png?dl=0

    Da ich die Ordner gelöscht habe, konnte ich einen Text finden, dass das plugin zu wp-fastest-cache deaktiviert wurde.

    Hoffe es kann mir jemand weiterhelfen.
    Danke

    Moderator Bego Mario Garde

    (@pixolin)

    Schau bitte nochmal in die Datenbank. In der Datenbanktabelle wp_options müssen die URLs in den Felder siteurl und home mit dem „Schema“, also mit vorangestelltem http:// eingegeben sein. Das scheint im Moment nicht zu passen.

    Im Moment werden (vermutlich aufgrund dieses Fehlers) ganz viele Dateien unter http://agoshop.hochl-it.at/agoshop.hochl-it.at/wp-content/uploads/… aufgerufen – da ist die Domain jetzt zweimal drin. Vielleicht hast du dich auch beim Suchen/Ersetzen vertan?

    Wir sprechen hier eigentlich über einen Vorgang, der in zehn Minuten abgeschlossen sein sollte. Wenn es so gar nicht klappt, solltest du dir einen Dienstleister suchen, der sich auch die Dateien auf dem Server und die Einträge in der Datenbank anschaut – da haben wir (ganz bewusst) keinen Zugang zu und können entsprechend auch nur in einem gewissen Rahmen helfen.

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke für die Antwort.
    Das WordPress Projekt habe ich am ftp in einem Ordner agoshop erstellt.
    Am Webhost habe ich eine subdomain agoshop.hochl-it.at eingetragen, die auf den Ordner agoshop zeigt.
    in der Tabelle wp_otions habe ich bei siteurl und home http://agoshop.hochl-it.at eingetragen.
    Jetzt bekomme ich aber keine Seite mehr angezeigt, sondern den Fehler 500:

    
    Serverfehler!
    Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.
    
    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    
    Error 500
    agoshop.hochl-it.at
    Tue Jun 29 23:41:00 2021
    Apache
    

    Hoffe es hat noch jemand eine Idee.
    Vielen Dank

    Moderator Bego Mario Garde

    (@pixolin)

    Die Fehlermeldung „500 – Internal Server Error“ beschreibt erst einmal nur, dass ein Fehler aufgetreten ist, aber nicht, was die Ursache ist. Damit soll verhindert werden, dass Angreifer auf mögliche Sicherheitslücken hingewiesen werden. Mehr Informationen erhältst du im Error-Log des Webservers, in dem die Ursachen protokolliert werden.

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke für die Antwort.
    Laut Log sollte es einen Fehler in der .htaccess Datei geben.
    Der Inhalt sieht aktuell wie folgt aus:

    
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase agoshop.hochl-it.at/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . agoshop.hochl-it.at/index.php [L]
    </IfModule>
    
    # END WordPress
    

    Alte htaccess Dateien habe ich bevor ich sie geändert bzw. gelöscht habe gesichert.

    Danke für eine weitere Hilfe

    • Diese Antwort wurde geändert vor 5 Monaten von haiflosse2.
    • Diese Antwort wurde geändert vor 5 Monaten von haiflosse2.
    Moderator Bego Mario Garde

    (@pixolin)

    Ändere mal RewriteBase agoshop.hochl-it.at/ in RewriteBase / und
    RewriteRule . agoshop.hochl-it.at/index.php [L] in RewriteRule . /index.php [L].

    Thread-Ersteller haiflosse2

    (@haiflosse2)

    Danke!
    Die Seite kann ich jetzt wieder öffnen.
    Der doppelte Link ist aber noch immer im Link und das Backend hat sich leider auch noch nicht geändert.

    Ich habe da schon überall gesucht.
    Vielleicht kann mir jemand noch einen Tip geben.
    Danke und lg

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)