Support » Allgemeine Fragen » WordPress 4.2 Mediathek: Bei dem Upload ist ein Fehler aufgetaucht.

  • Für allen, hier nochmal ganz klar beschrieben um was für ein Problem es genau geht:

    Fehlermeldung: „Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.“

    Bei WordPress 4.2.x funktioniert die Mediathek nicht mehr richtig. Bilder die man über die Mediathek oder in Beiträgen hochladen will, werden nicht in der Mediathek angezeigt um diese dann in den Beitrag einzufügen. Die Bilder werden zwar hochgeladen (wp-content/uploads)können in der Mediathek aber nicht genutzt werden, weil sie dort nicht angezeigt werden.

    Aus meiner Sicht muss es sich um ein WordPress Problem handeln und nicht um ein PHP oder Hoster Problem. Ich bin weder bei Strato noch bei 1und1. Bei mir tritt dieses Problem sowohl bei einer Online Installation, als auch bei einer Installation auf einem lokalen Server auf, es liegt also nicht an der neusten PHP Version, denn die habe ich (PHP 5.6), es liegt auch nicht am mangelnden Server Speicher denn ich habe 128MB was völlig ausreichend ist.

    Ich habe mehrere WordPress Webseiten beim gleichen Hoster, sogar unter der gleichen IP, aber nur bei einer tritt seit kurzem dieser „spezielle“ Fehler auf.

    Lösungen die bei mir NICHT funktioniert haben:

    – Alle Plugins deaktivieren
    – wp-config.php mit den Befehlen define(WP_TEMP_DIR….wp-content) und define(WP_MEMORY_LIMIT…) „modifizieren“
    – Plugin: „resize images before upload“ installieren
    – Plugin: „Add From Server“ nutzen
    – .htaccess Datei löschen
    – verschiedene Browser verwenden
    – WP Verzeichnisrechte per FTP auf 755 bzw. 777 ändern

    Auch mein Hoster konnte mir bis jetzt nicht weiterhelfen, ich bin echt am verzweifeln, wenn ich keine Lösung finden bleibt mir wohl nichts anderes übrig, all die komplette Webseite neu aufzusetzen 🙁

    Ich hoffe auf eure Hilfe.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Edi

    (@psychosopher)

    es liegt auch nicht am mangelnden Server Speicher denn ich habe 128MB

    Serverspeicher oder Memory Limit? 128 MB Speicherplatz für eine WordPress-Installation mit ein paar Plugins und Bildern, wäre etwas wenig.

    So oder so: Hast Du noch genug Speicherplatz?

    Beim Hoster habe ich unbegrenzten Speicher (also mehrere GB) und 128 MB Arbeitsspeicher wurde der Webseite zugewiesen die auf PHP 5.4.38 läuft. Die Webseite selbst hat ca. 40 MB, also nicht wirklich viel. Auf meinem lokalen Server (PHP 5.6.2) habe ich 1000GB Speicherplatz und auch 128MB Arbeitsspeicher über PHP für den Server zugewiesen.

    JA Speicher habe ich mehr als genug, ich denke nicht das es daran liegt.

    Auch Bilder die ich bereits schon mal auf die Webseite hochgeladen habe, lassen sich nicht mehr hochladen. Es liegt also auch nicht an den Bilder und den Pixeln und der größe der Bilder den die haben nur 100 – 200 KB und ca. 500×300 Pixel.

    Edi

    (@psychosopher)

    Nächste Frage:

    WP Verzeichnisrechte per FTP auf 755 bzw. 777 ändern

    Kannst Du die auch im Admin-Bereich des Hostings ändern? Nicht immer genügen die Rechte des FTP-Clients.

    Beides.

    Der Hoster hat alle Rechte auf 777 gestellt um zu sehen ob das Problem von WordPress an den Zugriffsrechten liegt oder nicht. Lag aber nicht an den Zugriffsrechten. Ich kann die Zugriffsrechte auch selbst beim Hoster einstellen. Das habe ich schon ausgetestet, leider ohne Erfolg.

    Ich habe die komplette WordPress Installation + Datenbank heruntergeladen und die komplette Webseite lokal auf meinem iMac über MAMP installiert, hier zeigt sich genau der gleiche Fehler, wie kann das sein? Irgendwie muss diese WordPress Installation bzw. Webseite einen Fehler haben.

    Wenn der Fehler nicht lokalisiert und gefunden wird komme ich wohl um einen neue Installation nicht herum, das ist aber leider viel viel Arbeit 🙁

    Edi

    (@psychosopher)

    Wir gross ist die maximale Dateigrösse für Uploads?

    Kannst Du vielleicht die Adresse der Website angeben?

    Die Seite ist: http://www.ballicu-sanierung.de

    Maximaler Upload für Dateien beim Hoster und online Installation sind lt. WordPress Installation 8 MB (Angabe aus der Mediathek).

    Bei meiner lokalen Installation sind es 32 MB.

    Edi

    (@psychosopher)

    Was ist, wenn Du die WordPress-Files noch einmal lädst? Vielleicht ist da etwas beschädigt.

    Ich würde versuchen, zuerst mit dem Duplicator, und wenn das nicht geht einem Backup, die Website auf einem „neuen“ Webspace mit neuer Datenbank zu installieren.

    Ich habe die Webseite mit dem Duplicator Plugin auf meinen lokalen Server geladen und habe das gleiche Problem. Aber ich werde Morgen ein Backup auf eine Subdomain hochladen und ein wenig testen. Ich lege zuerst eine neue Datenbank an und prüfe ob der Upload in der Mediathek funktioniert, dann importiere ich die alte Datenbank. Ich habe mehrere Backupdateien zur Verfügung die ich mit dem Plugin BackWPup auf Dropbox geladen habe. Sobald ich neue Erkenntnise haben und weiß woran es gelegen hat, werde ich es hier posten.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Bilder die man über die Mediathek oder in Beiträgen hochladen will, werden nicht in der Mediathek angezeigt

    Nur um sicher zu gehen: Werden die Bilder überhaupt nicht in der Medathek angezeigt (es wird kein Eintrag erzeugt) oder gibt es einen Eintrag, aber das Vorschaubild/Bild wird darin nicht angezeigt?

    Wenn letzteres: Was passiert bei einem Direktaufruf des Bildes? Gibt es eine Fehlermeldung?

    Hast Du mal lokal (da tritt der Fehler ja auch auf) den Debug-Modus aktiviert?
    http://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

    Gruß, Torsten

    Das Problem hat etwas mit der MySQL Datenbank zu tun.

    Ausgangs Situation: Ich sah die „alten“ Bilder in der Mediathek, aber Bilder die ich neu hochgeladen habe, sah ich nicht. Die neuen Bilder wurden aber in den Ordner wp-content/uploads gespeichet.

    Nachdem ich in der Datenbank in der Tabelle wp-1options in der Zeile: image_default_link_type den Wert „file“ eingetragen hatte, weil dieser Wert bei der funktionierenden Installation drin stand, verschwanden in der Mediathek auch alle „alten“ Bilder obwohl sie noch im Ordner wp-content/uploads da waren. Für mich ein Rätsel. Das Problem ließ nich dann auch nicht mehr Rückgängig machen, nachdem ich den Wert wieder entfernt hatte.

    phpMyAdmin Datenbankfehler:

    Fehlermeldung bei phpMyAdmin: Die aktuelle Markierung enthält keine eindeutige („unique“) Spalte. Gitter-Bearbeitungsfunktion, Kontrollkästchen, Bearbeiten, Kopieren und Löschen von Links sind nicht verfügbar.

    Fehlermeldung bei WordPress (WP_DEBUG true): WordPress database error: [Duplicate entry ‚0‘ for key ‚PRIMARY‘]

    In Foren habe ich über das Thema UNIQIE KEY und PRIMARY KEY gelesen, aber das ganze hat mich nur noch mehr verwirrt und nicht wirklich weitergebracht.

    Meine eigene Lösung:

    Ich habe auf meinem lokalen Server (iMac) eine älteres Backup der Webseite installiert und siehe da alles funktioniert prima. Ich muss nur die fehlenden Artikel und Änderungen nachtragen, aber das ist zum Glück nicht so viel. Damit endet für mich die Suche nach dem genauen Fehler und dem WARUM, irgendwie ist die Datenbank fehlerhaft, keine Ahnung warum und wie und da ich keine große Ahnung von MySQL habe um die Datenbank zu reparieren, endet der Beitrag für mich hier.

    Meine Lösung und mein Tipp für alle: Regelmäßig Backups machen!!! Ich nutze dazu das kostenlose Plugin: BackWPup und Dropbox. Zusätzlich kopieren ich mir immer wieder mal die Backups von Dropbox auf meinen PC und eine externe Festplatte. Mit einem funktionierenden Backup kann man die Webseite im Notfall wiederherstellen und anpassen (Permalink, Theme Einstellungen, Einstellungen von einzelenen Plugins usw.)

    das kann es nicht sein.. sitze jetzt auch mit dem fehler da.
    was für ein scheiß.. das kann es doch nicht sein.. das nach eine update fehler auftauchen.. boa zuerst soll man updates wegen der sicherheit machen und jetzt sitzt man mit so einem mist da.
    gibt es keine andere lösung? ich denke auch das an der mysql liegt. ich hab es nicht geschaft dieses debug modus. obwohl ich
    in die wp-config.php eingetragen habe.
    // Enable WP_DEBUG mode
    define( ‚WP_DEBUG‘, true );

    // Enable Debug logging to the /wp-content/debug.log file
    define( ‚WP_DEBUG_LOG‘, false );

    // Disable display of errors and warnings
    define( ‚WP_DEBUG_DISPLAY‘, true );
    @ini_set( ‚display_errors‘, 1 );

    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( ‚SCRIPT_DEBUG‘, true );
    wenn ich genau wüsste wo dieser fehler in der mysql wäre könnte man es mit eine klick entfernen und die ganze neuinstallation ersparen..
    1-2 wochen arbeit pfutsch.. hätte ich mal ein backup gemacht.. argh
    an die wordpress profis.. bitte um hilfe alternative lösung.

    Habe seit gestern dasselbe Problem und noch andere. Ich habe sämtliche Plugins deaktiviert und viele andere Dinge probiert, es nützte nichts. Folgendes funktioniert nicht mehr, möglicherweise seit dem Update von Woocommerce auf die neueste Version, ich bin nicht sicher, seit wann.
    1: Themes können nicht mehr im Admin-Bereich hinzugefügt werden, nur wenn ich sie manuell (ftp) hochlade, werden sie angezeigt und ich kann sie auch installieren. Wenn ich im Admin-Bereich auf „Neues Theme hinzufügen“ klicke, erhalte ich diese Meldung: „Ein unerwarteter Fehler ist aufgetreten. Das könnte an WordPress.org oder der Konfiguration dieses Servers liegen. Sollten Sie weiterhin Probleme haben, wenden Sie sich an den Support.“
    2: Beim Installieren von zB Plugins (ich deaktivierte ja alle nach und nach und aktivierte dann einige wieder, weil es nichts brachte) kommt nach dem Klick auf „Aktivieren“ eine leere weiße Seite,die auch nicht mehr weggeht. Ich muss dann „zurück“ klicken und bin wieder im Admin-Bereich und dann sind die Plugins aktiviert.
    3: Mediathek zeigt Bilder nur als Liste an. Wäre nicht schlimm, aber wenn ich ein Produkt hinzufügen möchte und auf Galerie gehe um die Bilder auszuwählen, ist die Mediathek komplett leer und die Sanduhr bewegt sich unaufhörlich.
    4: Meine Bilder/Daten scheinen unbeschädigt und sind über FTP erreichbar im wp-content Ordner.
    Meine WP Version: 4.4.2 Woocommerce 2.5.5
    Meine WP Adresse (ist nur eine vorläufige Testseite, aber ich möchte sie wirklich endlich bald richtig füllen können und sie soll auch dort bleiben auf diesem Host usw.) webijou.com/wonnereich
    Meine Datenbank – Memory ist auf höchstmögliche gestellt (128, 64M)
    Soll ich komplett neu installieren?
    Vielen Dank für Hilfe!

    PS: Andere Dinge, die ich ohne Erfolg probierte waren etwa (kann mich nicht an alles erinnern):
    Neuer Upload von wp-admin Ordner (dem von der alten noch funktionierenden Version von vorgestern)
    Dasselbe mit dem wp-Themes-Ordner in wp-content
    Das Theme 2016 aktiviert, andere Themes probiert und wieder die WP-Themes, auch 2015. Nützte alles nichts.
    Hatte natürlich auch Woocommerce komplett deaktiviert gehabt, aber auch das half nichts.
    Außerdem habe ich sogar die Berechtigungen hinaufgesetzt auf – glaube 777 =schreiben, lesen für Gruppen,allerdings nicht für „alle“ bzw. „öffentlich“, das habe ich nicht gemacht. Nur für mich und „Gruppen“ oder so. Kann aber genau im ftp nachsehen, wie das heißt, falls es jemanden interessiert. Ich würde dies niemandem empfehlen, bitte tun Sie das nur, wenn ein WP-Supportmitarbeiter oder Entwicklerin Ihnen dies empfiehlt. Ich bin das nicht und weiß nur, dass dies zu schweren Problemen führen kann und man muss damit sehr vorsichtig sein.

    das ist so krass. nach dem erneut selbe update und bereinigung der mysql tabelle mit phpmyadmin. läuft es heute.. verstehe ich nicht, aber es geht.. supi.

    was für ein scheiß.. das kann es doch nicht sein.. das nach eine update fehler auftauchen.. boa zuerst soll man updates wegen der sicherheit machen und jetzt sitzt man mit so einem mist da.

    das ist so krass. nach dem erneut selbe update und bereinigung der mysql tabelle mit phpmyadmin. läuft es heute

    Boa, ey, is ja voll krass, alda!
    Nee, im Ernst, ist ja erfreulich! 😉

    @claraquin: Am besten machst du einen neuen Thread auf und kopierst deine Problemschilderung dorthin, da kann gezielter auf deine spezielle Situation eingegangen werden – besser, als sich an einen Uralt-Thread dranzuhängen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Das Thema „WordPress 4.2 Mediathek: Bei dem Upload ist ein Fehler aufgetaucht.“ ist für neue Antworten geschlossen.