Support » Allgemeine Fragen » WordPress 6.1 Problem : es werden keine Seiten mehr gefunden

  • Gelöst Andreas

    (@andreas2021)


    Hallo,

    ich habe gerade auf WordPress 6.1 aktualisiert.
    update:
    es werden überhaupt keine Seiten mehr gefunden!
    Kann ich zurück zur vorherigen Version?

    • Dieses Thema wurde geändert vor 1 Jahr, 3 Monaten von Andreas.
    • Dieses Thema wurde geändert vor 1 Jahr, 3 Monaten von Andreas.
    • Dieses Thema wurde geändert vor 1 Jahr, 3 Monaten von Andreas.
Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Thread-Starter Andreas

    (@andreas2021)

    Beim Aufruf einer Seite erscheint in der Adresszeile die korrekte Adresse. Die Seite wird jedoch nicht angezeigt. Es kommt die Meldung:

    Server Error
    404
    Page Not Found
    This page either doesn't exist, or it moved somewhere else

    Ein Serverfehler erscheint mir aber unwahrscheinlich. Bis zur Aktualisierung auf WP6.1 funktionierte alles perfekt.

    Unter „Werkzeuge“ fand ich folgendes:

    Das REST-API kam zu einem unerwarteten Ergebnis 
    Das REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Der Bildschirm des Block-Editors beispielsweise stützt sich auf die REST-API, um deine Beiträge und Seiten anzuzeigen und zu speichern.
    
    Beim Testen des REST-API wurde ein unerwartetes Ergebnis zurückgegeben:
    
    REST-API-Endpunkt: https://www.steinszeit.de/wp-json/wp/v2/types/post?context=edit
    REST-API-Antwort: (404) Not Found
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Andreas.
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Andreas.
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Andreas.

    Kann ich zurück zur vorherigen Version?

    Klar. Das ist zwar nicht der empfohlene Weg, aber möglich.
    Oder was wolltest du jetzt wissen?

    Thread-Starter Andreas

    (@andreas2021)

    Meine Website zeigt keine Unterseiten mehr an. Dieses Problem besteht seit der Aktualisierung auf 6.1. Vorher funktionierte alles perfekt.
    Ich möchte die website wieder zum Laufen bringen. Derzeit geht kein Seitenaufruf.

    Meine Website zeigt keine Unterseiten mehr an.

    Das hast du bereits geschrieben.

    Ich möchte die website wieder zum Laufen bringen.

    Das überrascht mich auch nicht. (Dafür aber, dass du dann keine URL zur Website angibst, keinen Website-Bericht und auch sonst keine Informationen zum Webhoster, verwendeter PHP-Version usw.)

    Derzeit geht kein Seitenaufruf.

    Das hast du bereits geschrieben.

    Und jetzt?

    Wenn du tatsächlich meinst, es liegt an der WordPress-Version (was ich bezweifele), kommt es darauf an, ob du ins Backend kommst (Rollback per Plugin) oder nicht (manuelles Downgrade).

    Thread-Starter Andreas

    (@andreas2021)

    Sorry Bego, bin etwas aufgeregt.

    Die webseite ist „steinszeit.de“. Hatte ich vorhin vergessen.
    Der Fehler stellte sich erst so dar, dass ich nach dem Bearbeiten die Seite nicht speichern konnte. Da eröffnete ich den thread. Erst später stellte ich fest, dass kein Seitenaufruf mehr funktioniert.
    Auf die wordpresseite (backend) komme ich, ich kann dort auch die Seiten anzeigen lassen. Ebenso funktioniert die Startseite. Nur der Aufruf der Seiten funktioniert nicht.
    Beim Abspeichern einer Seitenänderung kommt die Fehlermeldung:
    „Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.“
    Ich habe in meinem ersten thread (den ich aus obigem Grund mehrfach änderte) noch eine Fehlermeldung geschrieben, die bei „Werkzeuge“ angezeigt wird.

    Wo finde ich den website-Bericht?

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Andreas.

    Panik ist immer schlecht. Statt direkt loszutippen, hättest du dich zuerst ein paar Minuten umsehen und den angehefteten Beitrag lesen sollen:

    Beitrag Bevor du einen Thread erstellst

    Da du meinst, dass das Problem zwingend mit dem WordPress-Update zusammenhängt (ich bin mir da wie gesagt nicht so sicher), ist ein Rollback auf die vorherige Version wohl sinnvoll. Da du auf das Backend zugreifen kannst, installier bitte das Plugin Core Rollback, geh dann in das Menü Werkzeuge > Core zurücksetzen und wähle die Version 6.0.3. Klick auf Zurücksetzen und bestätige auf der Folgeseite, dass du WordPress 6.0.3 erneut installieren möchtest.

    Gib uns dann eine Rückmeldung, dass das alles nichts gebracht hat und deine Website weiterhin nicht funktioniert, damit wir der eigentlichen Ursache auf den Grund gehen können.

    … inzwischen klappt es ja wieder. Woran hat’s denn nun gelegen?

    Thread-Starter Andreas

    (@andreas2021)

    Hallo Bego,

    ja Ruhe bewahren ist ja oK. Ich habe mich auch in der Zwischenzeit etwas bei wordpress belesen und konnte das Problem selbst klären. Dort steht was mit den Error 404 und permalinks. Ich habe die dort gesetzte Einstellung nochmal bestätigt und nun funktioniert es wieder. Die Permalinks hatten sich irgendwie verstellt.

    Danke dennoch, nächstes Mal bleibe ich ruhiger.

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Andreas.

    Halten wir fest: kein Problem mit der neuen WordPress-Version. 😀

    Schön, dass es wieder läuft und Danke für die Rückmeldung.

    Thread-Starter Andreas

    (@andreas2021)

    Leider kann ich das Thema nicht mehr ändernn – schade.

    Das ist nicht schlimm.

    Meine Erfahrung ist, dass man sich bei Fehlern nicht zu früh festlegen sollte, auch wenn eine mögliche Ursache naheliegend ist – etwa, wenn die Website unmittelbar nach einem Update ein Problem hat.

    WordPress wird millionenfach weltweit eingesetzt. Hätte ein Update tatsächlich dazu geführt, dass die Permalinks nicht mehr funktionieren, hätte es sehr schnell sehr viele Rückmeldungen dazu gegeben. Ob WordPress einfach die Permalink-Einstellung vergessen hat (bzw. sie durch ein fehlerhaft programmiertes Plugin überschrieben wurden), es ein Problem mit der .htaccess gibt oder eine Servereinstellung Ursache des Problems ist, hätten wir dann schrittweise erkunden müssen. Du hast dich aber für die naheliegende Variante entschieden, die Permalink-Einstellungen nochmal aufzurufen – sehr schön, wenn du das Problem dann so einfach beheben konntest.

    Wir hatten dieses Mal aber schon ein paar Beiträge, in denen gebeten wurde, wir sollten doch bitteschön mal „WordPress prüfen“. Auch in den Fällen lag die Ursache für ein Problem nicht im WordPress Core, sondern in einem Theme. Der Theme-Entwickler hat es leider versäumt, sein Theme während der vielen Betaversionen und Release Candidates zu prüfen.

    Viel Erfolg bei deinem Projekt.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „WordPress 6.1 Problem : es werden keine Seiten mehr gefunden“ ist für neue Antworten geschlossen.