Support » Installation » WordPress 6.4.1: Seite nicht gefunden

  • Gelöst Hommersum

    (@hommersum)


    Vor ein paar Tage habe ich unsere Webseite auf Version 6.4.1 migriert. Am Ende war auch ein Datenbank-Update beinhaltet. Beides gab keine Fehlermeldung. Aber jetzt sind fast alle Seiten und Termine nicht mehr erreichbar. Z.B.: https://hommersum.de/de/heimat-und-verschoenerungsverein-hommersum-e-v/. Ein paar Seiten funktionieren, z.B.: https://hommersum.de/de/kultuur/erntedankfest-2022-endlich-wieder-nas-frugger/
    Die Berichte funktionieren. Unsere Seite ist in 2 Sprachen (deutsch und niederländisch).

    Der Website-Zustand:

    ` wp-core
    
    version: 6.4.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 9
    dotorg_communication: true wp-paths-sizes wordpress_path: /home/hommersucz/www
    wordpress_size: 66,33 MB (69549774 bytes)
    uploads_path: /home/hommersucz/www/wp-content/uploads
    uploads_size: 3,59 GB (3856830745 bytes)
    themes_path: /home/hommersucz/www/wp-content/themes
    themes_size: 6,88 MB (7209105 bytes)
    plugins_path: /home/hommersucz/www/wp-content/plugins
    plugins_size: 75,12 MB (78773201 bytes)
    database_size: 82,85 MB (86874352 bytes)
    total_size: 3,82 GB (4099237177 bytes) wp-active-theme name: Twenty Seventeen/twentyseventeen_child (twentyseventeen_child)
    version: 1.7
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, starter-content, custom-header, widgets
    theme_path: /home/hommersucz/www/wp-content/themes/twentyseventeen_child
    auto_update: Deaktiviert wp-themes-inactive (2) Twenty Twenty-Four: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (19) ActivityPub: version: 1.2.0, author: Matthias Pfefferle & Automattic, Automatische Aktualisierungen aktiviert
    All-in-One WP Migration: version: 7.79, author: ServMask, Automatische Aktualisierungen aktiviert
    All-in-One WP Migration Unlimited Extension: version: 2.54, author: ServMask, Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.8.3, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Everest Gallery Lite: version: 1.0.3, author: Access Keys, Automatische Aktualisierungen deaktiviert
    Hommersum: version: 0.2, author: Simon Lissack / Antoon Rodoe, Automatische Aktualisierungen deaktiviert
    Instant Images: version: 6.1.0, author: Darren Cooney, Automatische Aktualisierungen aktiviert
    Loco Translate: version: 2.6.6, author: Tim Whitlock, Automatische Aktualisierungen aktiviert
    Media Library Assistant: version: 3.13, author: David Lingren, Automatische Aktualisierungen aktiviert
    MetaSlider: version: 3.50.0, author: MetaSlider, Automatische Aktualisierungen aktiviert
    NodeInfo: version: 2.2.0, author: Matthias Pfefferle, Automatische Aktualisierungen deaktiviert
    PHP Compatibility Checker: version: 1.6.2, author: WP Engine, Automatische Aktualisierungen aktiviert
    Polylang Pro: version: 3.4.5, author: Frédéric Demarle, Automatische Aktualisierungen deaktiviert
    Post Expiration Date: version: 1.3, author: Huguette Inc., Automatische Aktualisierungen deaktiviert
    Shortcodes Ultimate: version: 7.0.0, author: Vova Anokhin, Automatische Aktualisierungen aktiviert
    Simple Custom CSS and JS: version: 3.45, author: SilkyPress.com, Automatische Aktualisierungen aktiviert
    Team Members: version: 5.3.0, author: WP Darko, Automatische Aktualisierungen aktiviert
    The Events Calendar: version: 6.2.8.1, author: The Events Calendar, Automatische Aktualisierungen aktiviert
    User Role Editor: version: 4.64.1, author: Vladimir Garagulya, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 130M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 63 GB
    imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    imagick::RESOURCETYPE_FILE: 768
    imagick::RESOURCETYPE_MAP: 63 GB
    imagick::RESOURCETYPE_MEMORY: 31 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 1.844674407371E+19
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27 the-events-calendar wp-server server_architecture: Linux 5.15.41-ovh-vps-grsec-zfs-classid x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 16000
    time_limit: 165
    memory_limit: 512M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 130M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2023-11-24T11:02:03+00:00
    utc-time: Friday, 24-Nov-23 11:02:03 UTC
    server-time: 2023-11-24T12:02:00+01:00 wp-database extension: mysqli
    server_version: 5.7.42-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 33554432
    max_connections: 151 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/hommersucz/www/wp-content
    WP_PLUGIN_DIR: /home/hommersucz/www/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable activitypub

    Entschuldigung für mein niederländischen Deutsch!
    Ich hoffe auf eure Hilfe bei diesem Problem!
    Vielen Dank / alvast bedankt
    Antoon Rodoe

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo,
    vielleicht gibt es ein Problem mit den Permalinks. Das könnte möglicherweise wie folgt gelöst werden: Über Einstellungen > Permalinks im WordPress Dashboard unten auf der Seite auf den Button „Änderungen speichern“ klicken. Hier brauchst du keine Änderungen vornehmen – einfach auf die Schaltfläche klicken.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Hommersum

    (@hommersum)

    Hallo Hans-Gerd,
    danke für die schnelle Reaktion. Das hatte ich schon versucht, aber heute nochmal probiert. Leider hat es nichts gebracht. Noch immer werden die Seiten nicht gefunden. Die Berichte funktionieren sauber.
    Permalinks stehen bei uns auf individuelle: /%category%/%postname%/.
    Viele Grüße
    Antoon

    Hallo,
    meistens hilft es aber auch, wenn du (nach Datensicherung) die Einstellung zunächst auf „Standard“ durch Klick auf „Änderungen speichern“ bestätigst und anschließend die Permalinks wieder auf „Beitragsname“ setzt und wiederum bestätigst.

    Teste bitte danach mal, ob du wieder auf individuelle umstellen kannst: /%category%/%postname%/.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Hommersum

    (@hommersum)

    Hallo,
    ich nehme an, dass du mit „Standard“ die Option „Einfach“ meinst.
    Nach der Sicherung (hat etwas gedauert). Habe ich die Einstellungen darauf geändert. Dann funktionieren die Seiten, z.B. https://hommersum.de/?page_id=559&lang=de
    Wenn ich es aber dann wieder zurücksetze auf Individuelle Struktur: /%category%/%postname%/ ist das Problem wieder da.
    Interessant: Bei Option Einfach funktionieren die Seiten, ist aber der Kalender verschwunden. Dazu nutze ich das Plugin The Events Calendar.
    Viele Grüße
    Antoon

    Hallo,
    es könnte auch an einer defekten .htaccess liegen.

    Hilfreich könnte eine neue .htaccess sein:

    • verbinde dich mit deinem Server über FTP
    • suche die .htaccess-Datei in deinem Stammordner
    • lade eine Kopie der Datei auf deinen Computer (als Sicherung)
    • lösche die .htaccess-Datei von deinem Server, nachdem du eine Sicherungskopie auf deinem lokalen Computer hast.

    Um WordPress zu zwingen, eine neue, saubere .htaccess-Datei zu erzeugen:

    • gehe zu den Einstellungen > Permalinks in deinem WordPress Dashboard
    • unten auf der Seite klicken: auf Änderungen speichern (du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche).

    Unter Veranstaltungen > Einstellungen > Allgemein findest du unter „Genau hier“ den Link für den Kalender.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    Kalender

    Viele Grüße
    Hans-Gerd

    Thread-Starter Hommersum

    (@hommersum)

    Hallo,
    das Löschen von den .htaccess-Datei hat nichts geholfen.
    Das Suchen nach den Veranstaltungen hat aber ein Erkenntnis gebracht:
    Laut Plugin Events Calender ist die Seite hier: https://hommersum.de/evenementen/. Das stimmt auch.
    Mein Link auf der Webseite sagt aber: https://hommersum.de/de/evenementen/. Sprich aus den Permalinks der Seiten ist das /de bzw. /nl verschwunden. Da die Webseite damals (2017) eingerichtet wurde von jemanden anders, kenne ich mich da nicht genau aus. Ich denke es geht über den Plugin Polylang Pro. Die Einstellungen habe ich beigefügt.

    Ich sehe dort aber nichts was falsch ist.
    Viele Grüße
    Antoon

    Hallo,
    wenn ich das richtig sehe (z. B. hier), dann unterstützt das Plugin The Events Calendar nicht die Mehrsprachen-Funktionen von Polylang.
    Am besten wendest du dich mit der Frage direkt an die Entwickler von Polylang.

    Viele Grüße
    Hans-Gerd

    Hallo,
    scheint jetzt aber zu funktionieren, sogar mit Unterstützung durch Polylang. Würde mich interessieren, wie du das Problem lösen konntest.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Hommersum

    (@hommersum)

    Hallo,
    ich habe es gefunden: Es gab noch eine zweite Stelle mit Einstellungen für Polylang

    Im Bild nicht zu sehen, aber es gab noch links Sprachen -> Einstellungen und dort (siehe Bild): URL-Anpassungen. Dort habe ich kurz rechts die Option „Sprache in wohlgeformten Permalinks beibehalten“ aktiviert und gespeichert. Folge: Die Webseite war nicht mehr erreichbar. Nachdem ich die Option „Sprache in wohlgeformten Permalinks entfernen“ wieder angewählt hatte und gespeichert, funktioniert die Webseite wieder.

    Darum: Vielen vielen Dank für das Mitdenken und Fragen stellen!!!!
    Viele Grüße vom Niederrhein
    Antoon Rodoe

    Hallo,
    freut mich – herzlichen Dank für die ausführliche Rückmeldung.
    Danke auch für „Gelöst“-Markieren.

    Viele Grüße
    Hans-Gerd

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)