Support » Allgemeine Fragen » WordPress 6.4.3 – PHP 8.3 – Kompatibilität

  • Gelöst Roya

    (@royaho)


    Hallo,

    ist WordPress 6.4.3 mit der PHP Version 8.3 kompatibel?

    Bitte um Auskunft! Vielen Dank!

    Anbei noch der Bericht zum Website Zustand

    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    Warning: Array to string conversion in /home/.sites/85/site5774994/web/wp-admin/includes/class-wp-debug-data.php on line 1535
    
    ### wp-core ###
    
    version: 6.4.3
    
    site_language: de_DE
    
    user_language: de_DE
    
    timezone: Europe/Vienna
    
    permalink: /%postname%/
    
    https_status: true
    
    multisite: false
    
    user_registration: 0
    
    blog_public: 1
    
    default_comment_status: undefined
    
    environment_type: production
    
    user_count: 1
    
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/.sites/85/site5774994/web
    
    wordpress_size: 62,21 MB (65228878 bytes)
    
    uploads_path: /home/.sites/85/site5774994/web/wp-content/uploads
    
    uploads_size: 5,57 MB (5836683 bytes)
    
    themes_path: /home/.sites/85/site5774994/web/wp-content/themes
    
    themes_size: 5,12 MB (5372401 bytes)
    
    plugins_path: /home/.sites/85/site5774994/web/wp-content/plugins
    
    plugins_size: 73,11 MB (76660910 bytes)
    
    database_size: 40,92 MB (42909696 bytes)
    
    total_size: 186,93 MB (196008568 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    
    version: 3.3.1
    
    author: Tom Usborne
    
    author_website: https://tomusborne.com
    
    parent_theme: none
    
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, editor-color-palette, custom-logo, menus, editor-styles, editor-style, widgets
    
    theme_path: /home/.sites/85/site5774994/web/wp-content/themes/generatepress
    
    auto_update: Aktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty-Four: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    Twenty Twenty-Three: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-active (9) ###
    
    Code Snippets: version: 3.6.2, author: Code Snippets Pro, Automatische Aktualisierungen aktiviert
    
    GenerateBlocks: version: 1.8.2, author: Tom Usborne, Automatische Aktualisierungen aktiviert
    
    GP Premium: version: 2.4.0, author: Tom Usborne, Automatische Aktualisierungen aktiviert
    
    Maintenance PRO: version: 5.24, author: LintedCode LLC, Automatische Aktualisierungen aktiviert
    
    Rank Math SEO: version: 1.0.212, author: Rank Math, Automatische Aktualisierungen aktiviert
    
    Solid Security Basic: version: 9.3.0, author: SolidWP, Automatische Aktualisierungen aktiviert
    
    W3 Total Cache: version: 2.6.1, author: BoldGrid, Automatische Aktualisierungen aktiviert
    
    WPvivid Backup Plugin: version: 0.9.95, author: WPvivid Team, Automatische Aktualisierungen aktiviert
    
    Yoast Duplicate Post: version: 4.5, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### code-snippets (3) ###
    
    snippet-5: name: Add image title to featured images, scope: global, modified: 2023-05-26 04:25:21
    
    snippet-7: name: Show local fonts in WP block editor, scope: global, modified: 2023-06-03 11:59:40
    
    snippet-8: name: Disable WordPress login hints after failed login attempts, scope: global, modified: 2023-06-08 11:42:10
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    
    imagick_module_version: 1692
    
    imagemagick_version: ImageMagick 6.9.12-67 Q16 x86_64 17519 https://legacy.imagemagick.org
    
    imagick_version: 3.7.0
    
    file_uploads: 1
    
    post_max_size: 128M
    
    upload_max_filesize: 60M
    
    max_effective_size: 60 MB
    
    max_file_uploads: 20
    
    imagick_limits:
    
                   imagick::RESOURCETYPE_AREA: 251 GB
    
                   imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    
                   imagick::RESOURCETYPE_FILE: 768
    
                   imagick::RESOURCETYPE_MAP: 251 GB
    
                   imagick::RESOURCETYPE_MEMORY: 125 GB
    
                   imagick::RESOURCETYPE_THREAD: 1
    
                   imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    
    gd_version: bundled (2.1.0 compatible)
    
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.18.0-372.26.1.lve.1.el8.x86_64 x86_64
    
    httpd_software: Apache
    
    php_version: 8.2.14 64bit
    
    php_sapi: fpm-fcgi
    
    max_input_variables: 3000
    
    time_limit: 180
    
    memory_limit: 256M
    
    max_input_time: 180
    
    upload_max_filesize: 60M
    
    php_post_max_size: 128M
    
    curl_version: 7.61.1 OpenSSL/1.1.1k
    
    suhosin: false
    
    imagick_availability: true
    
    pretty_permalinks: true
    
    htaccess_extra_rules: true
    
    current: 2024-02-03T13:48:43+00:00
    
    utc-time: Saturday, 03-Feb-24 13:48:43 UTC
    
    server-time: 2024-02-03T14:48:41+01:00
    
    ### wp-database ###
    
    extension: mysqli
    
    server_version: 5.7.44-log
    
    client_version: mysqlnd 8.2.14
    
    max_allowed_packet: 16777216
    
    max_connections: 505
    
    ### wp-constants ###
    
    WP_HOME: https://www.hundetraining-mit-roya.at
    
    WP_SITEURL: https://www.hundetraining-mit-roya.at
    
    WP_CONTENT_DIR: /home/.sites/85/site5774994/web/wp-content
    
    WP_PLUGIN_DIR: /home/.sites/85/site5774994/web/wp-content/plugins
    
    WP_MEMORY_LIMIT: 256M
    
    WP_MAX_MEMORY_LIMIT: 256M
    
    WP_DEBUG: false
    
    WP_DEBUG_DISPLAY: true
    
    WP_DEBUG_LOG: false
    
    SCRIPT_DEBUG: false
    
    WP_CACHE: true
    
    CONCATENATE_SCRIPTS: undefined
    
    COMPRESS_SCRIPTS: undefined
    
    COMPRESS_CSS: undefined
    
    WP_ENVIRONMENT_TYPE: Nicht definiert
    
    WP_DEVELOPMENT_MODE: undefined
    
    DB_CHARSET: utf8mb4
    
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    
    wp-content: writable
    
    uploads: writable
    
    plugins: writable
    
    themes: writable
    
    ### solid-security ###
    
    pro: free
    
    initial_build: 4126
    
    activated: 2023-05-06 02:43:08
    
    patchstack: false
    
    modules:
    
                   0: ban-users
    
                   1: brute-force
    
                   2: security-check-pro
    
                   3: ssl
    
                   4: malware-scheduling
    
                   5: firewall
    
    settings:
    
                   ban-users: Array
    
                   brute-force: Array
    
                   firewall: Array
    
                   global: Array
    
                   system-tweaks: Array
    
                   wordpress-tweaks: Array
    
                   hide-backend: Array
    
    user_groups:
    
                   0: Array
    
                   1: Array
    
                   2: Array
    
                   3: Array
    
                   4: Array

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • ist WordPress 6.4.3 mit der PHP Version 8.3 kompatibel?

    Ja, aber vielleicht hat ein von dir installiertes Plugin oder die Code-snippets damit ein Problem.

    Thread-Starter Roya

    (@royaho)

    Hallo,

    danke für die Auskunft! Wie finde ich heraus, ob die anderen Anwendungen kompatibel sind? Muss ich da bei jedem einzeln nachfragen?

    Liebe Grüße!

    Hallo,
    das kannst du feststellen, wenn du beispielsweise alle Plugins deaktivierst und dann Plugin für Plugin aktivierst. Nach der jeweiligen Aktivierung prüfst du dann, ob die Warnings noch auftauchen.

    Voher bitte sichern.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Roya

    (@royaho)

    Hallo,

    vielen Dank für die Auskunft! Ich habe noch kein Update von PHP vorgenommen, weil empfohlen wurde zuerst sicherzustellen, dass WordPress kompatibel ist. Daher gibt es auch keine Warnings. Wo würde ich diese bitte im Fall des Falles finden?

    Ich habe Sorge, dass dann die Website nicht mehr ordentlich funktioniert und ich dann nicht weiter weiß. Leider kenne ich mich mit der Materie nicht so gut aus und die Entwicklerin der Website hat den Job aufgegeben, sodass ich leider keine Unterstützung mehr von ihr bekomme.

    Kann man bei den Plugin Entwicklern nachfragen? Oder soll ich mit dem Update noch warten? Ist es dringend und wichtig?

    Liebe Grüße, Roya

    Hallo,
    bei dir ist als PHP-Version 8.2.x eingestellt. Da besteht also kein Handlungsbedarf.

    Was meinst du mit:

    Kann man bei den Plugin Entwicklern nachfragen? Oder soll ich mit dem Update noch warten? Ist es dringend und wichtig?

    Die Warnings werden auch nicht auf der Website angezeigt. Soweit ich das sehe, sind GeneratePress, GP Premium und GenerateBlocks aktualisiert. Wir verwenden das Theme GeneratePress, die Premium-Version GP Premium und das Plugin GenerateBlocks auch auf einigen WordPress-Instanzen. Ich bin mir ziemlich sicher, dass das Problem nicht damit zusammenhängt.

    Wie gesagt: Ich könnte mir vorstellen, dass die Warnings mit den Snippets, die bei Code Snippets aktiviert sind, zusammenhängt. Du kannst an sich ohne Probleme die Snippets deaktivieren und schauen, ob es Probleme gibt. Vorher solltest du aber eine Sicherung über das bereits aktivierte WPvivid Backup Plugin durchführen.

    Wenn du unsicher bist, dann solltest du dir einen Dienstleister suchen. Bitte hier im Forum aber nicht anfragen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Roya

    (@royaho)

    Hallo nochmal,

    vielen Dank für deine Antworten!

    Für mich waren das schon 2 verschiedene Themen. Das eine, ob ein PHP-Update möglich (weil kompatibel) bzw. sinnvoll ist. Das andere die Fehlermeldung, die ich über Email erhalten habe.

    Meine Fragen: Kann man bei den Plugin Entwicklern nachfragen? Oder soll ich mit dem Update noch warten? Ist es dringend und wichtig?

    … haben sich auf die PHP-Kompatibilität bezogen. Also, ob ich vielleicht bei den Plugin Entwicklern erfahren kann, ob ihr Plugin mit der genannten PHP-Version kompatibel ist.

    Das hat sich insofern erübrigt, weil du meintest, dass ich derzeit kein PHP Update benötige.

    Das andere Thema ist eben diese Fehler Meldung. Du meinst also, dass dies mit den Snippets zusammenhängt. Wie kann ich dann herausfinden, ob diese Fehlermeldung danach noch existiert? Ich habe diese wie gesagt unmittelbar nach einem automatischen WordPress Upgrade per Email erhalten mit einem Link zu dieser Fehlermeldung. Wie kann ich sonst herausfinden, ob die Fehlermeldung noch existiert? Die 3 Snippets kurzfristig auszuschalten ist vermutlich kein Problem, langfristig fehlen halt diese Funktionen.

    Bekomme ich eigentlich nächste Woche wieder eine Meldung von Solid Security zu dem selben Problem, wenn ich dieses nicht behebe?

    Danke dir nochmal ganz herzlich für deine Unterstützung!

    Liebe Grüße, Roya

    Thread-Starter Roya

    (@royaho)

    Achja: Da gab es jemanden bei dem anderen Thread, der gemeint hat, ob nicht das WordPress Upgrade schuld an der Fehlermeldung sein könnte und ob dies nicht vielleicht ein falscher Alarm ist. Hupe13 wollte eine Information von mir, die ich ihm gegeben habe. Allerdings kann ich mit ihm nicht mehr kommunizieren, wenn das Thema nun geschlossen ist. Vielleicht ist das ganze Problem ja wirklich nur falscher Alarm und er hat Infos dazu…

    Moderator Michi91

    (@michi91)

    Für mich sind es tatsächlich auch eher zwei Themen.

    Also bezüglich des Security Hinweises kann ich dich beruhigen. Wenn du die 6.4.3 installiert hast, wurde die Lücke geschlossen 🙂 solid security darf somit künftig die Meldung auch nicht mehr auflisten…

    Bezüglich des PHP upgrades. Aktuell hast du ja 8.2 und die kannst du auch noch einige Zeit nutzen. Es besteht also kein akuter Handlungsbedarf.

    Wo würde ich diese bitte im Fall des Falles finden

    Also, die meisten Hoster erlauben ganz einfach zwischen den verschiedenen PHP Versionen zu wechseln. Ich mach es immer so: ich stelle auf die aktuelle PHP Version um, und teste danach ob noch alles tut (Seiten ansehen, formulare testen, neue Seite anlegen, ne vorhandene bearbeiten). Wenn alles tut ist super, wenn nicht kann ich mir die Fehlermeldungen notieren und bequeme zurück auf die alte Version wechseln, bis ich weiß was los ist 🙂

    Ansonsten wäre der theoretische Ansatz bei jedem Autoren / Hersteller nachzufragen natürlich auch ein Weg. Aber ob man da immer Antworten bekommt? Insbesondere bei den snippets? Schwierig.

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von Michi91.
    Thread-Starter Roya

    (@royaho)

    Hallo Michi,

    danke für deine Erläuterungen!

    Das ist ja mal eine gute Nachricht, dass diese Fehlermeldung wohl eine Fehlanzeige war. Eigenartig, dass ich diese genau dann bekommen habe, als der Fehler eigentlich behoben wurde.

    Betreffend PHP Update: Ab wann sollte ich auf eine neue Version umsteigen?

    Fein, dass aktuell kein Handlungsbedarf bei beiden Themen besteht! Das erspart mir jede Menge Arbeit 🙂

    Vielen Dank nochmal und liebe Grüße, Roya

    Hallo,

    Betreffend PHP Update: Ab wann sollte ich auf eine neue Version umsteigen?

    Das ist auch abhängig vom End of Life (EOL): https://www.php.net/supported-versions.php

    Da im November 2023 der Support für PHP 8.0.x beendet wurde, haben wir bei den von uns betreuten Projekten PHP auf 8.1.x umgestellt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Roya

    (@royaho)

    Hallo Hans-Gerd,

    danke für die Information!

    Damit ist das Thema nun erledigt.

    Danke nochmal Allen für die Unterstützung!

    Liebe Grüße, Roya

    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)