• Gelöst fritim

    (@fritim)


    Guten Tag, ich habe mein WordPress von 5.0.11 auf die aktuellste Version 5.7 aktualisiert (Manuell, da WordPress autoupdate schon sagte, dass es aktuell sei). Somit habe ich alle Datein über FileZilla vom Server gelöscht außer die WP-content. Dann alle neuen Datein drauf gezogen von 5.7. Jedoch steht unten rechts immer noch 5.0.11 und auch die Plugins sagen Sie brauchen eine neue Version.
    Hat wer eine Idee woran es liegen könnte?

    Danke schonmal

    Mit freundlichen Grüßen
    Tim

Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)
  • Hallo,
    hast du dir schon den Bericht angesehen? – Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Starter fritim

    (@fritim)

    Hallo Hans-Gerd
    unter „Tools“ befinden sich nur folgende Unterpunkte: „Available Tools, Import, Export, Network Setup, Export Personal Data, Erase personal Data“.
    Dort finde ich keine Infos zu der Webseite.

    Dann alle neuen Datein drauf gezogen von 5.7. Jedoch steht unten rechts immer noch 5.0.11 …

    Plausibelste Erklärung ist, dass du die falschen Dateien ausgetauscht hast.
    Was passiert, wenn du unter Dashboard > Aktualisierungen auf „erneut aktualisieren“ gehst? Was ist in der wp-config.php eingetragen? (Wenn du sie hier teilen magst, bitte Zugangsdaten und SALT-Keys aus der Antwort löschen.)

    Dort finde ich keine Infos zu der Webseite.

    Den Website-Bericht gab es in WordPress 5.0 noch nicht. Du kannst aber das Plugin Health Check installieren und dir dann unter Werkzeuge > Website-Zustand den Bericht anschauen bzw. per Button hier teilen.

    Thread-Starter fritim

    (@fritim)

    * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'database_name_here' );
    
    /** MySQL database username */
    define( 'DB_USER', 'username_here' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', 'password_here' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'localhost' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',         'put your unique phrase here' );
    define( 'SECURE_AUTH_KEY',  'put your unique phrase here' );
    define( 'LOGGED_IN_KEY',    'put your unique phrase here' );
    define( 'NONCE_KEY',        'put your unique phrase here' );
    define( 'AUTH_SALT',        'put your unique phrase here' );
    define( 'SECURE_AUTH_SALT', 'put your unique phrase here' );
    define( 'LOGGED_IN_SALT',   'put your unique phrase here' );
    define( 'NONCE_SALT',       'put your unique phrase here' );
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
    wp-config.php  * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
            define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php'; 

    Dies ist die wp-config.php

    • Diese Antwort wurde geändert vor 3 Jahren, 4 Monaten von fritim.
    • Diese Antwort wurde geändert vor 3 Jahren, 4 Monaten von Bego Mario Garde. Grund: Codeformatierung

    Bist du sicher, dass du nicht den Inhalt der wp-config-sample.php geteilt hast?

    Thread-Starter fritim

    (@fritim)

    Hey Bego, ja ziemlich.
    Wir haben noch eine config-elominersgermany.com.php
    Dort haben wir folgenden Inhalt:

    <?php
    # Created by setup-mysql 
    define('DB_NAME', 'worpress');
    define('DB_USER', 'worpress');
    define('DB_PASSWORD', 'XXXXXXX');
    define('DB_HOST', 'localhost');
    define('SECRET_KEY', 'XXXXXX');
    define('WP_CONTENT_DIR', '/var/lib/wordpress/wp-content');
    ?>

    Auch haben wir eine wp-conf.php
    dort sind folgende Sachen drin:

    <VirtualHost :80>
            ServerName elominers-germany.com
    
            ServerAdmin webmaster@example.com
            DocumentRoot /usr/share/wordpress
    
            Alias /wp-content /var/lib/wordpress/wp-content
            <Directory /usr/share/wordpress>
                Options FollowSymLinks
                AllowOverride Limit Options FileInfo
                DirectoryIndex index.php
                Require all granted
            </Directory>
            <Directory /var/lib/wordpress/wp-content>
                Options FollowSymLinks
                Require all granted
            </Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
                RewriteRule ^index.php$ - [L]
                RewriteCond /usr/share/wordpress%{REQUEST_URI} !-f
                RewriteCond /usr/share/wordpress%{REQUEST_URI} !-d
                RewriteRule . /usr/share/wordpress/index.php [L]
                # Also needed if using PHP-FPM / Fast-CGI
                RewriteCond %{REQUEST_URI} !^/php5-fcgi/
    </VirtualHost>

    Das ist eine recht individuelle Anpassung der WordPress-Dateien. Der Verweis auf PHP5 klingt auch nicht gerade gut (aktuell ist PHP 7.4, 7.3 ist auch noch OK). Wahrscheinlich führen diese Anpassungen zu der geschilderten Weiterleitung. Da ich das nicht in vollem Umfang einsehen kann, kann ich dir da auch nicht weiterhelfen.

    Thread-Starter fritim

    (@fritim)

    Hallo Bego,

    wir haben nun alles, auch PHP, aktualisiert. Nun klappt alles

    Danke für deine Hilfe

Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)
  • Das Thema „WordPress aktuallisiert, denkt aber es wäre alt“ ist für neue Antworten geschlossen.