Support » Allgemeine Fragen » WordPress Editor entfernt br aus dem Quelltext

  • Gelöst papermoon303

    (@papermoon303)


    Hallo,

    warum löscht WP 5.2.1 jedesma br nach dem abspeichern? Ich möchte gerne 1 oder 2 Leerzeilen in meinem Text haben. Im visual modus nutzt RETURN drücken nichts, da ich mich in einer LI befinde und er dann den nächsten Bullet erstellt. SHIFT RETURN funktioniert zwar, löscht aber dann nach dem abspeichern wieder.

    Ich will ganz simpel ein normales <br> im text modus schreiben. Warum diese Bevormundung? Es kann doch nicht sein, dass man sich heutzutage stundenlang mit solchen trivialen Problemen auseinandersetzen muss.

    Vielen Dank

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • warum löscht WP 5.2.1 jedesma br nach dem abspeichern?

    weil das Bedienkonzept seit den Anfangstagen von WordPress anders ist.
    AnwenderInnen sollen im visuellen Modus kein HTML eingeben, sondern „wie auf der Schreibmaschine schreiben“ können. WordPress fügt bei Absatzschaltungen im Editor selbständig Absatz-Tags <p>…</p> hinzu, bei weichen Zeilenumbrüchen (Großschreibtaste-Enter) ein Tag <br> – es sei denn, der Inhalt wird als Textauszug (Excerpt) ausgegeben. In Textauszügen werden Formatierungen (wie z.B. <strong> oder <em>) nicht berücksichtigt.

    SHIFT RETURN funktioniert zwar, löscht aber dann nach dem abspeichern wieder.

    Das kann ich – vorausgesetzt, der Inhalt wird komplett ausgegeben, nicht nur der Textauszug – nicht nachvollziehen. Gebe ich eine Liste mit einem Listenelemen und zwei weichen Zeilenschaltungen ein, wird das in WordPrdss 5.3.2 (das ist übrigens die aktuelle Version) so im Frontend ausgegeben:

    <div class="entry-content">
    <ul><li>Zeile eins<br>neue Zeile<br>noch eine neue Zeile</li></ul>
    </div>

    Warum diese Bevormundung?

    Weil AnwenderInnen, die nicht programmieren können (und wollen) ein leicht zu bedienender Editor an die Hand gegeben werden soll. Wenn du HTML einfügen möchtest, kannst du dafür HTML-Blöcke einfügen.

    Es kann doch nicht sein, dass man sich heutzutage stundenlang mit solchen trivialen Problemen auseinandersetzen muss.

    Nein, es reicht völlig, wenn man freundlich im Support-Forum nachfragt. Dort bekommst du dann recht zügig (nicht nach Stunden) eine Antwort. (Zumindest bemühen wir uns darum … 🙂 )

    vielen Dank für die schnelle Antwort.

    Habe es noch einmal versucht mit SHIFT + RETURN und funktioniert tatsächlich jetzt. k.A. warum auch diese Variante vorhin immer wieder gelöscht wurde. Vermutlich lag es an dem Editor von Bakery was ich für die betreffende Seite jetzt nicht mehr benutze.

    Danke noch einmal. Das hat geholfen 🙂
    vg

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)