• Hallo zusammen,
    es scheint als ob jede URL den Statuscode 404 im Header liefert. Ist es möglich, dass ein Fehler in der Konfiguration des CMS besteht?

    Ich freue mich über eine kleine Hilfestellung,

    besten Dank und liebe Grüße

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 16)
  • Zur Fehlersuche solltest du zuerst Cache- und sonstige Optimierungs-Plugins deaktivieren, um sie als Fehlerursache auszuschließen.

    Besteht der Fehler weiterhin, bräuchten wir mehr Informationen zur Website. Geh dazu bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist. Klick auf den Button „Bericht in die Zwischenablage kopieren“. Den Bericht kannst du dann hier in einer neuen Antwort mit Strg-V (Mac: Cmd-V) unverändert einfügen (also bitte ohne weitere Formatierung, aber mit den Akzentzeichen ` am Anfang und Ende).

    Wenn du selber nach möglichen Fehlerursachen suchen möchtest, ist das Plugin Health Check hilfreich. Es bietet dir unter Werkzeuge > Website-Zustand einen „Problembehandlungsmodus“, mit dem alle Plugins vorübergehend deaktiviert und zu einem Standard-Theme gewechselt wird. Du kannst die Plugins dann einzeln aktivieren und im Ausschlussverfahren testen, was sich jeweils ändert und ob sich er Fehler damit eingrenzen lässt.

    Thread-Starter chef2000

    (@chef2000)

    
    ### wp-core ###
    
    version: 5.6
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/www/wordpresswebseite
    wordpress_size: 52,41 MB (54951703 bytes)
    uploads_path: /home/www/wordpresswebseite/wp-content/uploads
    uploads_size: 625,31 MB (655680697 bytes)
    themes_path: /home/www/wordpresswebseite/wp-content/themes
    themes_size: 23,74 MB (24889477 bytes)
    plugins_path: /home/www/wordpresswebseite/wp-content/plugins
    plugins_size: 103,11 MB (108122700 bytes)
    database_size: 495,17 MB (519225344 bytes)
    total_size: 1,27 GB (1362869921 bytes)
    
    ### wp-active-theme ###
    
    name: Phlox (phlox)
    version: 2.7.2
    author: averta
    author_website: http://www.averta.net
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, post-formats, woocommerce, html5, gallery, customize-selective-refresh-widgets, custom-logo, auxin-portfolio, auxin-shop, automatic-feed-links, title-tag, menus, starter-content, infinite-scroll, wc-product-gallery-zoom, wc-product-gallery-slider, header-footer-elementor, widgets, editor-style
    theme_path: /home/www/wordpresswebseite/wp-content/themes/phlox
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 1.6, author: WordPress-Team (latest version: 1.9), Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.3, author: WordPress-Team (latest version: 2.5), Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.4, author: WordPress-Team (latest version: 1.6), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.0, author: WordPress-Team (latest version: 1.1), Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Elementor: version: 3.0.15, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Phlox Core Elements: version: 2.7.5, author: averta, Automatische Aktualisierungen aktiviert
    Phlox Portfolio: version: 2.1.1, author: averta, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (14) ###
    
    Autoptimize: version: 2.8.1, author: Frank Goossens (futtta), Automatische Aktualisierungen aktiviert
    BackWPup: version: 3.8.0, author: Inpsyde GmbH, Automatische Aktualisierungen aktiviert
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Cookie Notice: version: 1.3.2, author: dFactory, Automatische Aktualisierungen aktiviert
    Email Address Encoder: version: 1.0.22, author: Till Krüss, Automatische Aktualisierungen aktiviert
    Insert Headers and Footers: version: 1.5.0, author: WPBeginner, Automatische Aktualisierungen aktiviert
    Redirection: version: 4.9.2, author: John Godley, Automatische Aktualisierungen deaktiviert
    SiteOrigin Widgets Bundle: version: 1.17.11, author: SiteOrigin, Automatische Aktualisierungen aktiviert
    Smush: version: 3.8.2, author: WPMU DEV, Automatische Aktualisierungen aktiviert
    W3 Total Cache: version: 2.0.1, author: BoldGrid, Automatische Aktualisierungen aktiviert
    Wordfence Security: version: 7.4.14, author: Wordfence, Automatische Aktualisierungen deaktiviert
    WordPress Popular Posts: version: 5.2.4, author: Hector Cabrera, Automatische Aktualisierungen aktiviert
    WP ULike: version: 4.4.4, author: TechnoWich, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 15.5, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 150M
    upload_max_filesize: 150M
    max_effective_size: 150 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 251 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 251 GB
    	imagick::RESOURCETYPE_MEMORY: 126 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.9.0-8-amd64 x86_64
    httpd_software: Apache
    php_version: 7.1.33-24+0~20201103.44+debian9~1.gbp50e805 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 150M
    php_post_max_size: 150M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.15
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/wordpresswebseite/wp-content
    WP_PLUGIN_DIR: /home/www/wordpresswebseite/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Starter chef2000

    (@chef2000)

    Hallo @pixolin
    vielen Dank für deine Antwort.
    Ich habe Cache und Optimierungsplugins deaktiviert, jedoch besteht das Problem weiterhin. Nun werde ich Health Check probieren.

    Vielen Dank bis dahin!
    MS

    Thread-Starter chef2000

    (@chef2000)

    Das Problem scheint hier zu liegen: Phlox Plugin

    Thread-Starter chef2000

    (@chef2000)

    Hallo,
    auch wenn Phlox Plugins deaktiviert sind, wird weiterhin 404 ausgegeben. Selbst eine Umleitung der betroffenen URL https://veganegastro.de/wp-content/uploads/phlox/special25.css?ver=2.7.2 auf die Startseite ändert nichts.

    Freue mich über hilfreiche Gedanken 🙂
    Danke!

    Ich habe Cache und Optimierungsplugins deaktiviert, …

    Wenn ich die Webseiten aufrufe und mir in den Entwickler-Tools des Browsers den Code anschaue, bekomme ich im Footer das hier angezeigt:

    Screenshot Einstellungen

    Solange der Cache aktiviert ist, sehen wir nicht die Webseite, wie sie aktuell ist, sondern wie sie zwischengespeichert wurde. Damit lässt sich dann wenig zur Website sagen und auch eine Deaktivierung von Plugins bringt erst einmal keine Änderung.

    Thread-Starter chef2000

    (@chef2000)

    Hallo,
    Cache und Cookie notice war zwischenzeitlich aktiviert um den Problembehandlungsmodus zu starten. Habe Cache und Cookie Notice jetzt deaktiviert.

    Was ist denn der Inhalt der .htaccess?

    Thread-Starter chef2000

    (@chef2000)

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen <code>BEGIN WordPress</code> und <code>END WordPress</code> sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress 

    Hm, schade … ich hatte vermutet, dass eine Weiterleitungsregel Probleme macht. Aber da ist nur eine Weiterleitung von http auf https und die Permalink-Regeln, alles OK.

    Im Problembehandlungsmodus des Plugins Health Check bleibt auch bei deaktivierten Plugins das Verhalten gleich?

    Thread-Starter chef2000

    (@chef2000)

    Ja das tut es leider…

    Mich stört, dass die Browser „gemischte“ Inhalte anzeigen, also angeblich nicht alles https ist. In der Web-Console unter Netzwerkanalyse sehe ich aber nur css-Dateien, die nicht geladen wurden.
    Ich würde mit Query Monitor weiter suchen.

    Du könntest mal das Error-Reporting aktivieren und schauen, ob dabei Fehler ausgegeben werden.

    Dazu träsgt du in der wp-config.php ein:

    
    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    

    (Quelle: Debugging in WordPress)

    Danach rufst du die Webseiten erneut auf und schaust, ob in /wp-content/debug.log etwas geschrieben wird.

    Thread-Starter chef2000

    (@chef2000)

    Hallo,
    einfach nur den Text kopieren, nicht etwa manuell define( 'WP_DEBUG', true ); setzen richtig? Es wird keine debug.log ausgegeben.

    Bei den Templates werden von Phlox mehrere Duplikate (3 Stück) von Default Kit angezeigt. Ich vermute der Fehler liegt bei diesem Template.

    Hatte ich doch (wenn auch mit Tippfehler) geschrieben: Du trägst den Code in der Konfigurationsdatei wp-config.php ein – idealerweise oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ und mit einem geeigneten Code-Editor (z.B. mit dem kostenlos für alle Betriebssysteme erhältlichen Programm VS Code).

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 16)
  • Das Thema „WordPress gibt 404 im Header aus“ ist für neue Antworten geschlossen.