Support » Allgemeine Fragen » WordPress ist sehr langsam

  • Gelöst ngbrnet

    (@ngbrnet)


    Hallo, meine Homepage ist seit ein paar Tagen enorm langsam. Das gilt sowohl für das Backend, als auch für das Frontend. Ich habe alle Plugins getestet, die sind in Ordnung. Mein Theme ich aus dem neuesten Stand. PHP-Version laut meines Providers (Strato) ist die Version 7.2
    Das Protokoll von Health-Check füge ich hier an

    
    ### wp-core ###
    
    version: 5.2.1
    site_language: de_DE
    user_language: de_DE
    permalink: undefined
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web024/e3/02/51668002/htdocs/wordpress
    wordpress_size: 64,60 MB (67732938 bytes)
    uploads_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/uploads
    uploads_size: 2,60 GB (2789031781 bytes)
    themes_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/themes
    themes_size: 24,42 MB (25606006 bytes)
    plugins_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/plugins
    plugins_size: 73,08 MB (76626336 bytes)
    database_size: 94,50 MB (99087980 bytes)
    total_size: 2,85 GB (3058085041 bytes)
    
    ### wp-active-theme ###
    
    name: DI Photo
    version: 1.3
    author: Designers Inn
    author_website: (undefined)
    parent_theme: DI Basis – based on Divi 3.22.5
    theme_features: custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/themes/di-basis
    
    ### wp-themes (1) ###
    
    DI Basis – based on Divi 3.22.5: version: 3.22.5, author: Childthemes - Designers inn, Basistheme Divi by Elegant Themes
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.6.0
    
    ### wp-plugins-active (12) ###
    
    BackUpWordPress: version: 3.8, author: XIBO Ltd
    Classic Editor: version: 1.5, author: WordPress Contributors
    Copy Protection: version: 1.0, author: seosbg
    Envira Gallery: version: 1.8.6.2, author: Envira Gallery Team
    Envira Gallery - Gallery Themes Addon: version: 1.4.7, author: Envira Gallery Team
    Health Check & Troubleshooting: version: 1.3.2, author: The WordPress.org community
    Hello Dolly For Your Song: version: 0.15, author: Marco Hitschler
    The Events Calendar: version: 4.9.3, author: Modern Tribe, Inc.
    Ultimate Tables: version: 1.6.5, author: webpsilon.com
    WP Maintenance Mode: version: 2.2.4, author: Designmodo
    WP Media Category Management: version: 1.9.4, author: DeBAAT <wp-mcm@de-baat.nl>
    WP Real Media Library: version: 4.5.0, author: Matthias Günter
    
    ### wp-plugins-inactive (2) ###
    
    Envira Gallery - Slideshow Addon: version: 1.3.4, author: Envira Gallery Team
    Envira Gallery - Zoom Addon: version: 1.3.6, author: Envira Gallery Team
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_142901-13 i86pc SunOS localhost 5.10 Generic_142901-13 i86pc SunOS localhost 5.10 Generic_142901-13 i86pc
    httpd_software: Apache/2.4.39 (Unix)
    php_version: 7.2.18
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 0
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.50.3 OpenSSL/1.0.2j
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: http://www.krefelder-fotofreunde.de
    WP_SITEURL: http://www.krefelder-fotofreunde.de
    WP_CONTENT_DIR: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 34)
  • Leider befindet sich deine Seite im Wartungsmodus, so kann man sich das nicht ansehen.

    ngbrnet

    (@ngbrnet)

    Sorry, hab den Wartungsmodus jetzt aufgehoben.
    Gruß Norbert

    Also ich kann nicht behaupten, dass die Seite langsam aufbaut.

    Moderator Angelika Reisiger

    (@la-geek)

    Also die Website ist im Wartungsmodus und muss gerade einmal eine Überschrift und einen Absatz sowie 1 CSS- und 2 JavaScript-Dateien laden und braucht dafür 1.2 Minuten. Die jquery.js braucht ewig und endet mit „Failed“.
    Die Domain wirft einen 503 – Error.

    Prüfe deine Website mit den Developertools deines Browsers, Tab Network (oder ähnlich). Dort wird beschrieben, wie du sie aktivierst:

    https://de.wordpress.org/support/topic/warum-ein-link-zu-deiner-website-wichtig-ist/

    Entferne zum Test auch einmal die .htaccess (vorher auf Rechner sichern).

    Kann es sein, dass der Speicherplatz voll ist?

    @la-geek
    All die von die beschriebenen Probleme habe nicht, bei mir funktioniert die Seite. Zwar nicht rasant, aber immer noch im grünen Bereich.

    Moderator Angelika Reisiger

    (@la-geek)

    @bscu
    Eventuell habe ich die Website gestartet, als sie im Wartungs-Modus war und das wurde exakt zu diesem Zeitpunkt abgeschaltet, das würde die 503 erklären und wieso mir trotzdem etwas angezeigt wurde.

    Bei mir ist die Website (ohne Wartungs-Modus) immer noch am Laden … fertig: 1,6 Minuten.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    ich würde mal testweise Caching – Plugins wie z. B. Autoptimize und Cache Enabler einrichten. Außerdem kann man durch Komprimierung der Bilddateien auch noch einiges erreichen, z. B. Optimus.
    Viele Grüße
    Hans-Gerd

    ngbrnet

    (@ngbrnet)

    Hm, ich werde das mit dem „Developertools“ mal ausprobieren. Habe davon leider keine Ahnung.
    Aber das löst immer noch nicht das Problem, dass mein Backend so sehr langsam ist.
    Und DNS-Problematik? Muss das der Provider lösen?
    Meine Bilder werden mit dem Tool TinyPNG komprimiert, bevor sie auf die Webseite kommen.
    Gruß Norbert

    Moderator Hans-Gerd Gerhards

    (@hage)

    @la-geek,
    die Seite wird bei mir geladen, zeigt aber bei Pingdom keine allzu guten Werte, z. B.
    7.92 Load Time

    Moderator Angelika Reisiger

    (@la-geek)

    @ngbrnet

    Vergiss die DNS-Problematik, du hattest vermutlich den Wartungs-Modus abgeschaltet, als ich die Seite aufgerufen hatte.

    Moderator Hans-Gerd Gerhards

    (@hage)

    @ngbrnet,
    die developer tools zeigen u. a. mögliche Fehler an und werden mit STRG SHIFT J aufgerufen (Chrome) oder rechte Maustaste und „Untersuchen“

    ngbrnet

    (@ngbrnet)

    Ich benutze Safari und da bekomme ich 2 Fehler angezeigt:

    [Error] Did not parse stylesheet at ‚http://www.krefelder-fotofreunde.de/wp-content/plugins/copy-protection//style.css?ver=5.2.1&#8216; because non CSS MIME types are not allowed in strict mode.

    TypeError: $ is not a function. (In ‚$(document)‘, ‚$‘ is undefined)

    Habe aber davon leider keine Ahnung

    ngbrnet

    (@ngbrnet)

    Habe das Plugin „Copy-Protection“ deaktiviert, danach keine Fehlermeldung mehr, aber das Backend ist immer noch sehr langsam.
    Gruß Norbert

    Daniel X

    (@fibmyefriblot_doj)

    Wie ist der Stand der Dinge?

    Aktuell gibt es permanente TimeOuts bei der Laufzeitanalyse, hervorgerufen durch das File custom.min.css.
    Der Name deutet auf den Einsatz eines Cache-Plugins hin.
    Eventuell funktioniert die Compression der CSS-Files schlecht, was zu dem TimeOut führt. Leere den Cache, deaktiviere dann sofort danach das Cache-Plugin (oder auch andere Cache-Techniken) und überprüfe das Ergebnis.

    ngbrnet

    (@ngbrnet)

    Ich wollte einmal das Plugin „Autoptimize“ ausprobieren und es installiert. Leider noch nicht konfiguriert, da ich da etwas unsicher bin. Habe das Plugin jetzt wieder deaktiviert.
    Was habe ich bisher gemacht?
    1. Habe alle deaktivierte Plugins gelöscht.
    2. Habe alle inaktiven Themes gelöscht.
    3. Habe die Order wp-Admin und wp-content aus meinem Backup wieder zurückkopiert.

    Das Backend scheint wieder etwas besser zu laufen. Wäre schön, wenn Du mal überprüfen könntest, ob die Homepage jetzt einigermaßen flüssig läuft.

    Ansonsten Kanes denn an meinen Bildern liegen? Wenn ich ein Bild Hochlade, werden zusätzlich noch 6 weitere Bilder in verschiedenen Größen erstellt. Dadurch habe ich im upload-Ordner etwas über 20.000 Bilder. Ich weiß nicht, wie ich das in den Griff bekommen soll. Aufgrund der Grüße kann ich per FTP nicht auf diesen Ordner zugreifen (immer Timeout nach einer gewissen Zeit).

    Gruß Norbert

    • Diese Antwort wurde geändert vor 10 Monate von ngbrnet.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 34)
  • Das Thema „WordPress ist sehr langsam“ ist für neue Antworten geschlossen.