Support » Allgemeine Fragen » WordPress ist sehr langsam

  • Gelöst ngbrnet

    (@ngbrnet)


    Hallo, meine Homepage ist seit ein paar Tagen enorm langsam. Das gilt sowohl für das Backend, als auch für das Frontend. Ich habe alle Plugins getestet, die sind in Ordnung. Mein Theme ich aus dem neuesten Stand. PHP-Version laut meines Providers (Strato) ist die Version 7.2
    Das Protokoll von Health-Check füge ich hier an

    
    ### wp-core ###
    
    version: 5.2.1
    site_language: de_DE
    user_language: de_DE
    permalink: undefined
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web024/e3/02/51668002/htdocs/wordpress
    wordpress_size: 64,60 MB (67732938 bytes)
    uploads_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/uploads
    uploads_size: 2,60 GB (2789031781 bytes)
    themes_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/themes
    themes_size: 24,42 MB (25606006 bytes)
    plugins_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/plugins
    plugins_size: 73,08 MB (76626336 bytes)
    database_size: 94,50 MB (99087980 bytes)
    total_size: 2,85 GB (3058085041 bytes)
    
    ### wp-active-theme ###
    
    name: DI Photo
    version: 1.3
    author: Designers Inn
    author_website: (undefined)
    parent_theme: DI Basis – based on Divi 3.22.5
    theme_features: custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/themes/di-basis
    
    ### wp-themes (1) ###
    
    DI Basis – based on Divi 3.22.5: version: 3.22.5, author: Childthemes - Designers inn, Basistheme Divi by Elegant Themes
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.6.0
    
    ### wp-plugins-active (12) ###
    
    BackUpWordPress: version: 3.8, author: XIBO Ltd
    Classic Editor: version: 1.5, author: WordPress Contributors
    Copy Protection: version: 1.0, author: seosbg
    Envira Gallery: version: 1.8.6.2, author: Envira Gallery Team
    Envira Gallery - Gallery Themes Addon: version: 1.4.7, author: Envira Gallery Team
    Health Check & Troubleshooting: version: 1.3.2, author: The WordPress.org community
    Hello Dolly For Your Song: version: 0.15, author: Marco Hitschler
    The Events Calendar: version: 4.9.3, author: Modern Tribe, Inc.
    Ultimate Tables: version: 1.6.5, author: webpsilon.com
    WP Maintenance Mode: version: 2.2.4, author: Designmodo
    WP Media Category Management: version: 1.9.4, author: DeBAAT <wp-mcm@de-baat.nl>
    WP Real Media Library: version: 4.5.0, author: Matthias Günter
    
    ### wp-plugins-inactive (2) ###
    
    Envira Gallery - Slideshow Addon: version: 1.3.4, author: Envira Gallery Team
    Envira Gallery - Zoom Addon: version: 1.3.6, author: Envira Gallery Team
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_142901-13 i86pc SunOS localhost 5.10 Generic_142901-13 i86pc SunOS localhost 5.10 Generic_142901-13 i86pc
    httpd_software: Apache/2.4.39 (Unix)
    php_version: 7.2.18
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 0
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.50.3 OpenSSL/1.0.2j
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: http://www.krefelder-fotofreunde.de
    WP_SITEURL: http://www.krefelder-fotofreunde.de
    WP_CONTENT_DIR: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /mnt/web024/e3/02/51668002/htdocs/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 34)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,

    Leider noch nicht konfiguriert, da ich da etwas unsicher bin. Habe das Plugin jetzt wieder deaktiviert.

    da kann eigentlich gar nichts passieren. Ich würde einfach das Plugin mal aktivieren und auf dem ersten Reiter „JS, CSS & HTML“ alles ankreuzen. Danach testen und mal sehen, ob es irgendwelche Darstellungsprobleme gibt.

    Wäre schön, wenn Du mal überprüfen könntest, ob die Homepage jetzt einigermaßen flüssig läuft.

    läuft schon flüssig, aber die Ladezeit bei Pingdom ist eher schlecht: Load time
    6.03 s. Hier kann man sicher noch einiges optimieren.
    Je nach theme wird automatisch eine entsprechende Anzahl der Bilder mit verschiedenen Größen angelegt (das hat was mit den Darstellungen auf den unterschiedlichen Geräten zu tun, siehe hier)
    Viele Grüße
    Hans-Gerd

    ngbrnet

    (@ngbrnet)

    Ich hab den Eindruck, dass es mit dem Autoptimize noch langsamer ist.(9,22s) 🙁
    Gruß Norbert

    • Diese Antwort wurde geändert vor 1 Jahr von ngbrnet.
    Moderator Torsten Landsiedel

    (@zodiac1978)

    Gzip aktivieren und Browser Caching aktivieren würde schon helfen
    https://gtmetrix.com/reports/www.krefelder-fotofreunde.de/CZ6gwFul

    Bei welchem Hoster bist du denn?

    Gruß, Torsten

    ngbrnet

    (@ngbrnet)

    Ich bin bei Strato.
    Von Gzip und Browser Caching hab ich leider keine Ahnung.
    Gruß Norbert

    • Diese Antwort wurde geändert vor 1 Jahr von ngbrnet.
    Daniel X

    (@fibmyefriblot_doj)

    hast Du schon getestet, wie die Website sich verhält, wenn …

    • ein anderes Theme (Twenty Nineteen) testweise aktiviert ist?
    • alle Plugins testweise kurz deaktiviert sind?
    Moderator Hans-Gerd Gerhards

    (@hage)

    @ngbrnet,
    vielleicht hilft Dir dieser Link mit Infos zu GZIP und Browsercaching bei Strato.
    Erstelle aber bitte vorher eine Sicherungskopie der .htaccess – Datei (z. B. Runterladen auf Deinen Rechner)

    Daniel X

    (@fibmyefriblot_doj)

    Wenn Dir manuelle Eingriffe in die htaccess zu heikel sind, probiere es mal mit dem Plugin »WP Fastest Cache«: da lassen sich Cache und GZIP zum Testen einzeln aktivieren.

    Aber sei vorsichtig: wenn Du zu viel aktivierst, funktioniert die Website bisweilen ganz schnell nicht mehr.

    ngbrnet

    (@ngbrnet)

    @daniel, @Hans-Gerd
    Das liest sich alles ganz einfach, ein mulmiges Gefühl habe ich trotzdem dabei. Wenn ich das richtig begriffen habe, wird ausschließlich die htaccess verändert. Wenn ich mir diese Datei sichere und später, wenn alles nicht mehr gehen sollte, ich diese Datei wieder zurücksichere, müsste ich meinen jetzigen Zustand wieder haben? Sehe ich das richtig?
    Gruß Nobert

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo Norbert,
    das sollte kein Problem sein, wenn Du per FTP auf Deinen Webspace zugreifen kannst.
    Aber vielleicht testest Du das erst mal mit den genannten Plugins (Autoptimize und Cache Enabler ODER Fastest Cache). Im schlimmsten Fall deaktivierst Du das jeweilige Plugin einfach wieder.
    Viele Grüße
    Hans-Gerd

    ngbrnet

    (@ngbrnet)

    Autoptimize hab ich schon probiert, wurde eigentlich noch schlechter, so mein Gefühl. In meine htaccess habe ich mit einem normalen Texteditor gerade reingeschaut, da steht folgendes drin (allerdings mit viel größeren Leerzeilen):
    #######################################################################
    # Diese .htaccess wurde vom STRATO-Webservermanager erstellt #
    #######################################################################

    Options -Indexes

    DirectoryIndex index.php

    # BEGIN WordPress

    # END WordPress

    Moderator Hans-Gerd Gerhards

    (@hage)

    Autoptimize hab ich schon probiert, wurde eigentlich noch schlechter

    … kann ich mir eigentlich nicht vorstellen, wenn Du die Einstellungen entsprechend geändert hast. Autoptimize setze ich zusammen mit Cache Enabler auf einigen Seiten erfolgreich ein.
    Zu der .htaccess hatte ich Dir bereits heute morgen einen Link gesendet, in dem alles drin steht. Wichtig ist allerdings, dass Du einen Editor wie z. B. notepad++ oder Atom verwendest.

    ngbrnet

    (@ngbrnet)

    Ich werde das mal mit der htacces-Datei versuchen. Habe allerdings einen Mac und ich hoffe, das klappt auch mit dem Editor „TextEdit“.
    Gruß Norbert

    ngbrnet

    (@ngbrnet)

    Ich bins nochmal. der nervige Norbert 😉

    Mit Fastest Cache bin ich nicht zurecht gekommen, da alles in englisch. Deshalb habe ich mir den Link vorgenommen, den Hans-Gerd mir genannt hat. Also alles in die htaccess reinkopiert und folgendes Ergebnis lt. PageSpeed bekommen:

    vorher mobil 13 und desktop 62
    nachher mobil 69 und Desktop 86

    Ich glaube, die Steigerung ist ok. Sollte ich nochmal mit Autoptimize arbeiten oder bringt das nichts?

    Gruß Norbert

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo Norbert,
    das hört sich doch gut an. Du kannst ja noch mal Autoptimize testen – schaden kann es nicht.
    Viele Grüße
    Hans-Gerd

    ngbrnet

    (@ngbrnet)

    Autoptimize habe ich getestet, allerdings war es nicht unbedingt besser.
    Es war eher ein auf und ab, mal besser, beim nächsten Test schlechter und dann wieder gleichbleibend. Also irgendwie bringt das Tool nicht mehr viel.
    Aber ich bin jetzt schon sehr zufrieden mit der Geschwindigkeit, auch wenn sie nicht optimal ist.
    Vielen Dank für Eure Hilfe

    Gruß Norbert

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 34)
  • Das Thema „WordPress ist sehr langsam“ ist für neue Antworten geschlossen.