Support » Allgemeine Fragen » WordPress lädt Bilder nicht korrekt?

  • Hallo,

    Wir haben zur Zeit das Problem, das etwa 3 von 5 Benutzer verpixelte Bilder haben auf der Startseite (nur auf der Startseite) nach langem Suchen haben wir jetzt herausgefunden, dass je nach Computer/Browser und Internet Verbindung nur etwa 70KB vom Bild herunterlädt und dadurch natürlich das Bild total unscharf ist. Die Bilder im Headerbereich sind alle rund 1-2MB daher sollte das ja nicht wirklich ein Problem darstellen. Wie kann ich also einstellen, dass er immer gezwungen wird die Bilder komplett herunterzuladen?

    Bei der Seite chrispix.ch sind die Bilder im Headerbereich 8MB und auch immer scharf und lädt auch immer das komplette Bild herunter.

    Vielen Dank für jede Hilfe

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hi!

    Welches Plugin nutzt du denn für die Darstellung des Sliders (unabhängig von der Frage: Ein bis zwei MB pro Bild sind schon ziemlich groß, erst recht wenn sie nur abgedunkelt im Hintergrund abgezeigt werden – da solltest du vielleicht noch ein bisschen optimieren, damit die maximal nur so ein paar 100 KB haben 🙂 )?

    Viele Grüße
    Florian

    Hallo theboom,

    beim ersten Aufruf der Startseite werden alle Fotos als Thumbnails geladen und auf 100% Breite plus Höhe auto gezogen. Beim Refresh der Seite werden die Fotos in korrekter Dateigröße geladen.

    Siehe (Headerbild)
    https://cl.ly/mayH/first.jpg

    Anderes Foto der Startseite beim ersten Aufruf
    cl.ly/mbh7/19-09-_2017_14-49-45.jpg

    Dasselbe Foto nach Refresh
    cl.ly/mb20/refresh.jpg

    Was Florian über die Dateigröße schrieb, ist absolut richtig. Aktiviere einmal die Developertools deines Brwosers und schaue unter Netzwerk wieviel Zeit das Laden eines Fotos benötigt. Weitere Infos über Bildkomprimierung findest du auch dort.

    Thread-Ersteller theboom

    (@theboom)

    Vielen Dank schon einmal für die Hilfe! Ich habe jetzt alle Bilder optimiert/komprimiert auf 100 bis max. 400kb. Leider sind die Bilder beim erst Aufruf immer noch verpixelt, wieso er beim erst Aufruf immer nur eim Thumbnail herunterlädt ist mir ein Rätsel. Weiss jemand wie man das sperren/deaktivieren kann?

    Im Headerbereich ist der Content Slider von Visual Composer 5.2 eingesetzt, ich vermute es liegt aber nicht an dem, da ja die anderen Bilder auch verpixelt sind.

    Beste Grüsse
    marc

    Mich macht die CSS-Klasse „adaptive-async adaptive-fetching“ stutzig, siehe
    https://d3vv6lp55qjaqc.cloudfront.net/items/0u3z2y1b3C1J2U000g3c/first.jpg

    Hast du irgendein Mobile-Plug-in installiert?
    Falls nicht, hilft dir wohl nur das Ausschlussverfahren (Plug-ins, Theme).
    Also alle Plug-ins deaktivieren, prüfen, falls das Problem behoben ist, ein Plug-in aktiviern, prüfen, bis du das verursachende Plug-in gefunden hast. Falls das Problem weiterhin existiert, Theme wechseln, prüfen.

    Thread-Ersteller theboom

    (@theboom)

    Ich habe gerade eine Einstellung betreffend der adaptive async deaktiviert in den theme options und sowie es aussieht hat diese Einstellung das verursacht, ich muss morgen noch auf den anderen Computern testen ob die Bilder da jetzt auch scharf sind. Vielen dank für die Hilfe!!

    Gerne :). Feedback von hier: Der Fehler scheint behoben zu sein, Fotos werden jetzt direkt korrekt geladen.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „WordPress lädt Bilder nicht korrekt?“ ist für neue Antworten geschlossen.