Support » Allgemeine Fragen » WordPress Login funktioniert nicht – Fehler: Cookies gesperrt

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 29)
  • Hallo Madlin,

    Aber weiterhin die selben __Fehlermeldungen__.

    wieso verwendest du am Schluss wieder die __Mehrzahl__? Davor schreibst du doch, es werde „nur noch [der] Cookie Fehler“ gemeldet. Wieviele sind es jetzt genau und wie ist der exakte Wortlaut? Gibt es dabei Pfadangaben zu Dateien?

    Thread-Starter madlin2016

    (@madlin2016)

    Hallo Flower33,

    Entschuldige bitte. Also wenn ich momentan http://www.west-coast-dreams.com/wp-login.php aufrufe kommt folgende Meldung:

    Logging in with WordPress.com is not currently available because this site is experiencing connection problems.
    FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an die Support-Foren.

    Diese Dokumentation: https://codex.wordpress.org/Cookies
    Support-Foren: https://de.wordpress.org/hilfe/

    Ich bin der Dokumentation gefolgt und habe die cookies, chache & history geloescht. Versuche ich mich dann anzumelden passiert erst mal gar nix. Die Seite bleibt unveraendert.

    Wenn ich http://www.west-coast-dreams.com/wp-admin/ eingebe, kommt nur eine weisse Seite.

    Ich habe jetzt versucht mich mal unter WordPress.com anzumelden. Das hat funktioniert, aber in der Benutzeroberflaeche kann ich keine Einstellungen / Plugins / Daten einsehen.
    Hier kommt oben rechts in einem roten Feld: Es ist ein Fehler beim Abrufen deiner Website-Einstellungen aufgetreten.- Vergewisser dich, dass dein Jetpack auf dem neusten Stand ist.
    Vll. ist das ein Ansatz fuer meine Problemloesung.

    Desweiteren ist es jetzt auf einmal wieder moeglich die Seite wenigstens wieder anzusehen. Egal in welchem Browser. Das hat vor einer Stunde noch nicht funktioniert. Aber warum dies auf einmal funktioniert kann ich mir leider auch nicht erklaeren. Aber wenigstens was!

    • Diese Antwort wurde geändert vor 7 Jahren, 7 Monaten von madlin2016.

    Ich habe jetzt versucht mich mal unter WordPress.com anzumelden

    Aber wir reden hier von einer selbstgehosteten WordPress-Installation, richtig?
    Hast du mal nach Erscheinen der Fehlermeldung „Refresh“ (F5) gedrückt?
    Hast du ein Caching-Plugin aktiv?
    Hast du den Plugin-Ordner des Jetpack-Plugins mal per FTP umbenannt, um Jetpack zu deaktivieren?

    Thread-Starter madlin2016

    (@madlin2016)

    Ja wir reden hier von einer selbstgehosteten WordPress Installation. Bei wordpress.com hab ich nur einen Account wegen dem Jetpack Plugin. Ich dachte nur das ich hier vll. etwas rausfinden kann.

    Nach dem Erscheinen der Fehlermeldung habe ich Refresh F5 gedrueckt – Die Fehlermeldung ist noch da!

    Ich habe einen Plugin namens Cachify (Ich denke mal das dies so ein Caching Plugin ist) – diesen hab ich jetzt im FTP deaktiviert und auch den Jetpack Plugin habe ich deaktiviert. – Leider immer noch keine Aenderung an der Fehlermeldung.

    URL-Änderung

    Schau auch mal nach, ob evtl. nach deiner URL-Änderungsaktion in der wp-config.php oder in der .htaccess falsche URLs hartgecodet sind.

    Jetpack

    Vergewisser dich, dass dein Jetpack auf dem neusten Stand ist.
    Vll. ist das ein Ansatz fuer meine Problemloesung.

    Zumindest laut Quelltext deiner Seite ist Jetpack auf dem neuesten Stand:

    
    wp-content/plugins/jetpack/css/jetpack.css?ver=4.3.2
    

    Vgl.
    https://github.com/Automattic/jetpack/blob/master/changelog.txt

    Um ganz sicher zu gehen, dass eine aktuelle und fehlerfreie Jetpack-Version zur Verfügung steht und keine Altlasten reinspielen, könntest du die aktuelle per FTP löschen und eine ganz frische hochladen:

    https://jetpack.com/support/how-to-install-the-security-update/#ftpupdate

    Caching-Plugin

    Bei Caching-Plugins reicht ein Deaktivieren oft nicht aus, d.h., das könntest du, wenn nötig, auch per FTP löschen und später eine frische Version hochladen.

    Kodierung

    Nach deiner bisherigen Bescheibung eher nicht der Fall (sonst oft Teil der Lösung bei dieser Fehlermeldung), sondern vermutlich auf die URL-Änderung zurückzuführen, aber bei wp-config.php, .htaccess und functions.php deines Themes sicherheitshalber überprüfen, ob auch die Kodierung UTF-8 ohne BOM eingetellt ist. Diese Prüfung unbedingt mit einem Texteditor machen, der das auch kann (z.B. Notepad++, nicht das normale Notepad in Windows), sonst entstehen neue Probleme wegen falscher Kodierung.

    • Diese Antwort wurde geändert vor 7 Jahren, 7 Monaten von Flower33.
    • Diese Antwort wurde geändert vor 7 Jahren, 7 Monaten von Flower33.

    Beim etwaigen Löschen des Caching-Plugins die Vorgaben in den FAQ des jeweiligen Plugins beachten!

    Thread-Starter madlin2016

    (@madlin2016)

    Ich danke dir erst mal fuer deine viele Hilfe. Aber es funktioniert immer noch nicht.

    Also als erstes habe ich den Cachify Plugin ueber FTP entfernt. Das hatte erst mal nix gebracht.
    Danach habe ich die die Kodierungen von wp-config.php .thaccess und functions.php mit dem Editor Notepad++ ueberprueft. Diese sind alle auf UTF-8 ohne BOM eingestellt.

    Das Jetpack Plugin habe ich im FTP geloescht und die aktuellste Update Version wieder ueber FTP hochgeladen.

    Nach dem Refreshen ist hier nur die eine Sache passiert:
    Der Text ueber dem Fehler: „Logging in with WordPress.com is not currently available because this site is experiencing connection problems.“ ist jetzt weg.
    Der urspruengliche Fehler ist aber noch da.
    (FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an die Support-Foren.)

    Ich habe mir die wp-config.php und die .htaccess mal angeschaut wegen den URLs.
    Aber ich hab irgendwie gar nix dazu gefunden. Hier sind mal die beiden Dateien. Ich hab da halt keine Ahnung ob an denen was verkehrt ist oder nicht.

    wp-config.php

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen mit dem Namen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define('DB_NAME', 'xxx');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', 'xxx');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', 'xxx');
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define('DB_HOST', 'xxx');
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'xxx');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     … [gelöscht]
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix  = 'xxx';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');

    Und hier ist die .htaccess Datei

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Moderationshinweis: Code-Auszeichnung korrigiert. Bitte nutze demnächst das den Button „code“ im Beitragseditor, um Code korrekt zu formatieren. Danke, Bego

    In solchen Fällen ist es hilfreich, wenn du zuerst einmal das Debugging aktivierst, indem du in der wp-config.php die Konstante auf true setzt:
    define( 'WP_DEBUG', true );`

    Für Jetpack gibt es auch einen Debug-Modus, der vor allem dafür sorgt, dass die Verbindung zu WordPress.com unterbunden wird. Dazu trägst du in der wp-config.php folgendes ein:
    define( 'JETPACK_DEV_DEBUG', true);

    Erhältst du anschließend weitere Fehlermeldungen?

    Thread-Starter madlin2016

    (@madlin2016)

    Hallo Bego,

    ich habe das Debugging in der wp-config.php aktiviert und dann die Datei wieder hochgeldaen. Da ist nach dem Refreshen leider nix passiert. Danach habe ich dann noch den Jetpack Debug-Modus eingebunden, aber auch das hat leider keine Aenderung an der Fehlermeldung gebracht.
    Weiterhin wird folgender Fehler auf der Anmeldeseite angezeigt:

    (FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an die Support-Foren.)

    Das ist aber ein besonders hartnäckiger Fall, bei dem keine der gängigen Troubleshooting-Maßnahmen greift.

    (1)
    Bist du sicher, dass Website-URL und WordPress-URL korrekt eingetragen sind? Das hast du zwar anfangs mit Bezug auf die Datenbank-Einträge in wp_options so gesagt, aber bei der Notation können kleine Abweichungen genügen, um den Fehler hervorzurufen, z.B. ein übersehenes Leerzeichen am Schluss etc. Schau dir das nochmal genau an und gebe es am besten hier mit der richtigen Code-Auszeichnung wieder. Oben schreibst du, beide URLs seien identisch. Liegt also die WordPress-Installation wirklich nicht in einem Unterordner?

    (2)
    Für den Fall, dass es eine Multisite-Installation sein sollte (haben wir kürzlich in einem anderen Fall auch erst ganz am Schluss erfahren), würde ich testweise mal Folgendes in die wp-config.php eingeben:

    
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');
    

    Falls es nichts bringt, einfach wieder löschen.

    (3)
    Noch zum vorhergehenden Beitrag:
    Denke dran, den Debug-Modus wieder zu deaktivieren (auf „false“ setzen), da bei dauerhaft eingeschaltetem Debug-Modus Sicherheitsrisiken bestehen.

    Thread-Starter madlin2016

    (@madlin2016)

    Ich habe jetzt noch mal in meiner Datenbank nach den beiden URL’s geschaut. Diese sind wirklich beide gleich und keine Leerzeichen davor oder danach:

    
    http://www.west-coast-dreams.com
    

    Hier ist die Ordner Folge auf meinem FTP-Server:

    /…
    /cgi-bin
    /westcoastdreams
    Und in diesem Ordner liegt die WordPress Installation mit allen Unterordner (wp-admin, wp-content, wp-includes und die einzelnen Dateien wie .htaccess und wp-config.php, ect….)

    Heisst das, ich muss bei Site URL hinter http://www.west-coast-dreams.com ein /westcoastdreams angeben?

    Den Debug-Modus habe ich bereits wieder deaktiviert. Ich werde jetzt noch deinen Punkt Nr. 2 versuchen.

    Vielen Dank fuer eure Unterstuetzung…

    Heisst das, ich muss bei Site URL hinter http://www.west-coast-dreams.com ein /westcoastdreams angeben?

    Nein. Müsste so OK sein.
    Du hattest oben geschrieben:

    Die Website kann auch nicht mehr angezeigt werden.

    Sie wird bei mir aktuell angezeigt. War die Startseite auch vorher ohne Inhalte? Andere Seiten haben Inhalte. Die Login-Seite zeigt aktuell weiterhin den Cookie-Fehler.

    Thread-Starter madlin2016

    (@madlin2016)

    Ja am Anfang hat es mir die Website nicht mehr angezeigt..
    Nachdem ich das kostenpflichtige Backup von Hosteurope bekommen habe, hat es die Seite wenigstens wieder angezeigt, aber der Login ging trotzdem nicht (Cookie-Fehler)
    Wie du gerade gesagt hast, wird momentan die Startseite nicht komplett angezeigt. Das ist neu!!! Da muesste normaler Weise ein Inhalt zu sehen sein. 6 Verschiedene Bilder die auf meine Touren Seiten weiterleiten. So was hab ich denn jetzt wieder verstellt, das die Startseite nicht mehr richtig angezeigt wird?!

    Nochmal zu deiner Frge:

    Heisst das, ich muss bei Site URL hinter http://www.west-coast-dreams.com ein /westcoastdreams angeben?

    Ich bin mir nicht 100%-ig sicher, da ich die tatsächliche Ordnerstruktur nicht vor meinen eigenen Augen habe und nicht absolut sicher aus deiner Notation ersehen kann, ob das jetzt ein Unterordner /westcoastdreams ist oder nicht.

    als ich versehentlich die Site-URL in den allgemeinen Einstellungen veraendert habe.

    Ein paar Details zu diesem Punkt wären vielleicht nicht schlecht.

    Thread-Starter madlin2016

    (@madlin2016)

    Warum ich dort ueberhaupt was aendern wollte:

    Ich habe bei meinem Webhoster noch eine 2. Domain bestellt www.west-coast-dreams.de
    Mein Vorhaben war, da ich ja eine 2 sprachige Website habe, dass die .de Domain auf die Deutsche Seite leitet und die .com Domain auf die Englische.

    Ich dachte wenn ich bei Home URL http://www.west-coast-dream.com/en (Das ist der Pfad fuer die Englische Startseite) eingebe, dann kommen die Leute automatisch auf bei eingabe von http://www.west-coast-dreams.com auf die Englsiche Seite. Die .de Domain wollte ich dann auf die Deutsche Starteseite (die momentan unter http://www.west-coast-dreams.com zu erreichen ist) umleiten.

    Mein Vorhaben /en hinter die Home URL zu schreiben, hat erst mal nicht funktioniert. Es hat immer noch die Deutsche Seite angezeigt.
    Deshalb habe ich das /en dann hinter die Website URL geschrieben. Das war der Punkt wo mich WordPress dann rausgeschmissen hat und ich mich nicht mehr anmelden konnte.

    Das ist die Zusammenfassung meiner Misere!!!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 29)
  • Das Thema „WordPress Login funktioniert nicht – Fehler: Cookies gesperrt“ ist für neue Antworten geschlossen.