Support » Allgemeine Fragen » WordPress Login nicht möglich (Login Redirect)

  • Hallo zusammen,

    seit einigen Tagen kann ich mich nicht mehr bei WordPress anmelden. Jedes Mal, wenn ich meine Anmeldedaten eingeben und auf einloggen klicke komme ich wieder auf die Anmeldeseite zurück.

    Bei der WP Installation handelt es sich um ein Managed WordPress von IONOS. Der Support dort konnte mir allerdings nicht weiterhelfen und hat mich an den WordPress Support verwiesen.

    Ich habe schon ein wenig recherchiert und gelesen, dass es sich hierbei vermutlich um einen Login Redirect Fehler handelt. Ich habe dazu auch schon einige Lösungsvorschläge gelesen. Die erfordern das Eingreifen in die Installation per FTP Server. Da bin ich immer etwas unsicher. Vielleicht kann mir hier ja jemand weiterhelfen.

    Ich lade jetzt erst einmal die Sicherungskopie herunter. Sicher ist sicher.
    Danke schon einmal.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo,
    hast du das mal mit einem anderen Browser getestet und/oder den Browsercache gelöscht?

    Evtl. hilft es auch, wenn du per FTP die .htaccess zunächst als Sicherung auf deinen Rechner kopierst. Wenn du dich dann wieder anmelden kannst, wird die .htaccess durch Aufruf von Einstellungen > Permalinks neu erstellt.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Der Support dort konnte mir allerdings nicht weiterhelfen und hat mich an den WordPress Support verwiesen.

    Klarer Fall für Super- @krafit. 🦸🏻‍♂️

    (siehe https://de.wordpress.org/support/topic/seite-laedt-beim-ersten-aufruf-langsam/#post-128395)

    Ich hatte diesen Thread schon im Auge,
    ich werde sehen was ich tun kann, aber vielleicht muss ich mir später noch ein explizites “Go” von @merlenkamp abholen.

    Moderator Bego Mario Garde

    (@pixolin)

    @krafit

    Ich hatte diesen Thread schon im Auge …

    Ich hatte schon angenommen, dass du einen Stichwort-Filter verwendest.
    Superhelden ohne Capes … 😉

    Demnächst gibt’s dann kein unnötiges Ping. 🙂

    Thread-Ersteller merlenkamp

    (@merlenkamp)

    Guten Abend,

    vielen Dank schon einmal für die schnellen Rückmeldungen.

    Folgendes habe ich in der Zwischenzeit versucht.

    – Browsercache löschen
    – anderen Browser testen (Edge)
    – .htaccess vom Server löschen
    – Seiten URL in wp-config erneuern
    – einzelne Plugins durch umbenennen deaktivieren

    Im Vorfeld hatte ich auch schon einmal mein Passwort zurückgesetzt. Außerdem hat der Support von IONOS auch noch ein Captcha Plugin deaktiviert.

    Allerdings glaube ich gerade, dass ich es noch schlimmer gemacht habe. Nun kann ich nämlich einzelne Blockbeiträge nicht mehr anzeigen. Lediglich die Startseite ist anzeigbar.

    – einzelne Plugins durch umbenennen deaktivieren

    Bitte deaktiviere alle Plugins (einfach den gesamten plugin Ordner umbenennen) und nochmal den Login versuchen.

    Wenn es dann noch nicht klappt, einmal den theme Ordner umbenennen.

    Das die Unterseiten nicht mehr funktionieren liegt vermutlich an der entfernten htaccess

    Thread-Ersteller merlenkamp

    (@merlenkamp)

    Danke für die Tipps.

    habe beides ausprobiert. Leider ohne Erfolg.
    Auch nach nochmaligem Löschen des Browsercaches.

    Okay 😮 das ist schon recht ungewöhnlich.
    Was passiert wenn du einen anderen (zufällig gewählten) Benutzer mit einem zufälligen passwort als login versuchst?

    Thread-Ersteller merlenkamp

    (@merlenkamp)

    Ja, das habe ich mir auch gedacht.
    So ein Problem habe ich mit WP noch nicht gehabt.

    Ich habe die Anmeldung bereits mit zwei Benutzern ausprobiert.
    Einmal dem Admin und einmal mit einem anderen User.
    Das Ergebnis war beide Male das Gleiche. –> Kein Login möglich.

    Hmm, gibt’s einen mu-plugins Ordner? Eventuell auch nochmal umbenennen. Oder in der wp-config.php irgendwelche Einträge die es im Standard nicht gibt?

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von Michi91.
    Thread-Ersteller merlenkamp

    (@merlenkamp)

    Einen mu-plugins Ordner gibt es. Habe den auch gerade einmal umbenannt. Hat aber nichts gebracht.

    Irgendwie habe ich tatsächlich die wp-config im Verdacht. Wenn ich die mit der wp-config-sample vergleiche gibt es da schon einige Unterschiede.

    Da es sich bei meiner WP Installation allerdings um ein Managed WordPress handelt habe ich (zumindest soweit ich weiß) keinen Zugriff auf die Datenbank.

    Vermutlich muss ich mich mit den neuen Erkenntnissen doch noch mal bei IONOS melden.

    Hallo,
    für die Änderung der wp-config.php benötigst du allerdings keinen Datenbankzugriff. Wenn du per FTP zugreifen kannst, dann könntest du nach Sicherung der wp-config.php auf deinem lokalen Rechner die Datenbankzugangsdaten in die wp-config-sample.php eintragen, diese Datei als wp-config.php umbenennen und dann wieder hochladen, um das zu testen.

    Bezüglich Datenbankzugriff per phpMyAdmin könntest du noch Kontakt zum Support aufnehmen.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller merlenkamp

    (@merlenkamp)

    Vielen Dank für die Hilfe.

    Ich habe gerade noch einmal mit dem IONOS Support gesprochen. Nun wurde mir mitgeteilt, dass es ein Problem mit der Datenbank gibt. Das soll morgen im Laufe des Tages behoben werden. Danach soll ich mich dann wieder anmelden können.
    Ich bin gespannt.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)