Support » Allgemeine Fragen » WordPress Login Page übersetzen

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Schau mal, was unter Einstellungen > Allgemein als Sprache der Website eingestellt ist. Wenn du dort „Deutsch“ auswählst, wird die informelle Übersetzung geladen, bei „Deutsch (Sie)“ die formelle Variante mit der Anrede „Sie“.
    Nach der Sprachauswahl kannst du unter Dashboard > Aktualisierungen die Übersetzung aktualisieren – die Sprachdateien werden dann automatisch heruntergeladen und installiert.

    Thread-Starter calaiopee

    (@calaiopee)

    Danke, schonmal! Die Sprache ist auf Deutsche eingestellet und alle Übersetzungsdateien sind auf dem neuesten Stand. Die Strings im Login Formular sind jedoch weiterhin auf dem alten Stand, in Englisch. Wie einige andere Strings. Sie erscheinen in den Loco- .po Dateien übersetzt – werden aber im Frontend nicht übersetzt.

    Danke weiterhin …
    Cali

    Es ist gut möglich, dass das von dir verwendete Theme das Anmeldeformular anders ausgibt und entweder Zeichenfolgen des Themes noch nicht übersetzt wurden oder das Theme nicht die Übersetzungsfunktionen verwendet, die für eine Übersetzung notwendig sind.

    Probier doch mal, wie das Anmeldformular aussieht, wenn du ein Standard-Theme (z.B. „Twenty Twenty One“) verwendest. Das kannst du mit Hilfe des Plugins Health Check auch über einen „Problembehandlungsmodus“ so machen, dass niemand davon etwas mitbekommt.

    Bei Fragen zu gekauften Themes (hier: BuddyBoss Theme) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Thread-Starter calaiopee

    (@calaiopee)

    Danke, ich bin mit Deinem Tip zu den Themes weitergekommen. Das Übrersetzungsmanagment ist ein ziemliches Gewurschtel weil die Dokumentation eher dürftig ist. Nun ist das Problem aber gelöst.

    andreassokol

    (@andreassokol)

    Wie gadt Du das Problem gelöst?

    Ich habe das gleiche Problem zZ.

    Gruss
    Andreas

    Thread-Starter calaiopee

    (@calaiopee)

    Hi Andreas,

    ich habe in Loco für alle relevanten Themes (Haupt- und Child Themes) und alle relevanten Plugins (buddyboss BuddyBoss Platform, BuddyBoss Platform Pro und BP registration Options) die Übersetzungsdateien individuell gespeichert in
    wp-content/languages/loco/plugins/ oder /themes/ und habe alle anderen Übersetzungsdateien aus dem Systemverzeichnis und dem Verzeichnis des Paktes rausgelöscht. Wenn Loco nur eine einzige Datei zur Verfügung hat, nimmt es die auch überall. Bei mehreren Dateien gibts Gewurschtel.

    Ich muss nach jedem Update von Themes oder Platform wieder die „neu“ geladenen Übersetzungsdateien weglöschen. Sonst erscheint an diversen Stellen un- oder halbübersetzter Quatsch.

    Hilft das?

    LG
    Cali

    andreassokol

    (@andreassokol)

    Hallo Cali,

    heißt das Du hast nur noch eine po Datei für alle Plugins?

    LG
    Andreas

    Thread-Starter calaiopee

    (@calaiopee)

    Hi Andreas, nein, ich habe für JEDES Plugin und JEDES Theme nur EINE deutsche po/mo und die ist im Ordner „Individuell“ (wp-content/languages/loco/plugins/ oder /themes/ ) gespeichert. //Gehe im Dashboard auf LOCO -> Plugis -> BubbdyBoss Platform Pro. Da sollte dann eine Liste mit Übersetzungen auftauchen, die ausschließlich eine deutsche po enthält, in der Spalte ORDNER steht „Individuell“.

    Schau Dir vielleicht das hier mal an.https://localise.biz/wordpress/plugin/manual/settings?utm_medium=plugin&utm_campaign=wp&utm_source=admin&utm_content=config

    Und ich gehe davon aus, dass Du vollen FTP Zugriff hast und alles.

    Klärt das die Sachlage?

    LG
    Cali

    andreassokol

    (@andreassokol)

    Hallo Cali,

    FTP Zugang ist vorhanden. Alle POs jetzt in
    wp-content/languages/loco/plugins/ oder /themes/

    Trotzdem sehe ich noch MischMasch. trotz cacheLeerung

    Hast Du eine Synchronisierung durchgeführt?

    LG
    Andreas

    Moderator Bego Mario Garde

    (@pixolin)

    Trotzdem sehe ich noch MischMasch.

    Dazu zitiere ich mal rasch meine eigene Antwort hier:

    Es ist gut möglich, dass das von dir verwendete Theme das Anmeldeformular anders ausgibt und entweder Zeichenfolgen des Themes noch nicht übersetzt wurden oder das Theme nicht die Übersetzungsfunktionen verwendet, die für eine Übersetzung notwendig sind.

    Moderator Bego Mario Garde

    (@pixolin)

    @calaiopee

    Ich muss nach jedem Update von Themes oder Platform wieder die „neu“ geladenen Übersetzungsdateien weglöschen.

    Dann speicherst du deine Übersetzungen an der falschen Stelle.

    Hier gibt es einen (englischen) FAQ-Beitrag von den Loco-Translate-Entwicklern dazu:

    Disappearing files

    Thread-Starter calaiopee

    (@calaiopee)

    Hi ihr beiden!

    Ich habe kein Problem mit verschwundenen Dateien. Meine Dateien sind und bleiben stets vorhanden.

    Nach einem Update (von BuddyBoss Theme oder BuddyBoss Platform) jedoch, habe ich eine neue Übersetzungsdatei im System- und eine im Plugin Package-Ordner. Und wenn diese da sind, ZUSÄTZLICH zu meiner Datei, die nach wie vor in „Individuell“ gespeichert ist, habe ich im BuddBoss Frontend Sprachmischmasch. So, als würde Buddyboss auf die unvollständigen Dateien, die mit dem Update aufgespielt wurden, zurückgreifen. Anstatt auf meine 100% Datei in „Individuell“.

    Und wenn die neu aufgespielten Dateien dann lösche, ist alles in Ordnung.

    Jedoch auch NUR dann. Die Funktionalität unter „Kopieren oder als Vorlage verwenden“ hat mir mit zig Versuchen nichts gebracht.

    Ich will nicht ausschließen, dass ich irgendwas in Loco nicht richtig verstehe und/oder mit anderen Einstellungen weiter käme.
    Ich will nur sagen: dass ist der einzige Weg, den ich kenne, der für mich funktioniert.

    @andreassokol :

    Trotzdem sehe ich noch MischMasch. trotz cacheLeerung

    hast Du die anderen Dateien denn gelöscht?

    andreassokol

    (@andreassokol)

    Also: Ich sehe Licht am Ende des Tunnels.

    Cache geleert. Alles Dateien werden angesprochen. Jetzt fehlen mir nur noch einige wenige Stellen. Die werde ich auch hinbekommen.

    Vielen Dan Euch beiden für die Hilfe!

    Gruss
    Andreas

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „WordPress Login Page übersetzen“ ist für neue Antworten geschlossen.