Support » Allgemeine Fragen » WordPress login / Strato

  • Vielleicht kann mir jemand helfen.
    Ich habe eine Hauptdomain bei Strato und dort Wortpress erstellt. Hat alles funktioniert.
    Nun habe ich auch eine Subdomain erstellt.
    Diese habe ich auf meine alte Website auf WIX umgeändert ( hier musste ich den Cname ändern ). Dann habe ich eine Umleitung von der Haupt zu der Sub erstellt ( da die Hauptdomain bei WordPress bearbeitet wird )
    Jetzt komme ich nicht mehr in den Admin login von der WordPress Seite der Hauptdomain. Ist jetzt alles weg? In der Datenbank von Strato ist noch alles vorhanden.
    ( Ich habe gesehen, dass der Cname auch auf die Hauptdomain verändert wurde. Gibt es ein Cname für WordPress? )

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Dann habe ich eine Umleitung von der Haupt zu der Sub erstellt

    Da wird vermutlich der Fehler liegen. Wie bist du denn da vorgegangen? Ist das eine Einstellung im Kundenmenü oder ein Eintrag in der .htaccess?

    Thread-Ersteller uniquephoto

    (@uniquephoto)

    Ich hab die Umleitung gelöscht, aber es geht trotzdem nicht. Ich weiß nicht was .htaccess ist. Also denke ich nicht. Ich habe bei der Subdomain den CName verändert.

    Zur Serverkonfiguration musst du dich bitte an deinen Webhoster wenden. Dazu können wir hier nicht helfen.

    Nehmen wir an, du hast eine Domain abc.de bei einem Webhoster A.
    Du möchtest nun diese Domain für deine Website beim Webhoster B verwenden.
    Dazu trägst du beim Webhoster A die IP-Adresse des Webservers bei Webhoster B ein. Außerdem musst du bei Webhoster B angeben, welches Verzeichnis mit der Domain verknüpft ist. In diesem Verzeichnis kannst du dann auch eine weitere WordPress-Installation nutzen.

    Bei einem CName (einem kanonischen Namen) ist das etwas anders. Hier sagst du deinem Webhoster B „pass auf, da kommen auch Anfragen für eine andere Domain, die leitest du bitte auf die Hauptdomain um“.

    … aber es geht trotzdem nicht.

    … ist regelmäßig eine Stelle, an der ich nicht weiterkomme. Was genau hast du gemacht? was genau funktioniert nicht? wie sollte es funktionieren?

    Da wie gesagt Serverkonfiguration hier off topic ist, wende dich am besten an den Support des Webhosters. Erstell im Web-Stammverzeichnis und im Unterverzeichnis eine index.html mit unterschiedlichem Inhalt und sag dem Mitarbeiter, dass beide Webseiten erreichbar sein sollen, die zweite aber über deine andere Domain. Damit vermeidest du, dass der Support dort wieder kneift und sich damit herausredet, für Webanwendungen seien sie nicht zuständig.

    Thread-Ersteller uniquephoto

    (@uniquephoto)

    Danke dir. Ich habe beim Service nachgefragt und sollte bei den Fehler Logs schauen. Leider meinte der Service, dass es außerhalb ihres Services liegt…

    Vielleicht kennt sich jemand von euch asu: Das ist der Fehler:

    PHP Warning: Attempt to read property „post_type“ on null in /mnt/web210/c2/30/511785330/htdocs/STRATO-apps/wordpress_01/app/wp-content/plugins/flo-flex-builder/public/class-flo-flex-builder-public.php on line 143: /home/strato/http/power/rid/53/30/511785330/htdocs/STRATO-apps/wordpress_01/app/index.php

    Moderator Bego Mario Garde

    (@pixolin)

    Das ist ja nun ein ganz anderes Problem. Das Plugin flo-flex-builder scheint einen Programmierfehler zu haben, zu dem ein Warnhinweis ausgegeben wird. Den kannst du abschalten, indem du in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes hinzufügst:

    define( 'WP_DEBUG', false );
    @ini_set( 'display_errors', 0 );

    Warnhinweise abzuschalten ist reine Kosmetik: der Fehler besteht weiterhin, aber du wirst nicht mehr genervt.

    Hallo,
    da gibt es zumindest zwei Möglichkeiten:

    • sollte die Instanz unter PHP 8.x laufen, stelle mal bitte auf PHP 7.4.x um
    • deaktiviere das Plugin in dem Ordner flo-flex-builder. In der FAQ im Beitrag ist genauer beschrieben, wie man plugins deaktiviert, wenn man keinen Zugriff mehr auf das Dashboard hat.
      Also: Per FTP änderst du den Namen des Plugin – Ordners, der das Problem verursacht
      (z. B. \wp-content\plugins\das_ist_der_Ordner in \wp-content\plugins\_das_ist_der_Ordner) – ich habe hier vor dem Namen des Ordners einen Unterstrich gesetzt. Hier ist das der Ordner mit dem Namen flo-flex-builder.

    Ob das allerdings den in deiner Frage beschriebenen Fehler behebt und du dann wieder auf das Dashboard zugreifen kannst, müsstest du dann testen.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, ist ja nur eine „Warning“. Ich würde nicht gleich das Plugin rausschmeißen (das vermutlich zur Anzeige der Inhalte benötigt wird).

    Bei der Anmeldung möchte WordPress im Browser ein Cookie setzen. Das klappt aber nur, wenn nicht vorzeitig irgendwelche Warnhinweise ausgegeben werden. Unterdrückt man die Ausgabe wie beschrieben, sollte auch das Cookie korrekt gesetzt werden.

    Der Support von Strato zeigt sich wiedermal als wenig hilfreich. Für mich wäre das ein Grund, den Webhoster zu wechseln. Schon klar: die Margen sind so knapp, dass lange Support-Dialoge aus Kostengründen nicht drin sind, aber so ein bisschen Unterstützung wäre schon schön.

    Der Support von Strato zeigt sich wiedermal als wenig hilfreich. Für mich wäre das ein Grund, den Webhoster zu wechseln. Schon klar: die Margen sind so knapp, dass lange Support-Dialoge aus Kostengründen nicht drin sind, aber so ein bisschen Unterstützung wäre schon schön.

    das sehe ich absolut genauso. 👍

    Thread-Ersteller uniquephoto

    (@uniquephoto)

    Ja die Dame war auch irgendwie angepi**t.

    Ich habe die Plugins deaktiviert. Nun kommt:
    Not Found

    The requested URL was not found on this server.

    Thread-Ersteller uniquephoto

    (@uniquephoto)

    Gibt es einen Service den man buchen kann, wo einer mir dabei hilft? Ich denke dass durch mein nicht Wissen in dem Bereich nur die Option bleibt zu löschen oder externe helfen zu lassen.

    Moderator Bego Mario Garde

    (@pixolin)

    Es gibt Freelancer-Portale oder du suchst im Web nach WordPress-Dienstleistern.

    Unser Forum ist keine Jobbörse, Jobanfragen sind hier ausdrücklich unerwünscht.

    Thread-Ersteller uniquephoto

    (@uniquephoto)

    oh okay, danke für den Hinweis.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)