Support » Allgemeine Fragen » WordPress Mediathek funktioniert nicht

  • Gelöst hippi02

    (@hippi02)


    Hello ihr lieben,

    ich weiß nicht seit wann, aber meine Mediathek funktioniert leider nicht mehr. Die hinterlegten Bilder sind ausgegraut. Wenn ich neue hochlade, genau das gleiche Spiel. Rechte sind gesetzt, den Ordner hatte ich schon umbenannt und wieder neu erstellt. Kein Erfolg.

    Werkzeuge -> Zustand -> Bericht:

    ` wp-core

    version: 6.5.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes

    wordpress_path: /usr/www/users/hippzu
    wordpress_size: 2,85 GB (3059400079 bytes)
    uploads_path: /usr/www/users/hippzu/wp-content/uploads
    uploads_size: 171,61 MB (179944505 bytes)
    themes_path: /usr/www/users/hippzu/wp-content/themes
    themes_size: 3,54 MB (3711244 bytes)
    plugins_path: /usr/www/users/hippzu/wp-content/plugins
    plugins_size: 172,32 MB (180687731 bytes)
    database_size: 32,83 MB (34422784 bytes)
    total_size: 3,22 GB (3458166343 bytes) wp-active-theme

    name: Hello Elementor (hello-elementor)
    version: 3.0.2
    author: Elementor Team
    author_website: https://elementor.com/?utm_source=wp-themes&utm_campaign=author-uri&utm_medium=wp-dash
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, menus, post-thumbnails, automatic-feed-links, title-tag, html5, custom-logo, editor-style, align-wide, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider
    theme_path: /usr/www/users/hippzu/wp-content/themes/hello-elementor
    auto_update: Deaktiviert wp-themes-inactive (1)

    Twenty Twenty-Four: version: 1.1, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-mu-plugins (1)

    aios-firewall-loader.php: author: (undefined), version: (undefined) wp-plugins-active (13)

    All-in-One WP Migration: version: 7.83, author: ServMask, Automatische Aktualisierungen deaktiviert
    All-in-One WP Migration Unlimited Extension: version: 2.58, author: ServMask, Automatische Aktualisierungen deaktiviert
    All In One WP Security: version: 5.3.0, author: All In One WP Security & Firewall Team, Automatische Aktualisierungen deaktiviert
    Code Snippets: version: 3.6.5.1, author: Code Snippets Pro, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.9.5, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    CookieYes | GDPR Cookie Consent: version: 3.2.4, author: CookieYes, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.21.8, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.19.0, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Envato Elements: version: 2.0.13, author: Envato, Automatische Aktualisierungen deaktiviert
    Matomo Analytics - Ethical Stats. Powerful Insights.: version: 5.0.8, author: Matomo, Automatische Aktualisierungen deaktiviert
    PRO Elements: version: 3.21.3, author: PROElements.org, Automatische Aktualisierungen deaktiviert
    WP-Sweep: version: 1.1.8, author: Lester 'GaMerZ' Chan, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 22.8, author: Team Yoast, Automatische Aktualisierungen deaktiviert wp-plugins-inactive (3)

    ImageMagick Engine: version: 1.7.8, author: Orangelab, Automatische Aktualisierungen deaktiviert
    Image Optimizer by Elementor – Compress, Resize and Optimize Images: version: 1.3.0, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    LiteSpeed Cache: version: 6.2.0.1, author: LiteSpeed Technologies, Automatische Aktualisierungen deaktiviert wp-media

    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: 1
    post_max_size: 300M
    upload_max_filesize: 300M
    max_effective_size: 300 MB
    max_file_uploads: 50
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: 10.00.0 wp-server

    server_architecture: Linux 6.1.0-21-amd64 x86_64
    httpd_software: Apache
    php_version: 8.2.20 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 300M
    php_post_max_size: 300M
    curl_version: 7.88.1 OpenSSL/3.0.11
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2024-06-10T11:06:18+00:00
    utc-time: Monday, 10-Jun-24 11:06:18 UTC
    server-time: 2024-06-10T13:06:17+02:00 wp-database

    extension: mysqli
    server_version: 10.5.23-MariaDB-0+deb11u1
    client_version: mysqlnd 8.2.20
    max_allowed_packet: 268435456
    max_connections: 400 wp-constants

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /usr/www/users/hippzu/wp-content
    WP_PLUGIN_DIR: /usr/www/users/hippzu/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    • Dieses Thema wurde geändert vor 1 Woche, 5 Tage von hippi02.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Moderator Bego Mario Garde

    (@pixolin)

    Kannst du bitte versuchen, das WordPress-Logo hochzuladen:

    https://s.w.org/style/images/about/WordPress-logotype-wmark.png

    Wir die Datei korrekt übernommen?

    Beim Upload von Bildern spielt nicht die Dateigröße, sondern die tatsächliche Auflösung eine große Rolle, da WordPress Bilder pixelweise als Bitmap einliest, um sie zu skalieren. Reicht der Arbeitsspeicher nicht aus, wird die Skalierung abgebrochen und nur ein grauer Platzhalter angezeigt. Abhilfe:

    • den Arbeitsspeicher erhöhen
    • auf nicht benötigte Plugins verzichten, um so weniger Arbeitsspeicher zu besetzen
    • Bilder mit niedriger Auflösung hochladen
    Thread-Starter hippi02

    (@hippi02)

    Logo hochgeladen, leider kein Erfolg. Wenn ich auf bearbeiten gehe, dann sehe ich sogar die Bilder…
    Arbeitsspeicher etc alles erhöht. Es sind ja auch schon 72 Bilder drauf. Plugin Health Check auch schon probiert, ändert sich ebenfalls nicht.

    Moderator Bego Mario Garde

    (@pixolin)

    Plugin Health Check auch schon probiert

    Hast du damit auch den Problembehandlungsmodus gestartet, um alle nicht benötigten Plugins zu deaktivieren?

    Thread-Starter hippi02

    (@hippi02)

    Ja genau, kein Erfolg.

    Thread-Starter hippi02

    (@hippi02)

    Und wenn ich das Bild über die Website über einen neuen Tab öffnen will, folgendes:

    https://www.hippzulassungen.de/wp-content/uploads/2024/03/Netzwerk-1024×683.jpeg

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von hippi02.
    Moderator Bego Mario Garde

    (@pixolin)

    Der direkte Zugriff auf die Datei ist verboten.

    Was ist der Inhalt der .htaccess in deinem Web-Stammverzeichnis?
    Gibt es eine .htaccess im Verzeichnis wp-content oder wp-content/uploads?

    Thread-Starter hippi02

    (@hippi02)

    Im Überverzeichnis von wp-content also public.html gibt es die .htaccess und .htaccess.bk

    Soll ich die mal reinladen?

    Moderator Bego Mario Garde

    (@pixolin)

    Der Inhalt der .htaccess wäre interessant. Ein Backup dieser Datei sollte gar nicht auf dem Server liegen, der Zugriff ist aber wohl gesperrt – dann macht es auch nichts.

    Thread-Starter hippi02

    (@hippi02)

    Hmm okay.. das ist komisch.

    Hier der Inhalt:

    
    # BEGIN All In One WP Security
    #AIOWPS_PREVENT_IMAGE_HOTLINKS_START
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{REQUEST_FILENAME} \.(gif|jpe?g?|png)$ [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://hippzulassungen\.de [NC]
    RewriteRule \.(gif|jpe?g?|png)$ - [F,NC,L]
    </IfModule>
    #AIOWPS_PREVENT_IMAGE_HOTLINKS_END
    # END All In One WP Security
    
    # BEGIN LSCACHE
    # END LSCACHE
    # BEGIN NON_LSCACHE
    # END NON_LSCACHE
    
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Moderator Bego Mario Garde

    (@pixolin)

    Wie sind denn die Berechtigungen für das gesamte Verzeichnis wp-contentgesetzt? Und welchem Benutzer sind die Dateien zugewiesen – der gleiche Benutzer wie bei den php-Dateien?

    Thread-Starter hippi02

    (@hippi02)

    wp-content hat 755

    wo sehe ich, welchem Benutzer die Dateien zugeordnet sind?

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von hippi02.
    Moderator Bego Mario Garde

    (@pixolin)

    Hm, OK – da scheint eine Einstellung des All-in-One-Security-Plugins einen Eintrag in die .htaccess vorgenommen zu haben. Deaktiviere doch bitte mal das Plugin und kommentiere die Zeilen in der .htaccess aus. Was passiert dann mit der Darstellung der Website (im Moment werden gar keine Bilder mehr geladen) und wie sieht es in der Mediathek aus?

    Thread-Starter hippi02

    (@hippi02)

    Das kann jetzt nicht sein… es lag tatsächlich an dem Plugin… du bist mein Retter!! Verstehe trotzdem nicht, vorhin habe ich alle Plugins deaktivieren lassen durch Health Check…

    Moderator Bego Mario Garde

    (@pixolin)

    wo sehe ich, welchem Benutzer die Dateien zugeordnet sind?

    Du solltest im FTP-Programm die Möglichkeit haben, den Eigentümer und die Arbeitsgruppe zu sehen:

    Screenshot
    Thread-Starter hippi02

    (@hippi02)

    Hmm, das kann ich leider nicht.

    Ich danke dir vielmals!! Bis dahin 🙂

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)