Support » Allgemeine Fragen » WordPress mit Reverse Proxy

  • Hallo

    Ich fange neu mit WordPress an. Um für meine Webseite eine Subdomain anlegen zu können habe ich mir einen Reverse Proxy installiert jedoch habe ich jetzt einige Probleme bekommen, sobald ich SSL auf dem Reverse Proxy installiert habe.

    Zum Thema Reverse Proxy + WordPress habe ich schon einiges gelesen jedoch steig ich bei keiner Anleitung durch wo und wo ich was installieren soll

    Reverse Proxy: Apache (Extra PC)

    WordPress Installation: Apache (Extra PC)

    Das Problem besteht jetzt eigentlich daran, das ich keinen Zugriff auf meine WordPress Seite habe und diese auch nicht sichtbar ist.

    Gruß

    Martin

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Moderator Bego Mario Garde

    (@pixolin)

    Kannst du, wenn du im Web-Stammverzeichnis eine Datei phpinfo.php mit dem Inhalt <?php phpinfo(); anlegst, darauf zugreifen und die Informationen zu deiner PHP-Einrichtung abrufen?

    Also entweder stell ich mich momentan etwas an, ich weiß es nicht ich habe das ganze so gemacht wie du es beschrieben hast

    Im Verzeichnis /Var/www befindet sich die Datei phpinfo.php mit dem Inhalt
    <?php phpinfo();

    wenn ich das aber aufrufen will passiert nichts (Muss ich noch zusätzliche rechte anpassen)

    Gruß

    Martin

    Hallo,
    das war bei @pixolin nicht ganz vollständig. Richtig wäre:

    <?php
        phpinfo();
    ?>

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Doch, das war vollständig: <?php phpinfo(); reicht völlig.

    Warum? Darum.

    Dass die PHP-Datei im Browser nicht ausgeführt wird, zeigt, dass mit der Serverkonfiguration etwas nicht stimmt. Kein WordPress-Problem.

    @pixolin
    da hast du mal wieder recht 🙂
    Das hatte ich nicht getestet, weil ich rein gewohnheitsmäßig das immer abschließe.

    Was könnte dann in der Konfiguration nicht stimmen?

    Moderator Bego Mario Garde

    (@pixolin)

    Das lässt sich aus der Ferne kaum beurteilen.

    Wieso verwendest du denn einen Reverse Proxy Server?
    Zum aufsetzen eines einfachen Webservers mit Apache oder Nginx gibt es so viele Tutorials. Ich würde vielleicht danach den Server nochmal neu aufsetzen.

    Für Fragen zur Serverkonfiguration bist du hier allerdings auch im falschen Forum, auch wenn du WordPress (und/oder irgendwelche anderen Webanwendungen) nutzen möchtest.

    Einen Reverse Proxy verwende ich deshalb da ich mittlerweile mehrere Projekte habe, die ich alle über eine Subdomain erreichbar machen möchte, ohne reverse Proxy ging alles ohne Probleme.

    Ich habe nun die PHPInfo datei in den Ordner html gespeichert und siehe da da hat es geklappt

    Da ich gerade nicht weiß wie ich ein Bild hier reinschiebe kopiere ich es hinein und hoffe das es so lesbar ist.

    PHP Version 7.2.24-0ubuntu0.18.04.2
    System Linux WordPress 4.15.18-9-pve #1 SMP PVE 4.15.18-30 (Thu, 15 Nov 2018 13:32:46 +0100) x86_64
    Build Date Jan 13 2020 18:39:59
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php/7.2/apache2
    Loaded Configuration File /etc/php/7.2/apache2/php.ini
    Scan this dir for additional .ini files /etc/php/7.2/apache2/conf.d
    Additional .ini files parsed /etc/php/7.2/apache2/conf.d/10-mysqlnd.ini, /etc/php/7.2/apache2/conf.d/10-opcache.ini, /etc/php/7.2/apache2/conf.d/10-pdo.ini, /etc/php/7.2/apache2/conf.d/15-xml.ini, /etc/php/7.2/apache2/conf.d/20-bz2.ini, /etc/php/7.2/apache2/conf.d/20-calendar.ini, /etc/php/7.2/apache2/conf.d/20-ctype.ini, /etc/php/7.2/apache2/conf.d/20-curl.ini, /etc/php/7.2/apache2/conf.d/20-dom.ini, /etc/php/7.2/apache2/conf.d/20-exif.ini, /etc/php/7.2/apache2/conf.d/20-fileinfo.ini, /etc/php/7.2/apache2/conf.d/20-ftp.ini, /etc/php/7.2/apache2/conf.d/20-gd.ini, /etc/php/7.2/apache2/conf.d/20-gettext.ini, /etc/php/7.2/apache2/conf.d/20-iconv.ini, /etc/php/7.2/apache2/conf.d/20-json.ini, /etc/php/7.2/apache2/conf.d/20-mbstring.ini, /etc/php/7.2/apache2/conf.d/20-mysqli.ini, /etc/php/7.2/apache2/conf.d/20-pdo_mysql.ini, /etc/php/7.2/apache2/conf.d/20-phar.ini, /etc/php/7.2/apache2/conf.d/20-posix.ini, /etc/php/7.2/apache2/conf.d/20-readline.ini, /etc/php/7.2/apache2/conf.d/20-shmop.ini, /etc/php/7.2/apache2/conf.d/20-simplexml.ini, /etc/php/7.2/apache2/conf.d/20-sockets.ini, /etc/php/7.2/apache2/conf.d/20-sysvmsg.ini, /etc/php/7.2/apache2/conf.d/20-sysvsem.ini, /etc/php/7.2/apache2/conf.d/20-sysvshm.ini, /etc/php/7.2/apache2/conf.d/20-tokenizer.ini, /etc/php/7.2/apache2/conf.d/20-wddx.ini, /etc/php/7.2/apache2/conf.d/20-xmlreader.ini, /etc/php/7.2/apache2/conf.d/20-xmlwriter.ini, /etc/php/7.2/apache2/conf.d/20-xsl.ini, /etc/php/7.2/apache2/conf.d/20-zip.ini
    PHP API 20170718
    PHP Extension 20170718
    Zend Extension 320170718
    Zend Extension Build API320170718,NTS
    PHP Extension Build API20170718,NTS
    Debug Build no
    Thread Safety disabled
    Zend Signal Handling enabled
    Zend Memory Manager enabled
    Zend Multibyte Support provided by mbstring
    IPv6 Support enabled
    DTrace Support available, disabled
    Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, compress.bzip2, phar, zip
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
    Registered Stream Filters zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, bzip2.*, convert.iconv.*

    Hallo,
    einen screenshot kannst du wie folgt hier einstellen, siehe auch die Hinweise in der FAQ.
    Ansonsten hat das – wie bereits @pixolin geschrieben hat – nicht direkt was mit WordPress zu tun.
    Viele Grüße
    Hans-Gerd

    Also ich denke, es hat schon was mit WordPress zu tun oder im Zusammenhang

    Begründung: Verwende ich am Reverse Proxy kein SSL funktioniert WordPress einwandfrei und auch öffentlich erreichbar. Installieren ich nun SSL ist WordPress nicht mehr erreichbar, auch wenn ich in der WordPress (WP-conf) die URL auf HTTPS umstelle.

    Gruß
    Martin

    Das hat nichts mit WordPress zu tun, sondern mit der Proxy-Konfiguration des Apache.
    Ist der Proxy für https konfiguriert?

    Was ich gelesen habe das WordPress es nicht mag das im Heimnetz mit HTTP gesprochen wird und öffentlich mit HTTPS

    Inwiefern kann ich am Reverse Proxy etwas für HTTPS konfigurieren

    Das ich noch etwas am Reverse Proxy konfigurieren muss weiß ich schon ich weiß nur nicht was und das was ich im Internet gefunden habe versteh ich nicht wirklich

    Gruß

    Martin

    Hier ist eigentlich das Wesentliche sehr schön beschrieben.

    Also ich hab mir das mal so durchgelesen, verstehe aber nicht alles (https://znil.net/index.php/Apache2_als_http_/_https_Proxy_zu_anderen_Host)

    Die Config datei die er hineingestellt und habe ich bei mir eingefügt

    In die datei 000-default-conf (Hoffe das ist überhaubt die Richtige)

    Angepasst habe ich die Datei dann wie folgt

    <Directory /var/www/html>
    AllowOverride None
    Require all denied
    </Directory>

    <VirtualHost 192.168.178.55:80>

    ServerName meinesubdomain
    ServerAdmin webmaster@meinesubdomain

    ProxyPass / http://192.168.178.60/
    ProxyPassReverse / http://192.168.178.60/
    </VirtualHost>

    <VirtualHost 192.168.178.55:443>

    ServerName meinesubdomain
    ServerAdmin webmaster@meinesubdomain

    SSLEngine on
    SSLCertificateFile /var/www/clients/client0/web7/ssl/zabbix.znil.net.crt
    SSLCertificateKeyFile /var/www/clients/client0/web7/ssl/zabbix.znil.net.key

    ProxyPass / http://192.168.178.60/
    ProxyPassReverse / http://192.168.178.60/
    </VirtualHost>

    Wo ich selber noch rätsel sind die Pfade zu den SSL Zertifikaten diese liegen ja auf dem Reverse Proxy und nicht auf dem WordPress Server eventuell kannst du mir da auf die Sprünge helfen

    Momentan ist es so, wenn ich die WordPress Seite aufrufen möchte hat sie etwas geändert von

    Webseite nicht erreichbar

    auf

    Dienst nicht verfügbar

    Gruß
    Martin

    Nicht, dass wir aneinander vorbeireden. Welche Konfiguration soll denn nun funktionieren? Diese hier?
    Internet -> SSL Verbindung per https:// -> Apache2 Proxy -> Weiterleitung unverschlüsselt per http:// -> Zielserver 192.168.178.60/
    Die hattest Du doch schon zu Beginn, oder? Da läuft WordPress ohne SSL (https), aber hinter einem Proxy ist es i.O.

    Ansonsten ist das Konfigurieren des Apache und eines Proxies nicht trivial.
    Wenn Du keine Ahnung hast, hol Dir die Hilfe vom Fachmann.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)