Support » Allgemeine Fragen » WordPress Multisite – kann mich nicht mehr anmelden

  • Hallo,

    wenn ich mich ganz normal bei meiner Multisite über wp-login.php anmelden will, sagt mir meine Seite:

    „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Wenn ich dann die Seite aufrufe, sehe ich allerdings oben das schwarze WP-Panel und kann auch einiges anklicken, z. B. „+ neuen Beitrag“, doch dann springt die Seite automatisch wieder auf die Fehlermeldung, dass ich keine Berechtigung habe.

    Keine Ahnung, wie das passiert ist. Wir sind zwei SuperAdmins und niemand wir haben unsere Berechtigungen nicht geändert oder die Passwörter. Wir kommen beide nicht mehr rein.

    Der andere SuperAdmin schrieb mir:

    Ich habe gerade versucht, mich mit allen mir bekannten / im Browser gespeicherten PW einzuloggen, es geht nicht. Da ist was in der Benutzerverwaltung passiert, was nicht von meiner Seite aus zu ändern ist. Die Seite „hängt“ bei mir in Adminmodus, aber ich komme nicht ins Dashboard.
    Es könnte ein Datenbankreset oder ein Neueintrag eines Passwortes per MD5 Hash nötig sein.

    Doch das WordPress hat sich am 07.02. automatisch aktualisiert, auch ohne meinen Zugang.
    Ich habe keine Ahnung, was das bedeutet und wie es passiert ist, doch ich hätte gerne wieder Zugang zu meiner Seite.

    Vielen Dank

    Judith

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Wenn du die Admin-Leiste sehen kannst, kannst du dich dann dort abmelden?

    Wie meldest du dich im Backend an? Über welchen Link?

    Kannst du per FTP auf die Dateien auf deinem Webserver zugreifen?
    Falls ja, füge in der wp-config.php doch bitte mal oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:

    define( 'WP_DEBUG', true );

    Werden dann bei der Anmeldung Fehlermeldungen ausgegeben?

    Was ist die Haupt-Site der Multisite? Kannst du dich dort anmelden?

    Ja, habe mich abmelden können, bekomme die Meldung:

    „Du hast dich erfolgreich abgemeldet.“

    Anmeldung im Backend über: https://letsgetitstraight.de/wp-login.php

    Wenn ich mich wieder anmelden will, habe ich das gleiche Problem wie oben geschildert.

    Habe den Code in die wp-config.php kopiert zwischen:
    define( 'SUNRISE', 'on' );

    /* Memory limit */
    define('WP_MEMORY_LIMIT', '128M');
    define( 'WP_DEBUG', true );
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */

    und erhalte nun im Backend-Login-Bereich diese Meldung:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 434

    Und zwischen dem WordPress-Logo und dem Anmeldefenster diese Meldung:
    FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an die Support-Foren.

    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von Judith Schroeer.
    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von Torsten Landsiedel. Grund: Code repariert

    Mit welchem Editor hast du die wp-config.php denn bearbeitet? Da scheint die Zeichnkodierung nicht zu stimmen. Verwende doch bitte mal den kostenlosen Atom Editor und speichere die Datei damit erneut ab.

    Die Zeile mit dem (zu niedrigen) Memory Limit solltest du mit zwei vorangestellten Schrägstrichen // auskommentieren.

    Ich habe den ganz normalen Editor genommen, der auf meinem Windows ist.

    Habe nun die bereits modifizierte wp-config.php nochmal herunter geladen, dann mit dem Atom-Editor geöffnet, wieder hochgeladen und bekomme jetzt (wie mir scheint die gleiche) diese Fehlermeldung:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 434

    Wieviel Memory Limit sollte ich denn einstellen?

    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von Judith Schroeer.

    Da scheint weiterhin ein Fehler enthalten zu sein. Hast du mal im Atom-Editor auf die Anzeige der Status-Leiste geachtet, ob dort „UTF-8“ angezeigt wird. Der Windows-Editor Notepad speichert im falschen Zeichenformat.

    Kopiere auch bitte mal die wp-config.php und füge sie hier ein. Verwende dabei den Button [code] am Anfang und Ende des Codes, um den Inhalt als Code zu formatieren und entferne die Zugangsdaten (Username, Passwort) für die Datenbank.

    Eigentlich brauchst du gar kein Memory Limit angeben.

    Mir wird unten rechts im Atom-Editor UTF-8 angezeigt. Ich hoffe, ich habe alle Zugangsdaten auch tatsächlich entfernt…
    <?php
    /**
    * Grundeinstellungen für WordPress
    *
    * Zu diesen Einstellungen gehören:
    *
    * * MySQL-Zugangsdaten,
    * * Tabellenpräfix,
    * * Sicherheitsschlüssel
    * * und ABSPATH.
    *
    * Mehr Informationen zur wp-config.php gibt es auf der
    * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
    * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
    * bekommst du von deinem Webhoster.
    *
    * Diese Datei wird zur Erstellung der wp-config.php verwendet.
    * Du musst aber dafür nicht das Installationsskript verwenden.
    * Stattdessen kannst du auch diese Datei als wp-config.php mit
    * deinen Zugangsdaten für die Datenbank abspeichern.
    *
    * @package WordPress
    */

    // ** MySQL-Einstellungen ** //
    /** Diese Zugangsdaten bekommst du von deinem Webhoster. **/

    /**
    * Ersetze datenbankname_hier_einfuegen
    * mit dem Namen der Datenbank, die du verwenden möchtest.
    */
    define('DB_NAME', 'dbNameEntfernt');

    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'dbUserEntfernt');

    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', 'PassEntfernt');

    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'dbEntfernt.db.1and1.com');

    /**
    * Der Datenbankzeichensatz, der beim Erstellen der
    * Datenbanktabellen verwendet werden soll
    */
    define('DB_CHARSET', 'utf8mb4');

    /**
    * Der Collate-Type sollte nicht geändert werden.
    */
    define('DB_COLLATE', '');

    /**#@+
    * Sicherheitsschlüssel
    *
    * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
    * möglichst einmalig genutzte Zeichenkette.
    * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * kannst du dir alle Schlüssel generieren lassen.
    * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
    * Benutzer müssen sich danach erneut anmelden.
    *
    * @since 2.6.0
    */

    [Keys gelöscht] 

    /**#@-*/

    /**
    * WordPress Datenbanktabellen-Präfix
    *
    * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    * verschiedene WordPress-Installationen betreiben.
    * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
    */
    $table_prefix = 'wp_lgis';

    /**
    * Für Entwickler: Der WordPress-Debug-Modus.
    *
    * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
    * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
    * in ihrer Entwicklungsumgebung zu verwenden.
    *
    * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
    * die zum Debuggen genutzt werden können.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define('WP_DEBUG', false);

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'letsgetitstraight.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    define( 'SUNRISE', 'on' );

    //* Memory limit */
    define('WP_MEMORY_LIMIT', '128M');
    define( 'WP_DEBUG', true );
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */

    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Definiert WordPress-Variablen und fügt Dateien ein. */
    require_once(ABSPATH . 'wp-settings.php');

    Über das Kundenmenü solltest du die Möglichkeit haben, per phpMyAdmin in die Datenbank zu schauen. Kannst du bitte mal prüfen, ob die Tabellen dort tatsächlich alle mit wp_lgis anfangen?

    Der Code scheint soweit korrekt zu sein. Nächste Möglichkeit wäre, dass ein Plugin den Fehler verursacht. Um sie vorübergehend zu deaktivieren könntest du bitte per FTP das Verzeichnis wp-content/plugins in wp-content/no.plugins umbenennen. Kannst du dich dann anmelden?

    Die Tabellen scheinen alle mit wp_lgis anzufangen:


    wp_lgis10_terms
    wp_lgis10_term_relationships
    wp_lgis10_term_taxonomy
    wp_lgis10_wplc_chat_msgs
    wp_lgis10_wplc_chat_sessions
    wp_lgis10_wplc_offline_messages
    wp_lgisaepc_custom_audiences
    wp_lgisblogs
    wp_lgisblog_versions

    Das Verzeichnis habe ich in wp-content/no.plugins umbenannt und wenn ich mich nun anmelde, erhalte ich ein paar Fehlermeldungen mehr:
    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 434

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 920

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 921

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 922

    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von Judith Schroeer.
    • Diese Antwort wurde geändert vor 2 Jahre, 5 Monaten von Judith Schroeer.

    Die Fehlermeldung

    Cannot modify header information – headers already sent by wp-login.php

    bedeutet, dass WordPress versucht, ein HTML-Dokument mit einem Header zu senden, statt dessen aber schon ein Dokument – eine Fehlermeldung – versandt wurde. Cookies können nicht nachträglich angelegt werden. Die Fehlermeldung entsteht üblicherweise …

    • weil vor dem einleitenden Tag <?php Code oder eine Leerzeile steht,
    • es ein schließendes ?>-Tag gibt, gefolgt von weiteren Code oder Leerzeilen
    • die Datei wp-config.php nicht lesbar ist, weil die Zeichenkodierung nicht stimmt.

    Die ersten beiden Möglichkeiten würde ich aufgrund des Codes, den du hier geteilt hast, ausschließen. Deshalb prüfe bitte nochmal in einem Programmiereditor die Zeichenkodierung der Datei (UTF-8). Du musst natürlich die Datei anschließend auch wieder hochladen! Bei der Gelegenheit kannst du die Zeile define( 'WP_DEBUG', true ); auch wieder entfernen und wie gesagt die Zeile define('WP_MEMORY_LIMIT', '128M'); durch zwei vorangestellte Schrägstriche auskommentieren:
    // define('WP_MEMORY_LIMIT', '128M');.

    Die Frage ist dann, ob du dich im Backend anmelden kannst.

    Ich habe die Datei wieder geändert hochgeladen (ohne Debug & Memory Limit auskommentiert) und das Plugin-Verzeichnis wieder ordentlich benannt.

    Das führt zu dieser Fehlermeldung:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-login.php on line 434

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 920

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 921

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d13502089/htdocs/letsgetitstraight/wp-config.php:1) in /homepages/23/d13502089/htdocs/letsgetitstraight/wp-includes/pluggable.php on line 922

    Es tut mir leid, dazu fällt mir im Moment nichts ein.
    Die Ursache des Fehlers und wie man ihn behebt, habe ich dir geschildert. Normalerweise hätte die Fehlermeldung, die dir im Anmeldeformular angezeigt wird, längst behoben sein sollen.

    Einige Windows-User haben auch beschrieben, dass sie den Fehler beheben konnten, in dem sie in Windows Notepad unter „Speichern unter“ ANSI ausgewählt haben. Vielleicht magst du das nochmal ausprobieren?

    Ich habe auch schon erlebt, dass sich Änderungen überhaupt nicht ausgewirkt haben, weil ich die falschen Dateien bearbeitet oder Dateien an der falschen Stelle abgespeichert habe. Ich will dir damit nichts unterstellen, aber solche Dinge passieren auch erfahrenen Anwendern. Prüfe bitte nochmal, ob die wp-config.php an mehreren Stellen vorkommt.

    Die eigentliche Frage, ob du dich inzwischen (mit umbenanntem Plugin-Verzeichnis) wieder anmelden kannst, hast du leider nicht beantwortet.

    Naja, so ist das manchmal… ich habe mir schon überlegt, ob ich nicht „einfach“ eine neue Multisite installiere und das vorletzte Backup wieder einspiele. Doch eine Multisite-Installation ist für mich super langwierig und habe ich erst einmal gemacht. Ich erinnere mich, dass ich damals schon keine richtig gute Anleitung gefunden habe…

    Nein, mit unbenanntem Plugin-Verzeichnis kann ich micht auch nicht wieder anmelden, deshalb habe ich es wieder ordentlich rückbenannt.

    Danke für deine umfassende Hilfe 🙂

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „WordPress Multisite – kann mich nicht mehr anmelden“ ist für neue Antworten geschlossen.