Support » Installation » WordPress nach Backup Rückspielen leer

  • Gelöst philadou

    (@philadou)


    Hallo zusammen,
    folgendes Problem:

    Ich musste von meinem uralten Confixx Webhosting zum „neuen“ Plex Webhosting umziehen.
    Leider bekomme ich mein Backup von WordPress nicht hin. Es fehlt der Inhalt….keine Beiträge, keine Seiten etc.
    Was ich gemacht habe:

    1. Auf dem alten Server WordPress auf aktuellen Stand gebracht
    2. DB gesichert
    3. via FileZilla die Daten gesichert.
    4. Auf dem neuen Webspace per Anwendungen ebenfalls die neuste WordPress Version installiert.
    5. Im phpMyAdmin das DB Backup importiert
    6. Da auf dem alten Webspace die Datenbank anders heißt als auf dem neuen Webspace, habe ich in der wp-config die Daten abgeändert
    7. Nun per FileZilla die Daten der WordPress Installation auf dem neuen Webspace überschrieben

    Plugins, Themen etc. sind alle da, aber es sieht aus, als würden alle Inhalte fehlen. Überall steht noch willkommen bei WordPress etc. trotz
    Rückspielung der Daten. Was mach ich falsch? Irgendwie sieht es so aus, als ob da keine Kommunikation mit der DB statt findet.

    Wer kann einem Nook wie mir helfen? 🙂

    Danke & Grüße

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • 4. Auf dem neuen Webspace per Anwendungen ebenfalls die neuste WordPress Version installiert.

    Das war vermutlich der Fehler. 🙂

    Ich vermute, dass dabei ein neuer Satz Datenbank-Tabellen mit einem anderen Präfix angelegt wurde. Schau mal, welches Datenbanktabellen-Präfix in der wp-config.php eingetragen ist und ob es dazu passende Tabellen in der Datenbank gibt.

    Thread-Starter philadou

    (@philadou)

    Danke für Deine Antwort.

    In der wp-config.php hab ich nur das gefunden:

    $table_prefix = ‚wp_‘;

    was sagst mir das bzw. was muss ich da ändern?

    Öffne mal phpMyAdmin und schau, wie die Tabellen benannt sind.
    Fangen alle Tabellen mit wp_ an?

    Thread-Starter philadou

    (@philadou)

    Teilweise:

    ….kann hier irgendwie kein Bild einfügen….moment

    das ist ganz verschieden….Beispiele:

    terms
    users
    wppg_album
    wp_comments

    oder meinst du was anderes?

    • Diese Antwort wurde geändert vor 4 Jahre, 11 Monaten von philadou.
    • Diese Antwort wurde geändert vor 4 Jahre, 11 Monaten von philadou.
    • Diese Antwort wurde geändert vor 4 Jahre, 11 Monaten von philadou.

    Also haben einige Tabellen ein anderes Präfix als andere?

    Ein Präfix ist die Vorsilbe einer Datenbank-Tabelle, also z.B. wp_ in wp_options. Das Präfix wird verwendet, um mehere Webanwendungen (oder auch WordPress-Installationen) auf einer einzigen Datenbank unterzubringen.

    Wenn du WordPress neu installiert hast, wurde wahrscheinlich das Präfix wp_ verwendet (das ist die Standard-Einstellung). Dieses Präfix steht offensichtlich auch in der wp-config.php. Wenn nun die Datenbanktabellen, die du von der alten Website importiert hast, ein anderes Präfix haben – z.B. wppg_, findet WordPress diese Tabellen gar nicht (bzw. öffnet die anderen, neu angelegten). Lösung: In der wp-config.php das richtig Tabellen-Präfix eintragen:

    $table_prefix = 'wppg_';

    Danach solltest du wieder deinen alten Inhalte und Einstellungen sehen. Die neu angelegten Datenbank-Tabellen mit dem Präfix wp_ kannst du dann löschen.

    Thread-Starter philadou

    (@philadou)

    Ich verstehe es noch nicht ganz.

    Es gibt viele Tabellen Einträge…die einen haben garnichts davor, die anderen wpg_ nochmal andere wp_ etc.

    Es ist also nicht so, dass alle den falschen Präfix hätten.
    Habe gerade auf dem alten Server die DB angesehen, da sieht es genauso aus.
    Hat aber immer funktioniert.

    Hmmm

    Thread-Starter philadou

    (@philadou)

    Ok, ich hab es gelöst, für alle die es interessiert:

    $table_prefix = ‚_wp‘; war falsch

    $table_prefix = “; Hat den Content wieder sichtbar gemacht 🙂

    Hört sich doch prima an. Ich markiere den Thread dann mal als „gelöst“. 🙂

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „WordPress nach Backup Rückspielen leer“ ist für neue Antworten geschlossen.