Support » Allgemeine Fragen » WordPress – Repository

  • Hi,
    ich habe selbst mein erstes (offizielles) Plugin hochgeladen.
    Dabei muss mir jedoch irgend ein Fehler unterlaufen sein, weil WordPress dieses neue Plugin jetzt immer mit Version 4.2.2 angeibt, obwohl im Plugin-Header 1.1 steht.
    Demzufolge wird auf den WordPress-Seiten, bei denen das Plugin bereits installiert ist, immer eine Updateversion angeboten, obwohl es gar kein neues Update gibt.
    Kennt jemand eine Lösung, wie ich diese Neue Version auf die richtige Versionnummer bringt oder soll ich einfach einen Versionssprung auf die 4.2.2 machen…???
    Plugin-Ordner: http://plugins.svn.wordpress.org/picture-organizer/

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Moderator Torsten Landsiedel

    (@zodiac1978)

    Ich denke, dass diese überflüssige Angabe als „Version“ interpretiert wird und daher der Fehler kommt.
    „Min WP Version: 4.2.2“

    Siehe auch:
    https://developer.wordpress.org/plugins/the-basics/header-requirements/

    Lösche diese Zeile und schau dann mal, ob es klappt.

    Gruß, Torsten

    Hi Torsten,
    danke für die Info, habe ich gleich versucht, brachte leider auch nichts.
    Dann habe ich gesucht, wo in meinem Quellcode noch die 4.2.2. vorkommt. Das war nur in den Kommentaren (@since 4.2.2, die ich als WordPress-Version gedacht/interpretiert hatte).
    Die habe ich rausgenommen, jetzt läuft das.
    Trotzdem vielen Dank für die Hilfe,
    Viele Grüße,
    Rudi

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Das Thema „WordPress – Repository“ ist für neue Antworten geschlossen.