Support » Allgemeine Fragen » wordpress sitzung läuft immer wieder ab

  • Gelöst michaelbrilz89

    (@michaelbrilz89)


    Hallo zusammen, ich soll für unser Unternehmen ein Intranet erstellen und wir haben uns für WordPress entschieden. Jetzt habe ich seit letzter Woche das Problem, dass ich mich nicht sofort im Backend anmelden kann und wenn ich das mal endlich schaffe, werde ich nach paar Sekunden sofort wieder abgemeldet. Folgendes habe ich schon probiert, allerdings ohne Erfolg:
    -Lösche den Cache deines Browsers
    -Lösche die Cookies deines Browsers
    -Überprüfe die Einstellungen deines Browsers
    -Lösche den Cache deiner WordPress-Seite
    -Überprüfe die Adresse deiner WordPress-Seite
    -Deaktivieren und erneutes Aktivieren von WordPress-Plugins

    Außerdem habe ich das function.php file geleert, um zu schauen, ob es am Code liegt. Hat auch nicht geholfen.

    Da ich nicht ins Backend komme, kann ich auch kein Statusbericht erstellen um den hier reinzustellen. Leider habe ich auch kein Link zum Projekt, da die Seite nur aus dem privaten Netzt zu erreichen ist. Ich hoffe ihr könnt mir weiterhelfen.

    Da ich nicht ins Backend komme, kann ich auch kein Statusbericht erstellen, um den hier reinzustellen. Leider habe ich auch kein Link zum Projekt, da die Seite nur aus unserem privaten Netzwerk zu erreichen ist. Ich hoffe, ihr könnt mir weiterhelfen.

    • Dieses Thema wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 52)
  • Hast du bei der Installation von WordPress im Browser zum Aufruf der Seiten eine IP-Adresse oder eine Domain verwendet?

    Prüf bitte mal, was in der Datenbank-Tabelle wp_options in den Feldern home und siteurl eingetragen ist. (Für home musst du ggf. etwas in der Tabelle blättern.)

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Hallo Bego 😀
    Zur Installation haben wir die Domain verwendet.

    In beiden Tabellen ist die Domain eingetragen

    In beiden Tabellen? Du meinst in beiden Feldern?
    Was wird bei http://example.com/wp-json (natürlich mit deiner Domain) unter siteurl und home angezeigt?

    Wie wird die lokale Domain verteilt? Per Eintrag in /etc/hosts oder über einen eigenen DNS-Server?

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Sry, meinte Felder.

    siteurl ist nicht zu finden. Unter home steht:
    "home":"https:\/\/intranet3.intern.xxx.de" Das xxx steht für die Second-Level-Domain.

    Die Domain wird mit eigenem DNS-Server verteilt.

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Ich bekomme jetzt öfters diesen Fehler angezeigt, wenn ich mich mit dem Admin anmelden möchte

    WordPress-Datenbank-Fehler: [Table 'wp_intranet.wp_user_report' doesn't exist]
    SHOW FULL COLUMNS FROM wp_user_report
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.

    siteurl ist nicht zu finden.

    Hast du in der Datenbank geblättert?

    Du kannst sonst in der wp-config.php oberhalb von /* That's all, stop editing! Happy publishing. */ folgende Zeile eintragen:

    define( 'RELOCATE', true );

    Damit solltest du dich im Backend anmelden und den Eintrag in Einstellungen > Allgemein prüfen können.

    Unter home steht:
    "home":"https:\/\/intranet3.intern.xxx.de"

    Der zweifache Backslash gehört da nicht hin.

    WordPress-Datenbank-Fehler: [Table ‚wp_intranet.wp_user_report‘ doesn’t exist]

    Das hängt mit einem Plugin zusammen, vielleicht auch weil es noch nicht richtig eingerichtet wurde.

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Bei siteurl steht: http://intranet3.intern.xxx.de

    In der BD werden mir unter „home“ keine Backslashses angezeigt.

    Bis auf das LDAP Plugin, habe ich alle anderen deaktiviert.
    Kann es sein, dass ein Plugin, etwas in der DB geändert hat?

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.

    Verwendest du einmal http und einmal https?
    Gut möglich, dass das Anmelde-Cookie dann nicht richtig gesetzt wird.

    Plugins machen häufig Einträge in der Datenbank, die aber ignoriert werden, wenn das Plugin deaktiviert ist.

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Wird mir so zumindest unter Einstellungen -> Allgemein angezeigt. Sprich:

    WordPress-Adresse(URL) = https
    Website-Adresse(URL) = http

    Wir verwenden kein https.

    Ähm, ja? Und was wirst du jetzt dagegen tun? 😀

    Die Adressen sollten dann einheitlich mit http beginnen. Entweder wie gesagt in der wp-config.php die Zeile define( 'RELOCATE', true ); einfügen, im Backend anmelden, URL unter Einstellungen > Allgemein korrigieren oder in der Datenbank eine Änderung vornehmen.

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Also…die Zeile define( 'RELOCATE', true ); habe ich jetzt in der wp-config.php eingefügt und im Backend die URLs zu http geändert. Allerdings tritt dieses Problem immer noch auf das ich nach paar Sekunden abgemeldet werde bzw. mich erst nach paar versuchen Anmelden kann.

    In der DB sind die Domains ja als http hinterlegt. Sowohl die siteurlals auch die home

    Vor 2 Wochen hat alles so schön funktioniert :/ Richtig frustrierend.

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.

    Die Zeile in der wp-config.php hat nur den Zweck, dass du ins Backend kommst und die URLs anpassen kannst. Die müssen wie gesagt beide entweder mit http oder (wenn ein Zertifikat vorhanden ist) mit https beginnen.

    Bei der Anmeldung setzt WordPress ein Cookie, um später die Authorisierung zu prüfen. Das Cookie wird aber durch die Änderung der URL nicht automatisch neu gesetzt. Du solltest also das Cookie löschen und dich danach erneut anmelden. Damit sollte es dann eigentlich klappen.

    Vor 2 Wochen hat alles so schön funktioniert

    Die Einstellungen ändern sich nicht von selbst. Irgendeinen Grund muss es geben, auch wenn du das gar nicht unmittelbar mitbekommen hast.

    Wenn du dich jetzt im Backend anmelden kannst, poste doch bitte mal den Website-Bericht.

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Also. Beide URLs sind jetzt auf http gesetzt. Die Cookies habe ich im Browser auch gelöscht, allerdings werde ich immer noch nach paar Sek ausgelogt bzw. wenn ich im Backend Navigiere. Immerhin habe ich es geschafft, den Bericht zu kopieren.

    ### wp-core ###
    
    version: 6.0.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 12
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/intranet
    wordpress_size: loading...
    uploads_path: /var/www/intranet/wp-content/uploads
    uploads_size: loading...
    themes_path: /var/www/intranet/wp-content/themes
    themes_size: loading...
    plugins_path: /var/www/intranet/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: GeneratePress Child (generatepress_child)
    version: 0.1
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: GeneratePress (generatepress)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, editor-color-palette, custom-logo, menus, editor-styles, editor-style, widgets
    theme_path: /var/www/intranet/wp-content/themes/generatepress_child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: GeneratePress (generatepress)
    version: 3.1.3
    author: Tom Usborne
    author_website: https://tomusborne.com
    theme_path: /var/www/intranet/wp-content/themes/generatepress
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Active Directory Integration for Intranet Sites: version: 4.0.3, author: miniOrange, Automatische Aktualisierungen deaktiviert
    Post Slider and Carousel with Widget: version: 3.0, author: InfornWeb, Automatische Aktualisierungen deaktiviert
    User Role Editor: version: 4.63.1, author: Vladimir Garagulya, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Formality: version: 1.5.5, author: Michele Giorgi, Automatische Aktualisierungen deaktiviert
    Ultimate Blocks: version: 2.5.3, author: Ultimate Blocks, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.0-16-amd64 x86_64
    httpd_software: nginx/1.21.4
    php_version: 8.0.22 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 300
    upload_max_filesize: 256M
    php_post_max_size: 256M
    curl_version: not available
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.6.5-MariaDB-1:10.6.5+maria~bullseye-log
    client_version: mysqlnd 8.0.22
    max_allowed_packet: 16777216
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/intranet/wp-content
    WP_PLUGIN_DIR: /var/www/intranet/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: true
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von michaelbrilz89.

    Geh bitte mal die Punkte durch, die in diesem Beitrag aufgeführt werden:

    How to Fix the “WordPress Keeps Logging Me Out” Issue (7 Methods)

    Thread-Starter michaelbrilz89

    (@michaelbrilz89)

    Danke für den Link 😀
    Allerdings habe ich das alles schon, vor dem erstellen dieses Beitrages, probiert :/
    Habe das gerade noch einmal gemacht, hat leider wieder nicht geholfen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 52)
  • Das Thema „wordpress sitzung läuft immer wieder ab“ ist für neue Antworten geschlossen.