Support » Allgemeine Fragen » WordPress speichert nicht mehr (obwohl nicht offline

  • Hallo.
    seit einiger Zeit setzt WordPress bei mir aus und das Speichern ist nicht mehr möglich. Die Speicher-Buttons werden ausgegraut und unter dem „Veröffentlichen“-Feld erscheint ein drehendes Rädchen. Oben wird allerdings nicht angezeigt, dass WordPress offline ist, sondern alles sieht aus wie immer. Dieser Zustand wird nicht von allein beendet. Es hilft nur die Seite neuzustarten. Danach sind alle ungespeicherten Änderungen natürlich futsch.

    Ist das ein Bug der letzten Version? Gibt es irgendeine Möglichkeit, die Änderungen trotzdem zu speichern? Lässt sich das irgendwie beheben?

    Ich verwende den Classic Editor und einen Pagebuilder von Siteorigin.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Probier bitte mal, ob das Speichern funktioniert, wenn du das Pagebuilder-Plugin deaktivierst. Es geht erst einmal darum, eine mögliche Fehlerursache auszumachen.

    Falls der Fehler weiterhin besteht, schau mal in den Entwickler-Tools des Browsers, ob in der Konsole Fehlermeldungen ausgegeben werden.

    Seit Update auf WordPress 5.5 werden einige veraltete JavaScript-Bibliotheken nicht mehr unterstützt. Wenn du ein älteres Theme oder Plugin verwendest, kann das Ursache für die genannten Probleme sein. Bis der Theme-/Plugin-Entwickler ein Update liefert kannst du als Übergangslösung (!) das Plugin Enable jQuery Migrate Helper nutzen. (Unter Werkzeuge > jQuery Migrate musst du dann noch im Pulldown-Menü die jQuery-Version „Legacy“ auswählen.)

    Probier mal, ob damit die Probleme verschwinden.

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Hä? Wo ist denn meine Antwort hin? o.o

    Keine Ahnung – die Moderations-Warteschlange ist leer und gelöscht haben wir auch nichts von dir. ¯\_(ツ)_/¯

    Für mich hört sich das schwer nach
    – JavaScript-Problem oder
    – Fehler beim AJAX-Call
    an.

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Hallo, das ist sehr merkwürdig, dass meine letzte Antwort nicht veröffentlicht wurde. 2nd Trial…

    Der Ausfall tritt nur sporadisch auf, deswegen kann ich nicht testen.

    Ja, ich verwende das Enable jQuery – Plugin, weil mein Theme es braucht und es wahrscheinlich leider keine Updates mehr geben wird.

    Mittlerweile gab es einige Plugin-Updates, auch einige vom Pagebuilder. Vielleicht ist auch deswegen das Problem bislang nicht mehr aufgetreten.

    Hallo,
    dann wäre es sicher an der Zeit, sich Gedanken zu einem Themewechsel zu machen. Wie Bego bereits geschrieben hat: Das Plugin Enable jQuery Migrate Helper ist nur als Übergangslösung gedacht.
    Aber da du keine URL angegeben hast, werden wir dir hier wohl kaum weiterhelfen können.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Es ist wieder passiert. Und das einzige, was ich im Firefox-Inspektor-Tool finden konnte, waren Meldungen, die auch auftauchten, wenn ich den „gekillten“ Post in einem neuen Tab bearbeitet habe. Nur eine Meldung gab es exklusiv auf der Seite mit dem Speicherproblem:

    Source-Map-Fehler: Error: NetworkError when attempting to fetch resource.
    Ressourcen-Adresse: moz-extension://XXXzensiertXXX-b58e-48b5-8e46-f739fef5fc31/content/js/purify.min.js
    Source-Map-Adresse: purify.min.js.map

    Kann jemand etwas damit anfangen?

    Moderator Bego Mario Garde

    (@pixolin)

    Da gibt es zu viele Vektoren, die eine Rolle spielen könnten.
    Ich würde versuchen, mit dem Plugin Health Check im Problembehandlungsmodus zu testen und Plugins und Theme im Ausschlußverfahren als mögliche Ursache auszuschließen. Ein Update von Core, Theme und Plugins hast du sicher schon gemacht?

    Bisher hatten wir eine solche Fehlermeldung hier nicht.

    hupe13

    (@hupe13)

    Source-Map-Fehler: Error: NetworkError when attempting to fetch resource.
    Ressourcen-Adresse: moz-extension://XXXzensiertXXX-b58e-48b5-8e46-f739fef5fc31/content/js/purify.min.js
    Source-Map-Adresse: purify.min.js.map

    Das kommt von einer Erweiterung von Firefox. Vielleicht stört die, Du kannst sie ja mal testweise deaktivieren. map-Dateien werden nur in den Entwicklerwerkzeugen verwendet, deren Verwendung kann man irgendwo abschalten.

    Zum eigentlichen Problem kann ich leider nichts sagen. Vielleicht hilft ein Blick auf die Netzwerkanalyse in den Entwicklerwerkzeugen, ob alle Dateien ohne Fehler geladen werden. Dazu müssen die Entwicklerkonsole immer geöffnet sein.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)