Support » Themes » WordPress Teme (the7) wird für externe nicht richtig angezeigt

  • Gelöst seiter

    (@seiter)


    Hallo zusammen,

    seit dieser Woche haben wir Probleme mit unserer Homepage. Wenn ich die Seite bearbeite, also angemeldet bin, wird Sie richtig angezeigt mit richtigem Header, Slider etc.

    Sobald ich mich abmelde oder an einem nicht angemeldeten Rechner bin, funktioniert das Theme nicht mehr richtig und es sieht schlecht aus.

    Hat hier jemand Erfahrungswerte und könnte mir weiterhelfen?

    Eine weitere Frage wäre, ob man einen gelöschten Footer, bzw einen geänderten Theme Editor wiederherstellen kann?

    Vielen Dank im voraus für eure Hilfe!!!

    PS: Ist mein erster Beitrag, weis nicht ob das hier so richtig ist…

    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von seiter.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Da scheint aber einiges schief zu laufen, z.B.

    Laden fehlgeschlagen für das <script> mit der Quelle „https://www/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js&#8220;.
    Laden fehlgeschlagen für das <script> mit der Quelle „https://www/wp-content/cache/min/1/877aa2a5cb61dc6ffb38704f9ffe7c42.js&#8220;.

    Auch CSS-Dateien und Grafiken sollen über https://www/wp-content geladen werden, das kann alles nicht funktionieren.

    Sieh‘ mal nach, was im Dashboard und Einstellungen/Allgemein bei WordPress-Adresse (URL) und Website-Adresse (URL) steht.

    Thread-Ersteller seiter

    (@seiter)

    hast du einen Tipp wie ich das ändern könnte?

    Bei den Einstellungen ist die richtige Domain URL hinterlegt. bei beiden ist die selbe URL hinterlegt

    Kannst du per FTP-Programm auf deinen Webspace zugreifen?
    Dann verwende bitte einen geeigneten Editor (z.B. Atom Editor oder Notepad++, bitte nicht Windows Notepad oder Mac Texteditor und füge in der Datei wp-config.php oberhalb von
    /* That's all, stop editing! Happy blogging. */
    folgendes ein:
    define( 'RELOCATE', true );

    Thread-Ersteller seiter

    (@seiter)

    Leider kenne ich mich mit FTP Programmen nicht aus… Gibt es eine Möglichkeit im WordPress Backend etwas zu bearbeiten?

    Ich bin auch der Meinung(weiß nicht ob das stimmt) dass sich der Theke Editor verändert hat… Kann man da was zurücksetzen?

    Hallo,
    wenn du damit nicht klar kommst, wäre es sicher besser, wenn du einen Dienstleister (aber bitte nicht in diesem Forum) suchst.
    Der Theke Editor ist mir nicht bekannt. Theke passt eher zum derzeitigen Wetter 😉
    Vielleicht meinst du den Block-Editor.
    Wir können dir bei gekauften Themes (hier The7) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das passende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ (B 5.) zu diesem Thema.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller seiter

    (@seiter)

    Theme Editor natürlich 😅

    Hallo,
    du änderst aber nicht wirklich irgendwelche Dinge unter Design > Theme-Editor?
    Das ist – wenn es denn funktioniert – beim nächsten Update weg und wenn es nicht funktioniert, hast du ein Problem mit dem Theme.
    Dafür ist ein Child Theme gedacht. Eine umfangreichere Darstellung findest du z. B. hier.
    Hier noch ein weiterer Link direkt auf wordpress.org.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller seiter

    (@seiter)

    Also irgendwie haben wir es hinbekommen gehabt, dann lief sei zwei Tage, jetzt wird Sie wieder fehlerhaft angezeigt,

    Gestern Abend war die Website dann wieder normal und heute morgen wieder nicht…

    Woran kann das liegen?

    Also irgendwie haben wir es hinbekommen gehabt, dann lief sie zwei Tage, jetzt wird sie wieder fehlerhaft angezeigt,

    OK, du hast also deine Katze gefüttert, sie lief dann zwei Tage und jetzt sie wieder komisch aus? 😺

    Spaß beiseite – wenn du nicht genau erklärst, was du machst, was das Ergebnis sein soll und was statt dessen passiert, können wir das auch nicht nachvollziehen und dir kaum helfen. Mit Aussagen wie „wir haben es hinbekommen“ kann hier kaum jemand etwas anfangen.

    Thread-Ersteller seiter

    (@seiter)

    Die Homepage lief bis Sonntag nicht. Am Freitag haben wir versucht per wp-config direkt auf dem FTP-Server den Eintrag zu bearbeiten, was aber nicht geklappt hat bzw. eventuell auch erst verzögert geklappt hat. Am Montag morgen funktionierte die Website wieder einwandfrei. Heute Morgen jedoch, ist das alte Problem wieder aufgetreten, sprich, das Theme wird nur im Backend richtig angezeigt, wenn man die Homepage aber besucht (www.peter-hertweck-forum.de) ist wieder alles verschoben.

    Meine Frage hierzu ist: Wie kann das sein, ohne das etwas bearbeitet wurde und woran kann hier das Problem liegen?

    Dein Slider-Plugin Revolution Slider scheint Probleme zu bereiten.
    Deaktvier das Plugin doch mal und schau, wie die Website dann aussieht.

    Du kannst auch mal versuchen, das Plugin Enable jQuery Migrate Helper zu installieren. (Unter Werkzeuge > jQuery Migrate musst du dann noch im Pulldown-Menü die jQuery-Version „Legacy“ auswählen.)

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)