Support » Allgemeine Fragen » WordPress und Chrome

  • Gelöst katharina0815

    (@katharina0815)


    Hallo, ich habe eine Unverträglichkeit von WordPress und Chrome festgestellt und frage mich, ob ich da irgendwas falsch mache oder ob es einen Bug gibt. Und zwar fehlen bei den Beiträgen die Felder AUTOR, KATEGORIE und SCHLAGWÖRTER. Außerdem werden werden weder Beitragsbilder noch Bilder innerhalb des Textes geladen. Konkreter: Upload in die Mediathek funktioniert, aber der Beitrag kann nicht mehr gespeichert werden (Endlosschleife). Wenn ich DENSELBEN Beitrag im Firefox öffne und bearbeite funktioniert ALLES, wie es soll.

    Chrome 79.0.3945.88, WordPress 5.3.2 mit Theme Twenty Fifteen., Win 10

    Weiß jemand, was da los ist?

    Screenshot

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Verwendest du den Classic Editor? Dort kannst du über das Pull-Down-Menü Ansicht anpassen festlegen, welche Abschnitte angezeigt werden. Die Einstellungen werden im Browser gespeichert, was einen Unterschied erklären würde. Allerdings erklärt das nicht, wieso das Beitragsbild in einem Browser lädt, im anderen nicht.

    Hast du bei beiden Browsern mal den Cache geleert und die Cookies gelöscht?

    Es kann auch gut sein, dass eines deiner Plugins oder das verwendete Theme Fehler enthält und ein Browser damit toleranter umgeht, während der andere – z.B. beim Beitragsbild – nichts anzeigt. Testen kannst du das mit dem Plugin Health Check.

    Unglückseligerweise hat mir Health Check empfohlen, die PHP-Version zu wechseln und jetzt ist die Seite gar nicht mehr zu erreichen (habe ich vor über einer Stunde gemacht). Ich muss jetzt also erst einmal warten, was mein Hoster dazu sagt und melde mich dann wieder…

    Ich glaube nicht, dass es „unglückselig“ ist, AnwenderInnen zu empfehlen, eine aktuelle PHP-Version zu verwenden. Dass dein Theme oder eines deiner Plugins nicht mit der aktuellen PHP-Version zurechtkommt, ist ärgerlich. Waren alle Plugins und das verwendete Theme aktualisiert?

    Du könntest schauen, ob du zumindest Zugriff auf dein Backend bekommst, wenn du per FTP das Plugin-Verzeichnis umbenennst. Dadurch werden alle Plugins vorübergehend deaktiviert; nach zurück-benennen kannst du sie einzeln wieder aktivieren und so prüfen, wo die Fehlerursache liegt. Hilft das Umbenennen des Plugin-Verzeichnisses nicht, kannst du das Theme-Verzeichnis deines zuletzt benutzen Themes umbenennen. WordPress fällt dann auf eines der Standard-Themes zurück.

    Anschließend müsstest du schauen, ob du das Plugin oder Theme gegen eine neuere Version austauschen kannst.

    Der Server hatte wohl Schluckauf. Der Supporter hat mir geschrieben, dass er ein weiteres Mal auf OK geklickt hat und seitdem ist alles wieder da. Tja…

    Deine Tipps haben mich weitergebracht, ohne dass ich das „wieso“ verstehe. Ich verwende den eingebauten visuellen Editor (heißt wohl Gutenberg). Dort habe ich nun unter „Ansicht anpassen“ die Option „Eigene Felder“ angeklickt. Nachdem die Seite neu geladen wurde, war „Eigene Felder“ zwar weiterhin NICHT aktiviert, aber dafür waren die fehlenden Felder wieder da und die Bildanzeige und Beitragsspeicherung funktioniert wieder.

    An Cookies oder Cache sollte es nicht gelegen haben. Beim Chrome habe ich gestern mehrfach alles gelöscht, weil ich ein Cookie-Hinweis-Plugin installiert und getestet habe. Beim Firefox, bei dem es ja funktionierte, habe ich dagegen den Cache ewig nicht geleert, weil ich diesen Browser nur sporadisch nutze.

    Ein Problem, dass ich erst heute lösen konnte, war die richtige Konfiguration des https-Krams. Bei WordPress war http statt https eingetragen und bei den Hosting-Einstellungungen hatte ich die „dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS“ nicht aktiviert. Aber kann das Auswirkung auf den Editor haben? Und nur unter Chrome?

    Misteriös, aber durch deine Hilfe habe ich auf den richtigen Button geklickt. Danke!

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)