Support » Themes » WordPress-Variable wird nicht in meinem SASS erkannt

  • ulrichreto

    (@ulrichreto)


    Ich habe folgende Ausgangslage

    Ich binde in einem WP-Theme mein eigenes CSS „main.css“ ein. Dieses main.css kompilliere ich von einem main.scss. In diesem main.scss wiederum habe ich Bootstrap-Framework eingebunden, damit es mir möglich ist, die Bootstrap-Standardvariabeln zu überschreiben.

    Nun ist eine dieser Bootstrap-Variablen „$primary“, welche die Primäre Farbe definiert: Bekannterweise wäre dies also z.B. so:
    $primary: #fab300;

    Im neuen FSE-Modul von Worpress, gibt es die theme.json, welche globale Werte für das Theme definiert, so z.b. eben eine Primärfarbe: Diese Primärfarbe wird als Custom Property mit --wp--preset--color--primary ausgegeben.

    Ich möchte diese Primärfarbe nicht einmal im theme.json und in meinem SASS-File definieren müssen, sondern würde in meinem SASS-File gerne auf die Custom Property mappen. Das ganze mache ich so:
    $primary: --wp--preset--color--primary;

    Mein Problem ist nun folgendes: Wenn ich diese Codezeile verwende erhalte ich beim kompillieren des SCSS-Files die Meldung, dass --wp--preset--color--primarykeine Farbe sei, und es wird kein SCSS-File erstellt.

    Kennt das Problem jemand? Kann mir allenfalls jemand per Slack, Teams, etc. über die Schulter schauen und behilflich sein? Ich denke es müsste hierfür sicher irgendeine Lösung geben.

Ansicht von 1 Antwort (von insgesamt 1)
  • die Frage hast du doch bereits in diesem Thread gestellt.
    Auf die Antwort von Bego hast du aber nicht geantwortet. Insofern bringt es doch nichts, wenn du das Thema hier noch mal anbringst.
    Daher schließe ich das Thema und möchte dich bitten, die Frage in dem o. g. Thread ggfs. zusätzlich zu erläutern.

Ansicht von 1 Antwort (von insgesamt 1)
  • Das Thema „WordPress-Variable wird nicht in meinem SASS erkannt“ ist für neue Antworten geschlossen.