Support » Installation » WordPress via Strato eingerichtet – Jetzt komme ich nicht mehr auf WordPresssite

  • Gelöst caro92x

    (@caro92x)


    Hallo zusammen,
    erst einmal vielen Dank! Ich bin ein absoluter WordPress Neuling, habe mich bis jetzt immer mit Tutorials und Trial and Error durchgemogelt bei Problemen, aber jetzt komme ich absolut nicht weiter. Ich hoffe, ich habe das richtige Forum ausgewählt, die Einschätzung wohin es genau gehört, ist mir etwas schwer gefallen.

    Nun aber zum Problem:
    Ich habe versucht im WordPress Dashboard über Settings den Domainnamen zu ändern. Das hat die Seite komplett zerschossen. Daraufhin habe ich wieder die alte Domain dort eingetragen, weil ich dachte, dass ich es so rückgängig machen kann. Hat nichts gebracht. Wirklich problematisch ist, dass ich seitdem auch nicht mehr in den WordPress-Admin Bereich komme, da ich mich dort immer über die Strato Schnittstelle eingeloggt habe und das geht nicht mehr. Ein direkter Login über WordPress scheint nicht zuklappen oder ich weiß nicht welche Login Daten ich dafür bräuchte (die Strato Daten funktionieren auf jeden Fall nicht).

    Hintergrund:
    Das Hosting und die Domainregistrierung habe ich damals über Strato gemacht. Dort gab es dann die Möglichkeit per Button-Klick eine entsprechende WordPressseite anzulegen und so die Domain mit WordPress zu verknüpfen. Habe ich gemacht. Zur WordPress Admin Seite bin ich immer nur gegangen, indem ich mich bei Strato eingeloggt habe und dann auf Login zu WordPress geklickt habe. Hier war dann das Login dasselbe wie für Strato (Stratokundennummer & Stratopasswort). Jetzt funktioniert diese Verknüpfung nicht mehr und ich weiß nicht, wie ich auf die WordPressseite kommen soll. Ich habe Angst, dass wenn ich jetzt bei Strato irgendwas lösche, die WordPresssachen (Theme, Inhalt etc.) irgendwo im Nirvana verschwinden.

    Das selbe ist mir (in anders) auch schon für eine andere Domain passiert (dasfreundschaftsbuch.de). Hier hatte ich versucht, die Domain auf eine andere interne Domain umzuleiten. Hat nicht geklappt. Also habe ich auf Domainumleitung zurücksetzen geklickt und seit dem konnte ich mich dann aber auch nicht mehr bei der zugehörigen WordPressseite anmelden. Das war in dem Fall damals nicht so schlimm, da die Seite noch kaum bearbeitet war, aber wäre natürlich schön, auch dort wieder hin zurückzufinden.

    Ich weiß, mein Hosting, Website etc. Wissen ist super rudimentär. Ich habe inzwischen verstanden, dass bildlich gesprochen, Strato eher die leere Mietwohnung, die ich miete ist und das WordPress eher das Mobiliar, was ich anschaffe ist. Aber demnach habe ich mir auf WordPress eine komplette Inneneinrichtung erstellt, die ich jetzt nicht mehr finden kann. Existiert dieser WordPressteil jetzt einfach so weiter und ich finde nur nicht mehr den „Schlüssel“ um diese Wohnung zu öffnen? Falls mir hier jemand helfen kann wäre ich super dankbar! Wenn jemand Lust hätte, gegen eine kleine Aufwandsentschädigung mir ein paar wichtige Basics in einem kurzen Skype zu erklären (und das Problem mit mir zu lösen) wäre ich auch dafür total dankbar.

    Vielen Dank schon mal!
    Viele Grüße

    • Dieses Thema wurde geändert vor 3 Wochen von caro92x.
    • Dieses Thema wurde geändert vor 3 Wochen von caro92x.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Moderator Bego Mario Garde

    (@pixolin)

    Meld dich bitte mal im Kundemenü von Strato an und geh dort in das Menü Datenbanken und Webspace, dort in Datenbankverwaltung.
    Dort solltest du die Datenbank finden, die für WordPress verwendet wird. Ganz rechts in der Zeile steht phpMyAdmin starten.

    In phpMyAdmin wählst du die Datenbank-Tabelle wp_options aus, wobei die Vorsilbe wp_ bei dir anders lauten kann. Gleich am Anfang sollte sie Zeile mit der verkehrten URL stehen. Geh hier auf den Link Bearbeiten und korrigiere dann in der Zeile option_value die URL. Ganz unten mit OK bestätigen und dann schaust du, ob deine Website wieder läuft.

    Noch ein Hinweis: Jobangebote (dazu gehört auch sowas wie „Wenn jemand Lust hätte, gegen eine kleine Aufwandsentschädigung …“) sind hier ausdrücklich unerwünscht. Einige Helfer sind bei Agenturen fest angestellt und möchten ungern den Eindruck erwecken, dass sie hier Nebeneinkünfte erzeugen.

    Ich habe versucht im WordPress Dashboard über Settings den Domainnamen zu ändern.

    Dieses Problem sollten den Entwicklern von WordPress doch nicht unbekannt sein. Warum, um alles in der Welt, sind die nicht mal auf die Idee gekommen, das abzusichern und mindestens eine Warnung anzuzeigen? Man bekommt das ja auch hier im Forum oft genug mit, dass sich unerfahrene Anwender sich ihr System damit zerschießen.

    souri

    (@souri)

    WordPress ist ein offenes System und das heißt auch, dass man als Anwender selbst viel machen kann.
    Das sind Freiheiten – eben Dinge nach eigenen Wünschen anzupassen.
    Was du als Problem ansiehst, sehen andere als Feature an.
    Die Regel ist auch: Wenn ich nicht weiß, was eine Einstellung macht, ändere ich da nichts.
    Sehe das eher als Anwenderfehler, sorry!
    Wenn du hier eine Domain einträgst, dann ändert das ja nichts an den DNS-Einträgen, am Mapping oder whatever.

    Zum Einloggen über Strato: JA, SSO mag praktisch sein, aber ich hätt persönlich ein Problem damit, mich immer auf das BACKEND eines Hosters einzulassen.

    Keiner der großen schafft es da, immer zu 100% zu funktionieren.

    An den TE:
    Dein Einloggen in die Seite is ja auch net schwer hinzubekommen, wenn Strato grad nicht will.
    Geh einfach auf
    https://meine-entwickler-domain-als-beispiel.at/wp-login.php

    Dort gibt es den Link „Passwort vergessen?“
    Wenn du deine E-Mail oder deinen Usernamen weißt, kannst du dir ja einen Passwort-Zurücksetzen-Link schicken lassen.
    Falls du das nicht weißt, kannst du bei Strato in die DB-Verwaltung gehen und dir so diese Daten raussuchen.

    It’s a bug, not a feature..äh..ich mein: It’s a feature, not a bug! 😀

    • Diese Antwort wurde geändert vor 3 Wochen von souri.

    @souri

    Sehe das eher als Anwenderfehler

    Natürlich ist das ein Anwenderfehler, keine Frage. Aber bei so einer wichtigen Einstellung kann doch ein Warnhinweis nicht verkehrt sein, oder eine andere Absicherung. Programmiertechnisch sollte das doch kein Problem für die Entwickler sein.

    Moderator Bego Mario Garde

    (@pixolin)

    Warum, um alles in der Welt, sind die nicht mal auf die Idee gekommen, das abzusichern und mindestens eine Warnung anzuzeigen?

    Vor ein paar Wochen wurden WordPress-Nutzer gebeten, Feature-Vorschläge zu machen. Da hatte ich einen Warnhinweis beim Ändern der URL vorgeschlagen, bekam auch von zwei Teilnehmern ein positives Feedback, aber wie das so ist … wenig Entwickler/-innen, viele Prioritäten.

    @pixolin
    Ich verstehe so etwas nicht, das sind ein paar Zeilen JavaScript in der Datei options-general.php, das sollte doch nun wirklich kein Problem sein. Man kann doch davon ausgehen, dass nicht nur in diesem Forum dieses Thema immer wieder aufschlägt, sondern weltweit unerfahrene Anwender in diese Falle tappen. Es muss ja keine superelegante Lösung sein, aber ein Warnhinweis wäre wirklich wichtig.

    @bscu:

    Aber bei so einer wichtigen Einstellung kann doch ein Warnhinweis nicht verkehrt sein, oder eine andere Absicherung.

    3 Daumen hoch!

    @pixolin:

    Vor ein paar Wochen wurden WordPress-Nutzer gebeten, Feature-Vorschläge zu machen.

    Da hätte ich gerne mitgemacht

    Da hatte ich einen Warnhinweis beim Ändern der URL vorgeschlagen,

    ich auch!

    @pixolin hast du einen Link zum Ticket für mich?
    Sollte ja wirklich nicht so viel Aufwand sein und so einen kleinen Patch könnt ich ev einreichen…

    @souri Das war kein Bug-Ticket. Es gab irgendwann einen Aufruf, Ideen für neue Features einzureichen und dort hatte ich als Kommentar angegeben, dass ein Warnhinweis hilfreich wäre, wenn Anwender/-Innen entweder in Einstellungen/Allgemein unterschiedliche URLs eingeben (z.B. wegen der fehlerhaften Annahme, die URL müsse einmal mit www und einmal ohne eingegeben werden) oder URLs eingeben, die es nicht gibt oder die nicht erreichbar sind (typischer Fehler ist die Eingabe einer URL mit https, ohne dass ein SSL-Zertifikat eingerichtet wurde).

    Ich bin vorhin die Liste aller Blogbeiträge des Core-Teams aus 2021 durchgegangen, habe den Thread aber nicht mehr gefunden.

    Thread-Ersteller caro92x

    (@caro92x)

    Vielen Dank für den Support! Das Problem konnte behoben werden.

    Viele Grüße und einen schönen Sonntagabend.

    Hallo,
    danke für die Info. Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren. Das habe ich jetzt schon gemacht.
    Wir freuen uns auch, wenn du für Mitleser kurz beschreibst, wie du das Problem erledigt hast. Danke.
    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 2 Wochen, 6 Tage von Hans-Gerd Gerhards. Grund: als gelöst markiert
    Thread-Ersteller caro92x

    (@caro92x)

    Hallo Hans-Gerd/ @hage,

    vielen Dank für das Feedback und das Markieren als gelöst. Ich hatte den Status sogar auch selbst auf „gelöst“ gestellt, wohl jedoch vergessen, auf „Aktualisieren“ zu klicken. Das werde ich nächstes Mal beachten!

    „Wir freuen uns auch, wenn du für Mitleser kurz beschreibst, wie du das Problem erledigt hast.“ Gerne!

    Man muss als Ergänzung vielleicht noch dazu sagen, dass ich retrospektiv, anders als von mir zuerst beschrieben, zwei Dinge falsch gemacht habe. Erst habe ich die Website innerhalb des WordPress Dashboards zerschossen (siehe Problembeschreibung), dann hatte ich versucht den Fehler im Strato Hosting Bereich unter „Domainverwaltung“ rückgängig zu machen, indem ich auf „Umleitung deaktivieren“ geklickt habe (die Hauptdomain „domain.de“ wurde zuvor auf eine Subdomain „test.domain.de“ umgeleitet). Dieser Schritt hat dann letztendlich dazu geführt, dass ich mich neben der Tatsache, dass die Website total zerschossen aussah, nicht mehr in WordPress anmelden konnte. Dass es sich quasi um zwei separate Probleme handelte, habe ich jedoch zum Zeitpunkt der Problembeschreibung nicht realisiert. @souri das Login Problem lag daher nicht am fehlenden Passwort, sondern daran, dass der Server die Datenbank nicht mehr finden konnte. Das habe ich jedoch erst nachdem ich deinen Tipp ausprobiert habe realisiert.

    Letztendlich war der Vorschlag von @pixolin im ersten Beitrag genau richtig! Ich war bei der Umsetzung jedoch in der Datenbank von einer falschen Domain (domain.com anstatt .de) ohne es zu merken, sodass es für mich zuerst keinen Sinn ergeben hat.
    Ich habe mich dann aber irgendwann überwunden, den Strato Kundenservice anzurufen und zu sagen, dass ich mich nicht mehr bei WP anmelden kann, weil ich die Domainumleitung auf „rückgängig“ gestellt habe. Der Mitarbeiter hat mir dann tatsächlich auch geholfen! Nach vorheriger negativer Erfahrung in einem anderen Fall, hatte ich eigentlich nicht damit mit gerechnet, dass Strato bereit ist hier zu helfen, der Anruf war eher aus der Verzweiflung heraus. Der Mitarbeiter war jedoch sehr freundlich, hat alles wieder hingebogen und mir erklärt, was er gemacht hat. Das war dann genau das, was @pixolin beschrieben hatte:

    „Meld dich bitte mal im Kundemenü von Strato an und geh dort in das Menü Datenbanken und Webspace, dort in Datenbankverwaltung.
    Dort solltest du die Datenbank finden, die für WordPress verwendet wird. Ganz rechts in der Zeile steht phpMyAdmin starten.

    In phpMyAdmin wählst du die Datenbank-Tabelle wp_options aus, wobei die Vorsilbe wp_ bei dir anders lauten kann. Gleich am Anfang sollte sie Zeile mit der verkehrten URL stehen. Geh hier auf den Link Bearbeiten und korrigiere dann in der Zeile option_value die URL. Ganz unten mit OK bestätigen und dann schaust du, ob deine Website wieder läuft.“

    Allen noch einmal vielen Dank für den Support!

    Wir lesen hier leider öfters, dass Mitarbeiter/-innen im Support bei Strato Hilfe zu WordPress ablehnen. Schön, dass du da jemand gefunden hast, der kooperativer war und helfen konnte.
    Grundsätzlich ist es schon richtig, dass Webhoster keinen Support für Webanwendungen übernehmen können – dafür gibt es einfach zu viele Anwendungsmöglichkeiten. Ein wenig kundenfreundlicheren Umgang würde ich mir trotzdem so manches Mal wünschen.

    Freut mich, dass meine Anleitung (über Umwege) zum Erfolg geführt hat. Es ist vielleicht ein schwacher Trost, aber du bist ganz bestimmt nicht die Erste, die an der falschen Datenbank werkelt. Ich habe da einschlägige Erfahrungen. 😉

    Hallo @caro92x,
    danke für die umfangreiche Rückmeldung.
    Bei Strato erst mal durchzukommen, ist schon ein Abenteuer.
    Immerhin scheint es ja tatsächlich auch Mitarbeiter bei Strato zu geben, die helfen können. Vor ein paar Tagen musste ich bei Strato wegen eines Problems auf einer Kundenseite anrufen. Ich war mit der Problembeschreibung noch nicht ganz fertig, da war die Leitung tot. Beim zweiten Anruf sagte mir die nette Mitarbeiterin, sie könne mir leider nicht helfen, es sei denn, es ginge um die Installation von WordPress. Nun, das bekomme ich in der Regel noch gerade selber hin 😀
    Danke noch mal.
    Viele Grüße
    Hans-Gerd

    @hage

    Nun, das bekomme ich in der Regel noch gerade selber hin

    Genie 😀

    Ich lese häufiger, dass der Support von Strato nicht so dolle sein soll. Meine Erfahrungen sind da ganz andere, in den meisten Fällen sind das aber auch keine Fragen zu Datenbanken, WordPress, etc., sondern zu Servern, die eine Firma eines Freundes gemietet hat. Der Business-Support scheint also besser zu sein, als der Standard-Support 😉

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)