Support » Allgemeine Fragen » WordPress wird nicht automatisch aktualisiert

  • Gelöst watzweb

    (@watzweb)


    Hallo zusammen,

    ich habe ein (wahrscheinlich nur) kleines Problem.

    Hier die Beschreibung:

    Ich habe zwei Webseiten, die ich betreue. Bei beiden läuft die WordPressversion 5.5.3, also die aktuellste. Ich habe eingestellt, dass sich die Plugins automatisch aktualisieren sollen. So weit so gut. Nur leider aktualisert nur eine der beiden Webseiten die Plugins sowie WordPress und die andere halt nicht.

    An was kann das liegen?

    Noch ein wichtiger Hinweis: Beide Webseiten werden beim selben Anbieter gehostet.

    Vielen Dank schon mal für die Hilfe!

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ohne weitere Angaben zu den Websites lässt sich die Frage nicht beantworten.
    Mögliche Gründe, die mir spontan einfallen:

    • Eine Website wird seltener besucht als die andere. Da WordPress bei jedem Webseiten-Abruf prüft, ob zwischenzeitlich Aufgaben angefallen sind die abgearbeitet werden müssen („Pseudo-Cron“), kann sich umgekehrt wenn keine Seiten abgerufen werden, die Prüfung auf Updates verzögern.
    • Automatische Updates können auf verschiedene Weise unterbunden werden. Dazu gehören Plugin-Einstellungen, Konstanten in der Konfigurationsdatei wp-config.php und Filter in der functions.php des Themes. Während in der wp-config.php Konstanten wie define( 'WP_AUTO_UPDATE_CORE', false ); offensichtlich sind, kann auch ein zur Sicherheit der Website vor Fehleingaben des Benutzers vorgenommener Eintrag von define( 'DISALLOW_FILE_MODS', true ); unbeabsichtigt Updates deaktivieren. (Guter Beitrag dazu: https://kinsta.com/blog/wordpress-automatic-updates/)
    • Viele Webhoster bieten inzwischen eine automatische Installation von WordPress an und vereinfachen damit für Einsteiger die Installation. Manche Webhoster (z.B. Strato) installieren allerdings eine nach eigenen Vorstellungen angepasste Fassung, bei der eine automatische Aktualisierung aus verschiedenen Gründen abgestellt sein kann. (Strato begründet das damit, dass die Aktualisierung über das Kundenmenü ausgelöst werden soll.)
    Thread-Ersteller watzweb

    (@watzweb)

    Ich würde spontan auf den ersten Punkt tippen, die Seite wird wirklich seltener besucht. Ich werde das mal beobachten!

    Dankeschön!

    Thread-Ersteller watzweb

    (@watzweb)

    Hallo,

    ich habe das Problem jetzt mal beobachtet. Dabei ist mir aufgefallen, dass auf der Pluginseite steht: Automatische Aktualisierung geplant in 15 Jahren.
    Da ist klar, dass WordPress nicht aktualisiert.

    Jetzt meine Frage: Was ist der Auslöser für dieses Problem?

    Schon mal vielen Dank für Eure Hilfe.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller watzweb

    (@watzweb)

    
    ### wp-core ###
    
    version: 5.5.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/sites/site100017884/web/wordpress
    wordpress_size: 53,35 MB (55945049 bytes)
    uploads_path: /home/sites/site100017884/web/wordpress/wp-content/uploads
    uploads_size: 789,94 MB (828312588 bytes)
    themes_path: /home/sites/site100017884/web/wordpress/wp-content/themes
    themes_size: 7,56 MB (7926847 bytes)
    plugins_path: /home/sites/site100017884/web/wordpress/wp-content/plugins
    plugins_size: 51,52 MB (54022694 bytes)
    database_size: 29,05 MB (30463665 bytes)
    total_size: 931,43 MB (976670843 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Neu
    version: 1.0
    author: XXX
    author_website: none
    parent_theme: none
    theme_features: core-block-patterns, title-tag, editor-style, automatic-feed-links, post-thumbnails, menus, post-formats, custom-logo, custom-header, editor-styles, widgets
    theme_path: /home/sites/site100017884/web/wordpress/wp-content/themes/Neu
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twelve: version: 3.2, author: WordPress-Team,Automatische Aktualisierung aktiviert
    
    ### wp-plugins-active (17) ###
    
    Autoptimize: version: 2.7.8, author: Frank Goossens (futtta), Automatische Aktualisierung aktiviert
    BackWPup: version: 3.8.0, author: Inpsyde GmbH, Automatische Aktualisierung aktiviert
    Bildquellenangaben: version: 1.0, author: Olaf Parusel, Automatische Aktualisierung aktiviert
    Broken Link Checker: version: 1.11.15, author: WPMU DEV, Automatische Aktualisierung aktiviert
    Compress JPEG & PNG images: version: 3.2.1, author: TinyPNG, Automatische Aktualisierung aktiviert
    Contact Form 7: version: 5.3, author: Takayuki Miyoshi, Automatische Aktualisierung aktiviert
    Disable Toolbar: version: 1.0, author: Michael Dance, Automatische Aktualisierung aktiviert
    Download Monitor: version: 4.4.4, author: Never5, Automatische Aktualisierung aktiviert
    DSGVO All in one for WP: version: 3.8, author: Michael Leithold, Automatische Aktualisierung aktiviert
    Elementor: version: 3.0.13, author: Elementor.com, Automatische Aktualisierung aktiviert
    Limit Login Attempts Reloaded: version: 2.15.2, author: WPChef (latest version: 2.16.0), Automatische Aktualisierung aktiviert
    Page Restrict: version: 2.2.9, author: Matt Martz & Andy Stratton, Automatische Aktualisierung aktiviert
    WP-Sweep: version: 1.1.3, author: Lester 'GaMerZ' Chan, Automatische Aktualisierung aktiviert
    WP Calendar: version: 1.5.3, author: Fabian von Allmen, Automatische Aktualisierung aktiviert
    WPS Hide Login: version: 1.5.7, author: WPServeur, NicolasKulka, wpformation (latest version: 1.6), Automatische Aktualisierung aktiviert
    WP Super Cache: version: 1.7.1, author: Automattic, Automatische Aktualisierung aktiviert
    WP SVG images: version: 3.2, author: KubiQ, Automatische Aktualisierung aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1802
    imagemagick_version: ImageMagick 7.0.10-23 Q16 x86_64 2020-07-21 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 500M
    upload_max_filesize: 500M
    max_effective_size: 500 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 75000
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.50
    
    ### wp-server ###
    
    server_architecture: Linux 5.4.56 x86_64
    httpd_software: Apache
    php_version: 7.4.11 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 128M
    max_input_time: 240
    upload_max_filesize: 500M
    php_post_max_size: 500M
    curl_version: 7.71.0 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.2.29-MariaDB-log
    client_version: mysqlnd 7.4.11
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/sites/site100017884/web/wordpress/wp-content
    WP_PLUGIN_DIR: /home/sites/site100017884/web/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 128M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Thread-Ersteller watzweb

    (@watzweb)

    Hallo,

    mittlerweile sind mehrere Plugins upzudaten. Kann ich das manuell machen oder soll ich warten bis der Fehler gefunden ist, um den Fehler nachvollziehen zu können?

    LG

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    ich glaube zwar nicht, dass das Problem so zu lösen ist, aber momentan fällt mir nichts anderes dazu ein:
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße,
    Hans-Gerd

    Thread-Ersteller watzweb

    (@watzweb)

    Ich habe das jetzt mal versucht. Und wie du schon vermutet hast leider ohne Erfolg.
    Mir ist jedoch beim Website-Zustand aufgefallen dass da dieser Abschnitt steht. Vielleicht hilft das weiter bei der Fehlersuche :

    1 empfohlene Verbesserung
    Ein geplantes Ereignis ist verspätet Leistung

    Das geplante Ereignis, inpsyde_phone-home_checkin, wird zu spät ausgeführt. Deine Website funktioniert noch, aber das kann darauf hindeuten, dass die Planung von Beiträgen oder automatisierten Updates nicht wie geplant funktioniert.

    Schon mal vielen Dank für deine Mühe!

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    möglicherweise gibt es ein Problem in Bezug auf WP-Cron.
    Ich kann mich erinnern, dass wir aus diesen Gründen vor einigen Jahren auf einer Webseite das Plugin WP Crontol eingesetzt haben.
    Das Plugin „lässt dich anzeigen und kontrollieren, was im WP-Cron-System passiert.“
    Man kann allerdings auch über die wp-config.php Einstellungen vornehmen.
    Eine gute Anleitung bezogen auf solche Probleme findest du hier
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller watzweb

    (@watzweb)

    Hallo,

    ich habe dieses Plugin installiert. Dort habe ich gesehen, dass die Ausführungszeiten irgendwann im Jahre 2036 liegen. Ich habe die nächste Ausführung bei allen Jobs auf „Jetzt“ gesetzt. Dadurch hat WP die Updates automatisch ausgeführt.
    Ich werde das jetzt nochmal beobachten, aber ich denke das Problem ist gelöst.

    Vielen lieben Dank für die Hilfe!

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    na, das hört sich ja gut an, auch wenn ich es seltsam finde, dass die Ausführungszeit 2036 angegeben war.
    Es wäre nett, wenn du eine Rückmeldung beizeiten gibst und (hoffentlich) das Thema dann als gelöst markieren kannst.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller watzweb

    (@watzweb)

    Hallo,

    ich heute hat WordPress von ganz alleine aktualisiert.
    Hiermit werde ich das Thema auch als gelöst markieren. Hier noch die Beschreibung zur Lösung der Fehler (meines Erachtens haben die nicht ausgelöste Aktualisierung und der Fehler mit dem Ereignis inpsyde_phone-home_checkin nichts miteinander zu tun).

    1. Automatische Aktualisierung funktioniert nicht:
    Mit dem Plugin WP Crontol die Auslösungszeiten auf „Jetzt“ setzen. Danach müssten sie wieder ganz normal auslösen.

    2. Ereignis inpsyde_phone-home_checkin:
    Wenn das Plugin BackWPup installiert ist in den Einstellungen das Häkchen bei „Phone Home aktivieren“ entfernen.

    Ich hoffe ich konnte hiermit auch anderen helfen.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    danke für die Info.
    Viele Grüße
    Hans-Gerd

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „WordPress wird nicht automatisch aktualisiert“ ist für neue Antworten geschlossen.