Support » Allgemeine Fragen » WordPress zeigt keinen Code an

  • Gelöst Anonymous User 17650761

    (@anonymized-17650761)


    Ich möchte gerne folgenden PHP Code Ausgeben:

    <?php echo $test; ?>

    Im ganz normalen Textfeld wird er einfach nicht angezeigt.
    Wenn ich auf einen vorformatierten Block umschalte wird der Block jedoch ohne Inhalt angezeigt.
    Wenn ich auf Code umschalte wird überhaupt nichts angezeigt.

    Im Quellcode steht folgendes:

    <!–?php echo $test; ?–>

    WordPress scheint automatisch die HTML Kommentare einzufügen.

    Wie kann ich den Code anzeigen lassen?

    Anderes Beispiel:

    Name: <?php echo $row[’name‘]; ?><br>

    wird zu

    <!–?php echo $row[’name‘]; ?–>

    Ich habe schon 10 verschiedene Syntax Highlighting Plugins installiert und keins funktioniert wirklich.

    Die < und > Zeichen (größer und kleiner) umzuwandeln klappt auch nicht bei etwas größeren Code Schnipseln.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Zur Ergänzung:

    Ich will auch folgenden Code anzeigen lassen ohne Ausführung des h1 Tags

    <h1>Your payment has been successful.</h1>

    oder auch

    <input type=“hidden“ name=“item_name“ value=“<?php echo $row[’name‘]; ?>“>
    <input type=“hidden“ name=“item_number“ value=“<?php echo $row[‚id‘]; ?>“>
    <input type=“hidden“ name=“amount“ value=“<?php echo $row[‚price‘];€ ?>“>

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Nachtrag: Ich will den Code nur ANZEIGEN lassen. Nicht ausführen!

    Verwende ich im Block-Editor einen Block „Code“ …

    Screenshot Backend mit eingefügtem Code-Block

    sieht das im Frontend so aus:

    Screenshot Frontend

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Warum führt er bei mir h1 aus und macht tatsächlich eine Überschrift draus?
    Warum macht er bei dir keine Kommentare aus dem öffnenden PHP Tag wie bei mir?

    Bei dir wird es ja wirklich 1:1 dargestellt. Ich frage mich immer noch woran das bei mir liegt. Teilweise zerschießt es das ganze Layout.

    Wie gehst du denn vor?

    Ich habe … 

    1. eine neue Seite erstellt (hätte auch ein Beitrag sein können)
    2. Überschrift „Code“ eingefügt
    3. In das Eingabefeld /Code getippt
    4. In das Eingabefenster den Code per Copy/Paste eingefügt.
    5. Auf Veröffentlichen geklickt und Seite angesehen.

    Was nicht funktioniert ist, den Code in einen Absatz einzufügen. Dort wird er automatisch gelöscht, weil verhindert werden soll, dass du über diesen Web PHP-Code ausführst und damit möglicherweise Sicherheitskonzepte umgehst.

    Ich habe schon 10 verschiedene Syntax Highlighting Plugins installiert und keins funktioniert wirklich.

    Welche? Ich habe gute Erfahrungen mit https://wordpress.org/plugins/enlighter/.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Ich gehe wie folgt for:

    Neuer Beitrag erstellt
    Code Block eingefügt
    Folgenden Inhalt eingefügt

    <h1>Your payment has been successful.</h1>
    <input type=“hidden“ name=“item_name“ value=“<?php echo $row[’name‘]; ?>“>
    <input type=“hidden“ name=“item_number“ value=“<?php echo $row[‚id‘]; ?>“>
    <input type=“hidden“ name=“amount“ value=“<?php echo $row[‚price‘];€ ?>“>

    https://mattionline.de/test/

    Jetzt steht dort

    Your payment has been successful. in h1, was er nicht ausführen sollte und der Input Text ist komplett verschwunden.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Ich habe soeben dein erwähntes Enlighter Plugin installiert und es wird 1:1 wie der normale Code Blog mit den bereits erwähnten Fehlern angezeigt.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Ich glaube ich habe den Fehler gefunden. Autoptimize und WP Optimize waren es scheinbar.

    Dennoch geht bei dem normalen WordPress Code Block die Anzeige nicht.

    Cache- und Optimisierungs-Plugins sollten bei der Fehlerbehebung immer deaktiviert werden. Bevor wir noch mehr Überraschungen erleben, schick doch bitte mal einen Bericht zu deiner Website:

    Werkzeuge > Website-Zustand (gibt es hier Fehlermeldungen? Welche?) > Bericht > per Button in die Zwischenablage kopieren, dann hier unverändert in eine Antwort einfügen.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Zustand ist gut

    2 empfohlene Verbesserungen

    Inaktive Plugins sollten entfernt werden

    Ein Standard-Theme zur Verfügung haben

    
    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/mattionline.de
    wordpress_size: 56,91 MB (59671199 bytes)
    uploads_path: /var/www/mattionline.de/wp-content/uploads
    uploads_size: 376,72 MB (395023245 bytes)
    themes_path: /var/www/mattionline.de/wp-content/themes
    themes_size: 4,57 MB (4797176 bytes)
    plugins_path: /var/www/mattionline.de/wp-content/plugins
    plugins_size: 67,19 MB (70451961 bytes)
    database_size: 81,36 MB (85313536 bytes)
    total_size: 586,75 MB (615257117 bytes)
    
    ### wp-active-theme ###
    
    name: Astra Child (astra-child)
    version: 1.0.0
    author: Brainstorm Force
    author_website: http://wpastra.com/about/
    parent_theme: Astra (astra)
    theme_features: astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, widgets, menus
    theme_path: /var/www/mattionline.de/wp-content/themes/astra-child
    
    ### wp-parent-theme ###
    
    name: Astra (astra)
    version: 2.4.2
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    theme_path: /var/www/mattionline.de/wp-content/themes/astra
    
    ### wp-plugins-active (16) ###
    
    Affiliate Toolkit Starter: version: 2.7.4.2, author: Christof Servit
    Astra Pro: version: 2.4.0, author: Brainstorm Force
    CodeMirror Blocks: version: 1.2.3, author: Vicky Agravat
    Code Syntax Block: version: 1.3.0, author: Marcus Kazmierczak
    Cookie Notice: version: 1.3.1, author: dFactory
    Custom Fonts: version: 1.2.1, author: Brainstorm Force
    Embed Video Thumbnail: version: 1.3.1, author: ikanaweb
    Enlighter - Customizable Syntax Highlighter: version: 4.1, author: Andi Dittrich
    LuckyWP Table of Contents: version: 2.1.1, author: LuckyWP
    Rank Math SEO: version: 1.0.42.3, author: Rank Math
    Related Posts for WordPress: version: 2.0.3, author: Never5
    Shariff Wrapper: version: 4.6.5, author: Jan-Peter Lambeck & 3UU
    WebP Converter for Media: version: 1.2.3, author: Mateusz Gbiorczyk
    WordPress Zero Spam: version: 3.1.1, author: Ben Marshall
    wpDiscuz: version: 5.3.5, author: gVectors Team (A. Chakhoyan, G. Zakaryan, H. Martirosyan)
    Yet Another Stars Rating: version: 2.3.1, author: Dario Curvino
    
    ### wp-plugins-inactive (7) ###
    
    Autoptimize: version: 2.6.2, author: Frank Goossens (futtta)
    Easy Google AdSense: version: 1.0.3, author: naa986
    GA Google Analytics: version: 20200325, author: Jeff Starr
    Imagify: version: 1.9.9, author: WP Media
    kk Star Ratings: version: 4.1.3, author: Kamal Khan
    Social Rocket: version: 1.2.7, author: Social Rocket
    WP-Optimize - Clean, Compress, Cache: version: 3.0.19, author: David Anderson, Ruhani Rabin, Team Updraft
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 8
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-8-amd64 x86_64
    httpd_software: nginx
    php_version: 7.3.14-1~deb10u1 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.22-MariaDB-0+deb10u1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/mattionline.de/wp-content
    WP_PLUGIN_DIR: /var/www/mattionline.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: latin1
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### luckywp-table-of-contents ###
    
    domVersion: 20031129
    libxmlVersion: 2.9.4
    intlVersion: 7.3.14-1~deb10u1
    icuVersion: 63.1
    settings: {"lwptoc_general":{"min":"2","depth":"6","hierarchical":true,"numeration":"decimalnested","numerationSuffix":"dot","title":"Inhaltsverzeichnis","toggle":false,"labelShow":"Anzeigen","labelHide":"Verbergen","hideItems":false,"smoothScroll":true,"smoothScrollOffset":"24"},"lwptoc_appearance":{"width":"auto","float":"none","titleFontSize":"default","titleFontWeight":"bold","itemsFontSize":"90%","colorScheme":"light","backgroundColor":null,"borderColor":null,"titleColor":null,"linkColor":"#1a6ecc","hoverLinkColor":null,"visitedLinkColor":null},"lwptoc_autoInsert":{"enable":true,"position":"top","postTypes":["post","page"]},"lwptoc_processingHeadings":{"postTypes":""},"lwptoc_misc":{"skipHeadingLevel":"","skipHeadingText":"Verwandte Beiträge|Share|Das könnte dich auch interessieren...|Beitrag teilen|Das könnte dich auch interessieren","hashFormat":"asheading","hashConvertToLowercase":true,"hashReplaceUnderlinesToDashes":true,"wrapNoindex":false,"useNofollow":false,"showMetaboxPostTypes":"","listMarkupTags":"div","containerClass":""}}
    
    

    Deine Zeitzone solltest du mal auf „Berlin“ umstellen.

    Zu den Funktionen in deinem Child-Theme kann ich nichts sagen. Prüf mal mit dem Plugin Health Check, ob sich was ändert, wenn du ein Standard-Theme („Twenty …“) verwendest.

    Du verwendest verschiedene Blöcke für Code-Darstellung, die sich gegenseitig stören könnten. Deaktiviere die mal.

    Autoptimize ist toll, kann aber bei einer unbedachten Konfiguration Probleme bereiten. Später wieder aktivieren, aber jetzt erst einmal den Fehler suchen.

    Sonst sehe ich da nichts besonderes.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Die Zeitzone in WordPress -> Allgemein habe ich soeben auf Berlin umgestellt.
    Danke für den Tipp. Ist mir gar nicht aufgefallen.

    Ich habe eben das Twenty Twenty installiert und in der Live Ansicht sind ebenfalls die Darstellungsfehler. Wenn ich das Theme kurzzeitig veröffentliche ebenfalls.
    Immerhin macht das Enlighter Plugin wie gewollt Zeilenumbrüche. Die WordPress und CodeMirror Variante geht immer noch nicht. (h1 wird ausgegeben und der Rest unterdrückt)

    Da sich nichts gegenseitig stört habe ich jetzt alle Code Syntax Plugins deaktiviert und auch den entsprechenden Code aus der Testseite entfernt. Jetzt ist nur noch der Standard WordPress Code Block enthalten. (h1 wird immer noch ausgeführt statt ausgegeben und der input Code bleibt verborgen)

    Autoptimize ist ja jetzt deaktiviert. Das sollte keine Probleme mehr bereiten.

    Was ich jetzt genau mit dem Health Check Plugin testen soll weiß ich jetzt nicht genau. Habe ja ein Standard Theme testweise aktiviert und es bleibt das selbe Problem.

    Thread-Ersteller Anonymous User 17650761

    (@anonymized-17650761)

    Seltsamerweise klappt es im Problembehandlungsmodus des Plugins.
    Kann es dann an dem Astra Theme liegen?

    Was ich jetzt genau mit dem Health Check Plugin testen soll weiß ich jetzt nicht genau. Habe ja ein Standard Theme testweise aktiviert und es bleibt das selbe Problem.

    Das Healthcheck-Plugin bietet dir in einem Problembehandlungsmodus nur eine Hilfe, deine Website mit komplett/einzeln deaktivierten Plugins und einem Standard-Theme zu testen, ohne dass deine Webseitenbesucher etwas davon mitbekommen oder etwas verstellt wird. Kannst du nutzen, musst du aber natürlich nicht.

    Ansonsten bin ich im Moment ein wenig überfragt: Bei mir funktioniert das Einfügen von Code wie per Screenshot gezeigt einwandfrei.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Das Thema „WordPress zeigt keinen Code an“ ist für neue Antworten geschlossen.