Support » Allgemeine Fragen » WordPress zeigt nur Startseit

  • Gelöst radback

    (@radback)


    Sehr geehrte WordPress-Nutzer,

    ich habe ein Problem mit meiner WordPress-Seite. Ich habe plötzlich nur noch eine Startseite, jegliche Links funktionieren nicht mehr und zeigen auf weiße Seiten. In unterschiedlichen Browsern bekomme ich 404 und 500 Fehlermeldung.

    Ich habe die letzten Monate nichts an der Seite gemacht, vorher lief alles. Ich habe nun WordPress aktualisiert, alle Plugins deaktiviert und auch ein Standard Theme eingebaut. Keine Verbesserung, selber Fehler. Ich habe auch den Debug angeschalten, dieser verwies auf kleinere Fehler im Theme, aber diese sind auch verschwunden, als ich auf ein Standard Theme wechselte.

    Was auch interessant ist, ich kann keine Beiträge und Seiten bearbeiten. Betätige ich den Button Aktualisieren, erhalte ich die Fehlermeldung:

    „Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.“

    Mir gehen so langsam die Ideen aus, wo der Fehler noch zu finden sein könnte. Könnt Ihr mir weiter helfen?

    Vielen Dank!

    • Dieses Thema wurde geändert vor 2 Wochen von radback.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ruf bitte im Backend mal das Menü Einstellungen > Permalinks auf. Du brauchst hier nichts weiter ändern, der Aufruf reicht bereits, damit WordPress die Permalink-Einstellungen neu einliest. Ändert sich dadurch etwas am geschilderten Problem?

    Falls nicht, benötigen wir mehr Informationen zur Website: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen.

    Das mit den Permalinks hatte ich auch schon probiert. Hier mal der Bericht:

    
    ### wp-core ###
    
    version: 5.4.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 11
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/vagabund/public_html
    wordpress_size: 210,37 MB (220591859 bytes)
    uploads_path: /home/vagabund/public_html/wp-content/uploads
    uploads_size: 1,73 GB (1861669969 bytes)
    themes_path: /home/vagabund/public_html/wp-content/themes
    themes_size: 6,70 MB (7029798 bytes)
    plugins_path: /home/vagabund/public_html/wp-content/plugins
    plugins_size: 86,17 MB (90358641 bytes)
    database_size: 15,79 MB (16553684 bytes)
    total_size: 2,05 GB (2196203951 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Fifteen (twentyfifteen)
    version: 2.6
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /home/vagabund/public_html/wp-content/themes/twentyfifteen
    
    ### wp-themes-inactive (4) ###
    
    CastleWP: version: 1.0, author: GameSiteTemplates.com
    GameWorld: version: 2.4.2, author: The Smart Magazine Themes
    Twenty Nineteen: version: 1.6, author: WordPress-Team
    Twenty Twenty: version: 1.4, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    
    ### wp-plugins-inactive (32) ###
    
    All In One SEO Pack: version: 3.6.2, author: All in One SEO Team
    AntiVirus: version: 1.3.10, author: pluginkollektiv
    BBSpoiler: version: 2.01, author: Flector
    Better Search Replace: version: 1.3.3, author: Delicious Brains
    Category Order and Taxonomy Terms Order: version: 1.5.7.2, author: Nsp-Code
    Classic Editor: version: 1.5, author: WordPress Contributors
    Contact Form 7: version: 5.2, author: Takayuki Miyoshi
    Count Per Day: version: 3.6.1, author: EasyPlugin (Jon Highham)
    Custom Meta Widget: version: 1.5.1, author: bitacre
    Disable Embeds: version: 1.2.0, author: LittleBizzy
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer
    Download Manager: version: 3.1.05, author: W3 Eden
    Easy Custom Auto Excerpt: version: 2.4.12, author: tonjoo
    Email Address Encoder: version: 1.0.21, author: Till Krüss
    Exit Notifier: version: 1.7.5, author: Curtis V. Schleich
    Ginger - EU Cookie Law: version: 4.2.1, author: Marco Buttarini, Matteo Barale
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    iThemes Security: version: 7.7.1, author: iThemes
    Lightweight Social Icons: version: 1.1, author: Thomas Usborne
    Photo Gallery: version: 1.5.59, author: Photo Gallery Team
    Remove Comment IPs: version: 1.0.2, author: Geeky Software
    Remove Google Fonts References: version: 2.6, author: Bruno Xu
    Remove IP: version: 0.1, author: guido
    Smart User Slug Hider: version: 4.0.0, author: Peter Raschendorfer
    Social Media Widget: version: 4.0.6, author: Noah Kagan
    TinyMCE Advanced: version: 5.4.0, author: Andrew Ozz
    Webcraftic Clearfy – WordPress optimization plugin: version: 1.6.9, author: Webcraftic <wordpress.webraftic@gmail.com>
    WPDM - Button Templates: version: 1.1.0, author: Shaon
    WPDM - Image Button: version: 2.2.0, author: Shaon
    WP DSGVO Tools (GDPR): version: 3.1.9, author: legalweb
    WP Time Counter: version: 1.1, author: WPEka Club
    WP Updates Notifier: version: 1.6.0, author: Scott Cariss
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.36.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.2.32 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.23-MariaDB-log-cll-lve
    client_version: 10.3.23-MariaDB
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/vagabund/public_html/wp-content
    WP_PLUGIN_DIR: /home/vagabund/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Das ist eine üppige Liste mit Plugins, aber vermutlich nicht Ursache des Problems. Schau bitte mal per FTP-Programm oder über das Dateiverwaltungsmenü deines Webhoster in der Datei .htaccess, ob dort der von WordPress eingefügte Code-Block vorhanden ist.

    Wer ist dein Webhoster? Du könntest mal beim Support dort nachfragen, ob mod_rewrite deaktiviert wurde oder sonst Änderungen am Server vorgenommen wurden. (Der Server muss mit AllowOverride All so konfiguriert sein, dass die .htaccess auch greift.)

    .htaccess habe ich mal zum Test vom Server gelöscht. Problem bleibt. Ich schreibe dann mal den Hoster an. Hoster wäre ServerProfis.

    Moderator Bego Mario Garde

    (@pixolin)

    Löschen alleine genügt ja nicht. Du musst dann über Einstellungen > Permalinks die gewünschte Permalinkstruktur neu setze und dabei darauf achten, ob WordPress dich auffordert, den Eintrag händisch vorzunehmen. Ohne .htaccess funktionieren Permalinks nicht auf einem Apache-Server.

    Na Prima, dass scheint das Problem gewesen zu sein.

    .htaccess gelöscht. Permalink noch mal gespeichert und Links gehen wieder.

    Vielen Dank, Problem gelöst!

    • Diese Antwort wurde geändert vor 1 Woche, 6 Tage von radback.
    • Diese Antwort wurde geändert vor 1 Woche, 6 Tage von radback.
Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)