Support » Diskussion » WP 4.3.1 Update – Einstellungen – Schreiben

  • Matthieu Kluge

    (@mpluscinternetsolution)


    Sehr geehrte WordPress Gemeinde,
    Ich bräuchte eure Hilfe.

    Ich möchte Banner mit PHP SID einfügen, aber WordPress codet meine php scripte immer um. Ich hatte mich informiert und man sagte mir, ich muss bei Einstellungen – Schreiben – Formatierung > Wandle Emotions in Grafiken um und > WordPress soll falsch verschachteltes XHTML automatisch korrigieren, beides Auschalten. Aber ich habe seit dem Update diese Einstellungsmöglichkeit nicht mehr.

    Bitte um Hilfe.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Wo genau willst du den PHP-Code denn einbinden? In Posts/Pages, in Widgets oder in ein template deines Themes?

    Ich kann mir nicht vorstellen, dass die vorgeschlagenen Maßnahmen tatsächlich greifen. Für das Einfügen von PHP in den TinyMCE zum Beispiel könntest du auf Plug-ins zurückgreifen, zum Beispiel so etwas:
    http://www.user-xy.de/5-wordpress-plugins-zum-ausfuhren-von-php-code/
    (ist aber von 2013 also nicht ganz so aktuell)

    Was komisch ist, mir ist aufgefallen, dass die oben angesprochen Funktionen (Smiley / XHTML) bei mir in manchen WordPress-Installationen v.4.3.1 fehlen, in anderen aber noch vorhanden sind?

    Matthieu Kluge

    (@mpluscinternetsolution)

    Hallo Angelika Reisiger.

    Danke für dein schnelles Feeback.

    Ich möchte den PHP-Code auf Pages einfügen. Ich hatte bereits diverse Plugins probiert wie z.B „php-execution“ „exec-php“. Das Problem ist aber, das aufgrund der Einstellungen bei Schreiben, die ich anfangs getätigt hatte, php generell automatisch korrigiert wird, da ich damals bei den Einstellungen eingestellt hatte, das Worpdress falsch verschachteltes XHTML automatisch korrigieren soll. Viele WordPress User sagen mir, das diese Einstellung ausgeschaltet werden muss, da sonst PHP scripte umgewandelt werden und das sehe ich auch im Texteditor.

    Genau, diese Funktionen stehen mir nämlich seit dem letzten Update nicht mehr zur Verfügung. :/

    versuche das hier
    https://de.wordpress.org/plugins/php-code-for-posts/

    ich bin zwar absolut keine Freundin solcher Lösungen, weil sie immer hoch unsicher sind…

    Matthieu Kluge

    (@mpluscinternetsolution)

    Habe das Problem jetzt lösen können. Ich benutze das Plugin „Disable Auto Formatting“ um die Formationseinstellungen zu umgehen. Damit das Plugin funktioniert muss man aber unter Einstellungen – Disable Auto Formatting alles auf Disable stellen. Um PHP nun ausgeben zu können benutze ich das Plugin „Allow PHP in Posts and Pages“. Hier muss bei den Einstellungen darauf geachtet werden, das bei 1 NO und bei den anderen 3 YES eingestellt ist.

    Desweiteren muss bei Profil – Dein Profil der WYSIG Editor ausgeschaltet werden.

    nilolaus

    (@nilolaus)

    Na ja – fü den kleinen Umgang hat’s ja gereicht, die Autokorrektur auszuschalten und damit zu verhindern, das wordPress aus Gold Sch…e macht.

    Ist das jetzt einfach weg? Und wen ja – wie ist das weg? Was ist also die default-Einstellung, die geblieben ist? Autokorrektur aus oder an?

    Weiß jemand zufällig eine Setup-Zeile, mithilfe derer ich festlegen kann, dass WP einfach die Finger von meinem Code lässt?

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „WP 4.3.1 Update – Einstellungen – Schreiben“ ist für neue Antworten geschlossen.