Support » Allgemeine Fragen » WP 6.1.1 läuft nicht mit PHP 8.0 – minimalinstallation

  • Gelöst geoback

    (@geoback)


    aktuell bin ich bei meinem Hoster auf PHP Version 7.4, ich will aber auf mindestens 8.0.

    Habe alles mögliche versucht, mein WP bringe ich mit PHP 8.0 nicht zum Laufen, obwohl mitterweile total abgespeckt:

    mein WP ist Version 6.1.1, lediglich ein Theme ist installiert Twenty Seventeen in Version 3.1, es gibt nur noch ein Plugin: Maintenance

    Wenn ich beim Hoster auf PHP 8.0 umstelle, kann ich weder ins Backend noch wird die Website ordentlich dem Besucher angezeigt. Gibt es bitte einen Lösungsvorschlag?

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Moderator Bego Mario Garde

    (@pixolin)

    Da bleiben ja nicht mehr viele Optionen. Entweder das Maintenance-Plugin oder (wahrscheinlicher) ein Fehler in der wp-config.php. Poste doch mal den Inhalt der Datei, Zugangsdaten vor dem Absenden aus der Antwort löschen.

    Thread-Starter geoback

    (@geoback)

    @pixolin
    danke, hier https://pastebin.com/AcY7Dsdn liegt der Paste von wp-config.php

    @geoback
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.

    1. Wenn tatsächlich ganz am Ende ?> steht, solltest du das mal löschen.
    2. Au0erdem sollten normalerweise die Zeilen
      define( 'WP_ALLOW_MULTISITE', true );
      define ('FS_METHOD', 'direct');
      define( "WP_AUTO_UPDATE_CORE", minor );

      vor der Zeile
      /* That's all, stop editing! Happy blogging. */
      stehen.
      Es könnte aber auch sein, dass diese Zeilen bei der Einrichtung der Website automatisch eingetragen worden sind. Darauf hat mich @pixolin (danke übrigens) hier aufmerksam gemacht.

    Führe dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) die Änderung 1. in der wp-config.php zunächst lokal auf einer Kopie durch. Die geänderte Kopie kannst du dann wieder hochladen und testen, ob das Problem behoben ist.

    Wenn das nicht geklappt hat, führe bitte die Änderung 2. durch.

    Viele Grüße
    Hans-Gerd

    Thread-Starter geoback

    (@geoback)

    danke, hier zum Vergleich, der untere Teil vom original : https://pastebin.com/a6NVdmvS
    und die von mir angepasste wp-config.php(untere Teil): https://pastebin.com/zkaseFi0

    Die angepasst funktioniert leider nicht mit 1. Änderung und auch nicht mit Änderung 1. PLUS 2. siehe https://pastebin.com/zkaseFi0

    Irgend einen Fehler mache ich noch …

    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von geoback.
    Thread-Starter geoback

    (@geoback)

    die wp-config.php muss vom System erstellt worden sein, ich hab da in der Vergangenheit nie was geändert

    Hallo,
    noch ein Versuch: Hast du evtl. eine wp-config-sample.php?

    Wenn ja, dann

    • lade die wp-config.php auf deinen lokalen Rechner,
    • benenne diese aktuelle wp-config.php in wp-config_sik.php um,
    • trage in die wp-config-sample.php die Zugangsdaten ein,
    • erstelle die SALT-Keys neu,
    • trage die geänderten SALT-Keys in die wp-config-sample.php
    • und benenne diese Datei in wp-config.php um.

    Da ich davon ausgehe, dass du die gerade geänderten Änderungen lokal durchgeführt hast, musst du die wp-config.php noch hochladen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter geoback

    (@geoback)

    @hage Vielen Dank, die wp-config-sample.php war auf dem Server vorhanden, habe entsprechend angepasst, nun läuft alles auf php 8.0 mit aktivierten php Boost. TOP Support

    @geoback
    super – freut uns. Danke für die Rückmeldung.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „WP 6.1.1 läuft nicht mit PHP 8.0 – minimalinstallation“ ist für neue Antworten geschlossen.