Support » Allgemeine Fragen » wp-admin not accessible – The requested URL was not found on this server

  • Gelöst edmonddantes

    (@edmonddantes)


    Auf der AWS-Instanz habe ich Ubuntu 22 und dann WordPress installiert. Ich verwende die Subdomain einer registrierten Domain. (Domäne wurde für eine andere Website registriert, die auf einer anderen Instanz ausgeführt wird). Ich versuche, eine neue Instanz zum Testen zu erstellen, und ich verwende die Subdomain der registrierten Domain.

    Ich kann auf das Frontend meines WordPress zugreifen, aber nicht auf das Backend.

    Wenn ich versuche, mich bei meinem wp-admin-Backend anzumelden, indem ich browser

    http://aws_route_53_subdomain_name.domain_name.com/wp-admin

    Wenn ich versuche, mich bei meinem wp-admin-Backend anzumelden, indem ich browser

    http://aws_route_53_subdomain_name.domain_name.com/wp-admin

    Ich bekomme diesen Fehler

    "Not Found" The requested URL was not found on this server. Apache/2.4.52 (Ubuntu) Server at <IP address> Port 80".

    Ich habe auch versucht einzusteigen

    "aws_route_53_subdomain_name.domain_name.com/wordpress/wp-admin"

    aber das Ergebnis ist das gleiche. Wenn ich die Eingabetaste drücke, sehe ich, dass sich die URL in etwas wie ändert

    "http:///wordpress/wp-login.php?redirect_to=http%3A%2F%2Ftest.%2Fwp-admin%2F&reauth=1".

    Können mir bitte jemand dabei helfen?

    Ich vermute, dass das Problem darin liegen könnte, dass ich die Subdomain einer ersten Prod-Instanz verwende und sie auf eine andere (diese neue) Testinstanz verweise. (Ich kann mit „mydomainname.com“ auf das Frontend zugreifen, aber nicht auf das Backend) Z. B. wenn ich lief

    sudo certbot --apache

    Ich habe diesen Fehler

    Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
    Domain: www.test.mydomainname.com
    Type: dns
    Detail: DNS problem: NXDOMAIN looking up A for www.test.mydomainname.com - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for www.test.mydomainname.com - check that a DNS record exists for this domain

    Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

    Some challenges have failed. Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Ohne Angabe der richtigen Domain kann ich mir die Website nicht anschauen. Da wird es schwierig zu helfen.

    http://wordpress/wp-login.php?redirect_to=http%3A%2F%2Ftest.%2Fwp-admin%2F&reauth=1".

    ist ein Link, der aufgerufen wird, wenn du als noch nicht angemeldeter Benutzer versuchst, auf wp-admin zuzugreifen und WordPress dich auf die Anmeldeseite wp-login.php zur „Reauthentification“ weiterleitet. Dabei sollte aber die Domain sowohl im GET-Parameter wie auch in der URL identisch sein. Sind sie, wie von dir angedeutet, unterschiedlich, hast du einen Fehler bei der Installation gemacht. In dem Fall solltest du in der Datenbank prüfen, ob in der Datenbank-Tabelle wp_options (Vorsilbe wp_ kann individuell verschieden sein) in den Feldern siteurl und home die gleiche Domain verwendet wird.

    Die Website kannst du grundsätzlich auch ohne SSL-Zertifikat betreiben, was aber natürlich deutlich unsicherer ist, weil bei der Anmeldung im Backend die Anmeldedaten im Klartext durchs Netzwerke laufen.

    Serverkonfiguration ist hier off topic. Bei Fragen zur Einrichtung von AWS/SSL-Zertifikat solltest du dich an ein anderes Forum wenden.

    Thread-Starter edmonddantes

    (@edmonddantes)

    Ich habe diesen Tutorial gefolgt und alle Schritte bis zum Abrufen von wp-admin erfolgreich gemacht: Create and Host a WordPress Website on AWS EC2 with your own domain name! – YouTube

    Da ich kein WP Experte bin, kannst du (@pixolin ) mir bitte sagen wo und wie ich die Checks machen soll? Danke!

    Hast du meine Antwort gelesen? 🙂

    Thread-Starter edmonddantes

    (@edmonddantes)

    Ich verscuche es noch einmal. Kannst du mir bitte sagen wo und wie folgenden von dir empfohlenen Check machen kann?

    In dem Fall solltest du in der Datenbank prüfen, ob in der Datenbank-Tabelle wp_options (Vorsilbe wp_ kann individuell verschieden sein) in den Feldern siteurl und home die gleiche Domain verwendet wird.

    Ich weiß nicht, was auf deinem Server installiert ist, aber irgendwie wirst du an die MySQL-Datenbank herankommen, die du bei der Installation von WordPress verwendet hast? Entweder per phpMyAdmin, Terminal-Befehl mysql -u root -p oder du lädst Adminer auf deinen Server und verwendest die Zugangsdaten in der wp-config.php, um auf die Datenbank-Tabellen zugreifen zu können.

    Die meisten WordPress-Anwender haben ein normales Shared Webhosting, bei dem du über das Kundenmenü auf die Datenbank zugreifen kannst. Das ist bei einer selbst administrierten AWS-Instanz anders. Serverkonfiguration und -administration ist hier off topic.

    Nachtrag: Ich hab keine Zeit, mir das ganze Video anzuschauen, aber bei https://youtu.be/8Uofkq718n8?t=485 wird gezeigt, wie die Datenbank per Terminal eingerichtet wird. Mit mysql -u root -p und deinem Passwort für den Datenbank-Admin kannst du auf die Datenbank zugreifen und dann mit MySQL-Befehlen eine Änderung vornehmen. Einfacher ist wohl die Installation von Adminer wie bereits beschrieben.

    Thread-Starter edmonddantes

    (@edmonddantes)

    danke für die Antwort. Mit mysql -u root -p ´kann ich auf die DB zugreifen. Kannst du mir bitte sagen welche Abfrage ich ausführen soll, damit ich die Infos bekomme, die du erwähnt hast?

    Folgendes habe ich probiert:
    SELECT * from wp_options;

    Hier bekam ich als Ergebnis:
    No database selected

    Thread-Starter edmonddantes

    (@edmonddantes)

    das ist was ich sehe, wenn ich die Datei „wp-config.php“ öffne: Screenshot by Lightshot (prnt.sc)

    Thread-Starter edmonddantes

    (@edmonddantes)

    Im Tutorial wird empfohlen das Wort „wordpress“ hier hinzuzufügen: Screenshot by Lightshot (prnt.sc)

    Zusätzlich habe ich gemerkt, wenn ich statt subdomain die IP adresse im Browser verwende….

    http://<IP_adresse>/wp-login.php

    … dann bekomme ich folgendes Ergebnis: Screenshot by Lightshot (prnt.sc)

    Und wenn ich auf „Login“ klicke, dann ändert sich der Link im Browser von http://<IP_adresse>/wp-login.php auf http://<IP_adresse>/wordpress/wp-login.php
    … und ich bekome wieder dieses Ergebnis:

    Not Found The requested URL was not found on this server. Apache/2.4.52 (Ubuntu) Server at <IP address> Port 80

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von edmonddantes.
    Thread-Starter edmonddantes

    (@edmonddantes)

    Als ich das Wort „wordpress“ aus der Datei 000-default.conf gelöscht habe, konnte ich auf WP-admin logon Seite zugreifen mit:

    http://<IP_Adresse>/wordpress/wp-admin/

    Warum passiert das?

    (In der gleichen Datei habe ich – wie im Tutorial – ServerName und ServerAlias definiert. Das eine ohne „www“ und das andere mit „www)

    Jetzt habe ich – wie im Tutorial – im General –> Settings–> WordPress address und Site Address statt „<IP Adresse>/wordpress“ folgendes eingegeben „subdomain“.

    Jetzt habe ich „wordpress“ wieder eingefügt – und es schheit zu funktionieren (Zugriff zu WP-Admin Logon)

    Moderator Michi91

    (@michi91)

    Du solltest dir ein Hostingpaket mieten, offenbar fehlt es am nötigen Basiswissen und folglich in diesem Fall Fachwissen zur Administration von Webservern. Die Kiste ist vermutlich binnen weniger Wochen gehakt..

    Zur Lösung: du kannst in der wp-config.php Auch die URL festlegen, dann musst du nichts in der SQL anpassen..

    define(‚WP_HOME‘,’http://aws_route_53_subdomain_name.domain_name.com&#8216;);

    define(‚WP_SITEURL‘,’http://aws_route_53_subdomain_name.domain_name.com&#8216;);

    Edit: oh da hast du schneller einen Lösungsweg gefunden als ich antworten konnte. Schön das es klappt..

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Michi91.
    Thread-Starter edmonddantes

    (@edmonddantes)

    Ich konnte auch SSL Issue lösen – „A“ Record für „www.subdomain“ hat gefehlt.

    Alles ist gelöst. Danke für deine Hilfe!

    Freut mich, dass alles gelöst wurde. Ich markiere den Thread noch als „gelöst“.

    Die Bedenken, die @michi91 geäußert hat, teile ich allerdings. Gibt es einen triftigen Grund für die Nutzung des AWS-Servers?

    Übrigens empfehle ich, nach Möglichkeit nicht die URLs in der wp-config.php vorzugeben. Das ist sinnvoll, wenn laufend zwischen Staging und Production gewechselt wird, aber ansonsten kommt nach drei Monaten die Anschlußfrage „wieso kann ich die Felder eigentlich nicht im Backend bearbeiten“. Eine Korrektur der Einträge in der Datenbank sollte kein großes Ding sein und vermeidet Hilfskonstruktionen.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „wp-admin not accessible – The requested URL was not found on this server“ ist für neue Antworten geschlossen.