Support » Allgemeine Fragen » wp-admin URL geändert. komme nicht mehr auf admin panel

  • Gelöst drumbell243

    (@drumbell243)


    Hallo,

    ich habe versehentlich den link zu meiner Seite irgendwie verändert.

    Auf dem admin panel gab es eine Einstellung wo man links verändern konnte. Wenn ich auf der Seite bin, ist die ganz normale Domain „Domain.de“ aber wenn ich irgendwo drauf drücke dann ist sie „Domain.de/category/termine/…“. Somit komme ich auch nicht mehr auf die „Domain.de/wp-admin“. Kann mir bitte jemand helfen. ich habe schon im Forum gesucht aber ich check´s einfach nicht.

    • Dieses Thema wurde geändert vor 7 Monaten von drumbell243.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo,
    vermutlich hast du auf der Seite Einstellungen > Allgemein die falschen Eintragungen vorgenommen. Wenn das der Fall ist, dann gibt es u. a. zwei Möglichkeiten, wenn du …

    • entweder im Kundenmenü deines Webhosters die Datenbankverwaltung öffnest (üblicherweise über phpMyAdmin) und dort in der für WordPress genutzten Datenbank in der Tabelle wp_options die korrekten Einträge für die Felder siteurl und home einträgst (Das Präfix wp_ kann auch anders lauten),
    • oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einfügst.
      Danach solltest du dich über ...\wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Wurde der Eintrag korrigiert und die Einstellungen per Button aktualisiert, muss man sich erneut anmelden. Die Website sollte dann aber wieder funktionieren. Vorsichtshalber solltest du danach in der wp-config.php die eingefügte Zeile wieder entfernen.

    Du solltest vor entsprechenden Änderungen in der von mir genannten Art auf jeden Fall eine Sicherung erstellen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter drumbell243

    (@drumbell243)

    Hallo, danke für die schnelle Antwort.

    Ich habe die Datei bearbeitet, dass Problem ist nur, dass ich immer noch auf die selbe Seite gelange, also auf eine sehr simple WordPress Anmeldeseite und wenn ich versuche mich anzumelden, dann werde ich wieder auf „Domain.de/category/termine/wp-login.php“ weitergeleitet und es heißt es seien zu viele Weiterleitungen durchgeführt worden.

    VG

    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.

    Hallo,
    poste doch bitte mal den Inhalt der Datei wp-config.php. Zugangsdaten und SALT-Keys solltest du vor dem Absenden aus der Antwort löschen. Auf die Datei kannst du per FTP zugreifen.

    Alternativ kannst du auch die Änderung in der Datenbank durchführen – siehe oben. Evtl. ist das einfacher für dich.

    Viele Grüße
    Hans-Gerd

    Thread-Starter drumbell243

    (@drumbell243)

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '');
    
    /** MySQL database username */
    define('DB_USER', '');
    
    /** MySQL database password */
    define('DB_PASSWORD', '');
    
    /** MySQL hostname */
    define('DB_HOST', '');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '');
    define('SECURE_AUTH_KEY',  '');
    define('LOGGED_IN_KEY',    '');
    define('NONCE_KEY',        '');
    define('AUTH_SALT',        '');
    define('SECURE_AUTH_SALT', '');
    define('LOGGED_IN_SALT',   ');
    define('NONCE_SALT',       ');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define( 'RELOCATE', true );
    
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    

    Falls irgendetwas fehlt oder irgendetwas weiterhin drin steht, obwohl es nicht sollten bitte Bescheid geben. Danke schon mal im Voraus.

    VG

    Hallo,
    lösche bitte die Zeile define( 'RELOCATE', true ); wieder aus der wp-config.php.
    Vermutlich wird das Problem gelöst, wenn du die richtige Eintragung der URL in der Datenbank vornimmst (also ohne category/termine/).
    Ich habe das gerade hier noch mal lokal sicherheitshalber getestet und damit funktionierte das auf jeden Fall.

    Wie das genau funktioniert, kannst du z. B. in dem folgenden Beitrag von mir nachlesen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter drumbell243

    (@drumbell243)

    Hallo,

    das Problem ist bloß, dass ich das Erste aus dem geteilten Beitrag ja schon versucht hatte und das andere mit siteurl und home das funktionierte auch nicht. Ich habe alle siteurl und home´s mit „https://Domain.de&#8220; ausgetauscht.

    Bitte Hilfe …

    Abgesehen davon komme ich wie gewohnt auf die Anmeldeseite, jedoch werde ich auch „Domain.de/category/termine/wp-login.php“ weitergeleitet, wenn ich versuche, mich anzumelden.

    Leider kann ich kein Foto einfügen.

    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.
    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.
    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.
    Moderator Bego Mario Garde

    (@pixolin)

    Ich habe alle siteurl und home´s mit „https://Domain.de&#8220; ausgetauscht.

    Was meinst du damit?

    In der Datenbank-Tabelle wp_options gibt es die Felder siteurl und home nur ein einziges Mal. Was soll „alle“ bedeuten?

    Abgesehen davon komme ich wie gewohnt auf die Anmeldeseite, jedoch werde ich auch „Domain.de/category/termine/wp-login.php“ weitergeleitet.

    Das wissen wir doch schon. 🙂

    Leider kann ich kein Foto einfügen.

    Nein, du kannst aber z.B. (auch ohne Registrierung) bei imgur.com einen Screenshot hochladen und dann hier per [+]-Icon einen „Imgur-Block“ einfügen.

    Thread-Starter drumbell243

    (@drumbell243)

    Also hier nur einmal ein Beispiel. In der Datei gibt es noch ein paar mal siteurl.

    
    
    	// If home is not set use siteurl.
    	if ( 'home' == $option && '' == $value )
    		return get_option( 'siteurl' );
    
    	if ( in_array( $option, array('siteurl', 'home', 'category_base', 'tag_base') ) )
    		$value = untrailingslashit( $value );
    
    	/**
    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.
    • Diese Antwort wurde geändert vor 7 Monaten von drumbell243.
    Moderator Bego Mario Garde

    (@pixolin)

    Eine Datei hat nichts mit einer Datenbank zu tun.

    Du solltest keine Dateien ändern, sondern im Kundenmenü des Webhosters die Datenbank-Verwaltung aufrufen (meistens wird dafür phpMyAdmin verwendet) und dort – ähnlich wie in einem Tabellenkalkulationsprogramm – die Tabelle wp_options öffnen. Da gibt es dann zwei (und wirklich nur zwei) Felder, die mit siteurl und home benannt sind. Für home musst du unter Umständen in der Tabelle blättern.

    Bitte mach deine Änderungen in Dateien rückgängig. Du machst die Skripte sonst unbrauchbar.

    Thread-Starter drumbell243

    (@drumbell243)

    Hallo,

    ich danke Euch von ganzem Herzen, es hat nun funktioniert.
    VG

    Moderator Bego Mario Garde

    (@pixolin)

    Super. Dann spricht sicher nichts dagegen, dass ich den Thread als „gelöst“ markiere.

    Weiterhin viel Erfolg mit WordPress.

    Hallo,
    super – freut uns. Danke für die Rückmeldung.

    Allerdings solltest du noch dafür sorgen, dass die Website ein Sicherheitszertifikat erhält. Websites ohne SSL-Verschlüsselung sind nicht mehr zeitgemäß: Schlechtere Platzierung in Suchmaschinen wie Google und Sicherheitswarnungen in Browsern wie Firefox oder Chrome ist die Folge. Wie das funktioniert, kannst du z. B. hier nachlesen.

    Aber das wäre dann ein neues Thema, wenn du dazu Fragen hast. 😉

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Screenshot
    Zum Vergrößern bitte anklicken …

    … ist ja https. Nur leider mit Mixed Content (gemischte sichere und unsichere Inhalte). Da wäre es sinnvoll, die URL mit http://aben… mit der neuen URL mit https://aben… zu ersetzen, z.B. mit dem Plugin Better Search Replace.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „wp-admin URL geändert. komme nicht mehr auf admin panel“ ist für neue Antworten geschlossen.