Support » Allgemeine Fragen » WP ignoriert Änderungen in den Theme-Dateien

  • Guten Morgen

    Ich wollte die Beschreibung der Kategorien in meine Seite einbauen und habe deshalb in der index.php meines Child-Themes die entsprechende Codezeile rein geschrieben. Hat einwandfrei funktioniert, jedoch noch ohne Formatierung. Wollte ich ergänzen, jedoch ohne jegliche Wirkung. Auch im Quellcode nix.

    Weil es schlecht ausschaut und ich gerade keine Zeit hab da lange rum zu eiern, hab ich die Zeile wieder entfernt. Nur, die Beschreibung wird weiterhin angezeigt.

    Nun habe ich auf dem Sever im Child und im Parent die index.php entfernt. Eigentlich erwarte ich spätestens jetzt einen hässlichen Fehler. Nix, alles gut, die Seite läuft, zumindest auf der Hauptdomain (Multiinstallation). Eine Subdomain liefert nur noch eine weisse Seite. Also die Dateien wieder hochgeladen, läuft wieder überall, mit Anzeige der Beschreibung, obwohl diese aus den hochgeladenen Dateien wieder entfernt wurde.

    Mir ist dieses Verhalten in der Vergangenheit schon mal aufgefallen. Hat WP auf dem Sever einen Cache der mir jetzt meine Änderungen ignoriert. Oder wie kann ich mir dieses Verhalten sonst erklären?

    Ich hab auch kontrolliert, dass ich die richtige Datei ins richtige Verzeichnis hochlade. Habe auch versucht, zwischen Child und Parent zu wechseln.

    Gruß René

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Deine Frage lässt sich ohne weitere Informationen zu deiner WordPress-Installation nicht beantworten.

    Meine persönliche Erfahrung ist: Wenn ich eine Änderung an einem Theme vornehme und sich das nicht auswirkt, habe ich

    • am falschen Theme gearbeitet,
    • an der falschen WordPress-Installation gearbeitet oder
    • ein Cache zeigt weiterhin das alte Ergebnis an.

    Um den Browser-Cache als Ursache auszuschließen, reicht ein rascher Wechsel in den privaten Modus des Browsers. Ich behelfe mir auch gerne mit HTML- oder PHP-Kommentaren – immer mit Sonderzeichen bestückt, damit sie leichter im Quellcode zu finden sind.

    WP 4.9.5, Theme: Lovecraft.

    Es ist wie verhext, aber was Du schreibst ist schlüssig. Browser Cache habe ich gelöscht, bei unterschiedlichen Browsern, falsches Theme oder WP Installation, alles soweit richtig, die erste Änderung hat es ja geschluckt. Zeichen die ich so rein schreibe, dass der Browser sie anzeigen müsste, nein, nicht sichtbar.

    Es schaut sehr danach aus, als werden die Änderungen im Server Verzeichnis nicht vorgenommen. Ich drück mir heute Abend mal das Wattestäbchen ins Ohr und teste nochmals alles.

    Besten Dank.

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)