Support » Allgemeine Fragen » wp-login funktioniert nicht

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hast du vor deinen Änderungen eine Sicherung der Datenbank gemacht?

    Danke für die schnelle Antwort!

    Sicherung habe ich grundsätzlich, und die wesentlichen Elemente der Sicherung habe ich eingespielt: SQL-Datenbank, wp-content-Ordner, .htaccess, wp-config.
    Warum ich das Ganze gemacht habe: Ich musste von php 5.3 auf php 7.1 umstellen, und damit hat die Website nicht mehr funktioniert. An den genauen Fehler kann ich mich nicht mehr erinnern, ich glaube, dass auch schon da kein Login mehr möglich war. Damit hilft wohl der Rest der Sicherung auch nicht viel.

    Xari

    OK … Ich würde folgendermaßen vorgehen:

    Auf dem Webserver die Verzeichnisse wp-admin und wp-includes sowie im Web-Stammverzeichnis die WordPress-Dateien löschen. Nicht gelöscht werden die wp-config.php, .htaccess sowie das verzeichnis wp-content, das ja deine eigenen Themes, Plugins, Sprach- und Mediendateien enthält.

    Dann lädst du einen neuen Dateiensatz herunter, entpackst ihn, löschst darin das Verzeichnis wp-content und lädst die Dateien auf den Webserver hoch. Achte darauf, wirklich erst die alten Dateien zu löschen und erst anschließend neu hochzuladen – einige FTP-Clients sind beim Ersetzen sehr sportlich und überspringen einfach vorhandene Dateien.

    Das Verzeichnis wp-content/plugins benennst du in wp-content/keine.plugins um.

    In der WordPress-Konfigurationsdatei wp-config.php fügst du vor der Zeile /* That's all, stop editing! Happy blogging. */ folgendes ein:
    define( 'RELOCATE', true );

    In der Datenbank löschst du alle vorhandenen Tabellen.

    Dann importierst du die Tabellen erneut – nimmst aber keine Änderungen per SQL-Statement vor!

    Nun solltest du dich über https://example.com/wp-login.php (natürlich mit deiner Domain) im Backend anmelden können, selbst wenn das Login-Formular noch etwas merkwürdig aussieht. Falls nicht, wären die Fehlermeldungen interessant.

    Unter Einstellungen > Allgemein änderst du die beiden URLs entsprechend den neuen Werten. Danach entfernst du in der wp-config.php wieder die zugefügte Zeile und meldest dich erneut im Backend an. (Beim nächsten Umzug wäre es einfacher, vor dem Umzug in Einstellungen > Allgemein die URLs zu ändern. Das erspart die Arbeit mit der Konstante RELOCATE.)

    Um nun auch noch die URLs für alle Mediendateien zu ändern, installierst du Better Search Replace und ersetzt die alte URL mit der neuen.

    Durch Umbenennen des Plugin-Verzeichnisses wurden zunächst alle Plugins deaktiviert; das erleichtert die Fehlersuche. Wenn du dich im Backend ganz normal anmelden kannst und die URL umgestellt ist, kannst du das Verzeichnis wieder in wp-content/plugins umbenennen und im Menü Plugins jedes Plugin einzeln wieder aktivieren. Wenn dabei ein Fehler auftritt, weißt du, woran es liegt und du brauchst nur das Verzeichnis dieses Plugins in wp-content/plugins umzubenennen. Danach müsste natürlich geschaut werden, wor es bei dem Plugin hapert.

    Wenn du mit diesen Schritten fertig bist, gehst du bitte noch in Einstellungen > Permalinks und speicherst erneut die gewünschte Permalink-Struktur. Die Rewrite-Basis müsste sich dadurch ändern.

    Alles zusammen so in etwa 20 Minuten Aufwand … los geht’s! 😉

    Hallo Bego Mario,

    alle Plugins sind deaktiviert, alle WP-Dateien neu, config.php wurde mit dem entsprechenden relocate-Befehl bestückt, der dann wieder entfernt wurde … bei Login kommen leider zwei Fehlermeldungen:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‚wp_heartbeat_settings‘ not found or invalid function name in /opt/users/www/XXXX/MT/wp-includes/class-wp-hook.php on line 286

    Und die schon bekannte in dem Fester, in dem man sich anmeldet:

    Fatal error: Uncaught Error: Call to undefined function checked() in /opt/users/www/XXXX/MT/wp-login.php:1003 Stack trace: #0 {main} thrown in /opt/users/www/monikatrweb81/html/MT/wp-login.php on line 1003

    Bei Eingabe von Benutzername und Passwort passiert nichts.

    Gibt es noch eine Rettung?

    Xari

    alle Plugins sind deaktiviert, alle WP-Dateien neu, config.php wurde mit dem entsprechenden relocate-Befehl bestückt,…

    Meiner Anleitung bist du jetzt aber nicht gefolgt? 🙂

    Was steht denn aktuell in deiner .htaccess?

    Na, läuft ja wieder. 👍🏻

    Hallo Bego Mario,

    danke für Deine Geduld und den liebevollen Hinweis! Nach meiner unmaßgeblichen Meinung hatte ich tatsächlich nicht alle originalen WordPressdateien und die beiden Ordner hochgeladen, da ich dies ja kurz vor meiner Bitte um Support gemacht hatte! Jetzt sind sie – genau nach Deiner Anleitung – hochgeladen worden, und alles andere habe ich auch gemacht. Juhu – jetzt geht es! Da war das Ei wieder klüger als die Henne. Herzlichen Dank für deine Zeit!

    Wenn es möglich ist, bitte ich Dich, diesen Thread zu löschen, weil ich doch einige Strukturen meiner Site preisgegeben habe. Ich denke, dass mein Problem im Prinzip mehr oder weniger ein Allerweltsproblem war.

    Gute Zeit!

    Xari

    Ich habe jetzt in deiner Frage die URL soweit anonymisiert, dass sie für Suchmaschinen keine Rolle spielt. Potentielle Angreifer können mit den mitgeteilten Informationen nichts anfangen – da gäbe es lohnendere Möglichkeiten.

    Wir löschen keine Threads, weil wir hier im Forum keinen privaten Support leisten, sondern möglichst vielen Nutzern und Nutzerinnnen helfen möchten.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „wp-login funktioniert nicht“ ist für neue Antworten geschlossen.