Support » Allgemeine Fragen » wp-login nicht erreichbar

  • Hi,

    ich habe ein großes Problem, da meine Seite eigentlich fast fertig ist und an den Start gehen sollte, nun aber ein Problem aufgetaucht ist. Und zwar kann ich mich auf meiner login Seite (http://webseite.gymga.de/wordpress/wp-admin/) zwar einloggen mit meinen Daten, allerdings erfolgt dann keine Weiterleitung zum Dashboard mehr, sondern der Browser wird einfach weiß und lädt sich tot.

    Ich habe eine Weg gefunden wie ich ind Dashboard komme:

    1.) Ich gehe auf die obige Loginseite und logge mich ein.
    2.) Ich lösche „wp-admin“ aus der Adresszeile und die Seite erscheint nochmal.
    3.) Ich klicke oben auf „Anpassen“ und werde weitergeleitet.
    4.) Anpassen Seite schließen und zurück auf die HP.
    5.) Jetzt komme ich ins Dashboard.

    Lasse ich den Schritt über die Anpassen Seite weg, klappt es nicht.

    Was ist da los?!

    Ich habe schon einige Hilfen von dieser Seite:

    https://codex.wordpress.org/Login_Trouble

    versucht, soweit mir das möglich war (bin kein Code Crack!). Bin ratlos 🙁

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Fehlermeldungen können nicht nur auf die Ursache eines Problems hinweisen, sondern auch möglichen Angreifern wertvolle Informationen liefern, wie sie einen Fehler für ihre eigenen Zwecke ausnutzen können. Deshalb erscheint statt einer Fehlermeldung nur ein weißer Bildschirm. Um mehr Informationen zur Fehlerursache zu erhalten, sollte im Rahmen der Behebung des Fehlers (und auch tatsächlich nur so langen) der Debug-Modus aktiviert werden. Danach solltest du statt der weißen Seite eine Fehlermeldung sehen.

    Dass du dich über das Verzeichns wp-admin anmelden kannst, hat damit zu tun, dass WordPress beim Zugriff auf das Backend erst einmal prüft, ob Anwender überhaupt angemeldet sind. Wenn nicht, erfolgt eine Weiterleitung entsprechend der Einstellungen der Website- und WordPress-URL im Menü Einstellungen > Allgemein. Bei Problemen mit der Anmeldung solltest du dich aber nicht auf diese Weiterleitung verlassen, sondern statt dessen direkt das Anmeldeformular wp-login nutzen.

    Um Plugins als mögliche Fehlerquellen auszuschließen, würde ich vor der Anmeldung das Verzeichnis wp-content/plugins in z.B. wp-content/plugins_ umbenennen. Bei Aufruf des Plugin-Menüs siehst du dann eine Fehlermeldung, die dir mitteilt, dass alle Plugins deaktiviert wurden, weil die Verzeichnisse nicht mehr aufzufinden sind. Nun kannst du das Plugin wieder in seine ursprüngliche Bezeichnung zurück benennen und anschließend die Plugins im Ausschlussverfahren wieder aktivieren.

    Auch Änderungen am Theme können zu einem White Screen of Death führen. Hilft die Umbenennung des Plugin-Verzeichnisses nicht weiter, kannst du das Verzeichnis deines Themes umbenennen. Dazu sollte aber ein Standard-Theme (Twenty …) in wp-content/themes/ vorhanden sein, damit WordPress darauf ausweichen kann.

    Hey,

    1000 Dank für die schnelle Antwort. Die Plugins hatte ich schon deaktiviert (bzw. das Verzeichnis umbenannt), ich habe jetzt auch den Debug Modus aktiviert und seitdem läuft es tadellos!

    Kein White Screen, keine Fehlermeldung, keine Probleme beim Einloggen. Ich habe sukzessive die Plugins reaktiviert, auch keine Probleme bislang.

    Soll och den Debug Modus jetzt einfach anlassen und abwarten, ob der Fehler irgendwann wieder auftritt?

    Der Debug-Modus sollte nur eingeschaltet werden, um zu möglichen Problemen Fehlermeldungen zu erhalten. Damit gibst du aber auch potentiellen Angreifern Informationen, wo sie Schwachstellen finden könnten – also nach Möglichkeit wieder deaktivieren.

    Es wäre übrigens ungewöhnlich, dass sich ein Problem nur durch Aktivierung des Debug-Modus beheben lässt. Wahrscheinlich hast du (kurz) vorher noch eine andere Änderung vorgenommen, die eigentlich zur Problemlösung beigetragen hat.

    Ok, ich lasse es jetzt erst einmal so, so lange die HP nicht öffentlich ist und beobachte, ob das Problem in den nächsten Tagen wieder vorkommt. Dann setzte ich den Debug Modus wieder zurück und schaue mal, ob es dann wieder kommt. Wenn nicht… Problem gelöst!

    Danke auf jeden Fall!!!

    Ok, das Problem ist nicht behoben. Eine Nacht drüber geschlafen und der Blank Screen ist wieder da. Es erscheint trotz Debug Modus keine Fehlermeldung.

    Seltsamerweise kann ich mich aber über mein iPad einloggen. Nicht aber auf meinem Mac.

    Hallo!

    Mal noch ein paar weitere Überlegungen:

    (1)
    Cache und Cookies löschen, danach erneut testen

    (2)
    Welche Plugins sind im Einzelnen installiert und derzeit aktiviert?
    (Auch wenn du sie schon mal deaktiviert hast)

    (3)
    Mal auf ein Standard-Theme (z.B. Twenty Sixteen) wechseln, danach erneut testen.
    Dazu per FTP das Verzeichnis wp-content/themes/dein-theme umbenennen und dafür sorgen, dass in wp-content/themes ein Standard-Theme liegt, auf das WP dann zurückgreifen kann, wenn das aktuelle Theme durch die Umbenennung deaktiviert wird.

    (4)
    Sicherheitskopie der Datei .htaccess im WordPress-Verzeichnis ziehen, anschließend .htaccess löschen. Falls du danach wieder ins Backend gelangst, dort unter Einstellungen > Permalinks einmal abspeichern (Aufrufen allein genügt meist schon), um die .htaccess neu zu generieren.

    (5)
    Speedtest durchführen:
    https://tools.pingdom.com/
    Vgl. folgende Überlegung bzgl. Timeouts

    • Diese Antwort wurde geändert vor 3 Jahre, 7 Monaten von Flower33. Grund: Tippfehler

    Ok, also:

    1) Habe ich schon 100x gemacht, bringt nix!

    2.) Aktiviert sind Simple Calendar, PDF Embedder, Simple Custom CSS und WPFront Scroll Top. Ich nutze das Theme Zerif Pro.

    3.) Ein Wechsel auf das Twenty Sixteen Theme bringt auch keine Besserung.

    4.) Löschen der .htaccess führt dazu, dass ist das Dashboard immer noch nicht erreiche. Wenn ich die Seite selbst aufrufe, hat es mir das komplette Menü und die Theme Einstellungen durcheinandergebracht.

    5) Bringt nix, da die Site PW geschützt ist.

    Da kein Caching-Plugin dabei ist und, allem Anschein nach, keines, das selbstständig die .htaccess verändert, kann man vermutlich ein Plugin als Ursache ausschließen, zumal du ja auch schon testweise mal alle deaktiviert hattest.

    Seltsamerweise kann ich mich aber über mein iPad einloggen. Nicht aber auf meinem Mac.

    Ich würde, da offenbar nur Erfahrungen mit Mac und iPad vorliegen, jetzt mal noch auf mindestens einem dritten Gerät – einem anderen Desktoprechner oder Notebook (mit Firefox, Chrome oder IE) – gegentesten, um auszuschließen, dass es nur an deinem Mac bzw. dem darauf installierten Browser liegt.

    Danach mal noch Benutzer- und Dateirechte überprüfen; falls das nichts bringt, WordPress manuell updaten (falls beim letzten Update irgendwas schiefgegangen sein sollte) und, falls auch das keine Lösung bringt, mich mal an den Webhoster wenden, ob da serverseitig evtl. ein Problem vorliegt. Wir hatten hier vor ein paar Monaten mal den Fall, dass keiner der genannten bzw. üblichen Trouble-Shooting-Schritte die Lösung brachte und sich letzlich Folgendes als Ursache für die Login-Probleme herausstellte:

    Aufgrund einer Sicherheitseinstellung war das Login von WordPress nur von IPv6-Adressen aus erreichbar. Unser Rechenzentrum hat den Fehler behoben.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „wp-login nicht erreichbar“ ist für neue Antworten geschlossen.