Support » Installation » WP nach Update – Nichts geht mehr!

  • Gelöst n.funky

    (@signmanufaktur)


    Hallo liebe WP Gemeinde,

    Ich benötige hier mal Hilfe von einem Vollprofi.

    Was ist das Problem?
    Ich arbeite zur Zeit an einem Projekt für einen Kunden. Nachdem ich nun das letzt Update von WP (Version 5.8.1) durchgeführt hatte, beckham ich im Dashboard die folgende Meldung „Ein automatisches Update konnte nicht beendet werden“ Auch bei erneuter Ausführung bleibt die Info bestehen.

    Ich habe das WP Update dann manuell installiert.

    Nach Überprüfung hatte ich festgestellt das zwei Plugins nicht mehr vorhanden Waren. Per FTP Zugang aber schon.

    Auch kann ich die Plugins die schon mal vorhanden waren nicht mehr installieren, hier bekomme ich die Info das „Installation fehlgeschlagen: Der Zielordner existiert bereits.“ Auch wenn ich diesen per FTP lösche, bekomme ich die gleiche Info.

    Speicherplatz beim Provider ist reichlich vorhanden.
    WP_MEMORY_LIMIT 256M
    WP_MAX_MEMORY_LIMIT 256M
    PHP-Speicher-Limit (memory_limit) 256M

    Hat jemand von Euch vielleicht noch eine Idee worden das liegen könnte.

    Danke für Eure Hilfe.

    Viele Grüße

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Gibt’s auch eine URL zur Website?

    Warum ein Link zu deiner Website wichtig ist

    Thread-Ersteller n.funky

    (@signmanufaktur)

    Hallo @pixolin

    Oh, ja klar. https://www.vgr-elmshorn.de/

    Eine weitere Meldung nach versuchten Update:

    WordPress aktualisieren
    Herunterladen der Aktualisierung von https://downloads.wordpress.org/release/de_DE/wordpress-5.8.1.zip…
    
    Die Echtheit von wordpress-5.8.1.zip konnte nicht verifiziert werden, da keine Signatur gefunden wurde.
    
    Entpacken der aktualisierten Version …
    
    Überprüfung der entpackten Dateien …
    
    Vorbereitung für die Installation der neuesten Version …
    
    Anschalten des Wartungsmodus …
    
    Kopieren der erforderlichen Dateien …
    
    Abschalten des Wartungsmodus …
    
    Auflistung des Verzeichnisinhaltes ist fehlgeschlagen.
    
    Installation fehlgeschlagen.

    Hallo,
    die aktuelle WordPress-Version 5.8.1 scheint aber installiert zu sein.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Hm, bisher sehe ich nur, dass die Links zu Unterseiten nicht funktionieren. Die Meldung „Ein automatisches Update konnte nicht beendet werden“ kann verschiedene Ursachen von Problemen mit der Datenbank über fehlenden Specherplatz, fehlerhaften Benutzerrechten bis hin zu Schnittstellen-Problemen des Servers haben. Mit den wenigen Angaben ist das schwer zu beurteilen.

    Kannst du dich im Backend anmelden? Dann wäre ein Bericht zur Website hilfreich. Geh dazu bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Vielleicht gibt es auch ein paar Fehlermeldungen im Error-Log des Webservers. Darauf solltest du über das Kundenmenü des Webhosters zugreifen können.

    Ein Arbeitsspeicher von 256MB kann recht schnell knapp werden, wenn du einen Webshop mit diverse AddOns betreibst. Die Aussage „reichlich vorhanden“ wäre mir (ohne weitere Details zu kennen) zu pauschal.

    Du schreibst „Der Zielordner existiert bereits. – Auch wenn ich diesen per FTP lösche, bekomme ich die gleiche Info.“. Ohne dir zu nahe treten zu wollen (ich weiß nicht, wie gut du dich auskennst und will das auch nicht beurteilen), ist häufig die Ursache, dass bei mehreren vorhandenen Installationen an der falschen Stelle gelöscht wurde. Prüf das doch bitte vorsichtshalber nochmal.

    Ganz allgemein solltest du alle Annahmen, die du als „selbstverständlich“ voraussetzt (ich hab doch genug Speicher, ich hab doch die Verzeichnisse gelöscht) besonders kritisch prüfen – wir stellen uns allzu gerne ein Bein, in dem wir ganz einfache Ursachen ausschließen. „Have you tried turning it off and on again“ hört sich banal an, hat dann aber doch bei sehr vielen Problemen geholfen.

    Thread-Ersteller n.funky

    (@signmanufaktur)

    @hage

    Hier ist der Bericht von der Website.

    ### wp-core ###
    
    version: 5.8.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: undefined
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/wp13586533_R0YY3ZL8QR/wp
    wordpress_size: loading...
    uploads_path: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/uploads
    uploads_size: loading...
    themes_path: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/themes
    themes_size: loading...
    plugins_path: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Hello Elementor (hello-elementor)
    version: 2.4.1
    author: Elementor Team
    author_website: https://elementor.com/?utm_source=wp-themes&utm_campaign=author-uri&utm_medium=wp-dash
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, menus, post-thumbnails, automatic-feed-links, title-tag, html5, custom-logo, editor-style, align-wide, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider
    theme_path: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/themes/hello-elementor
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.4, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (1) ###
    
    Site Health Tool Manager: version: 1.1, author: William Earnhardt, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (14) ###
    
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Borlabs Cookie - Cookie Opt-in: version: 2.2.32, author: Benjamin A. Bornschein, Borlabs, Automatische Aktualisierungen deaktiviert
    Check & Log Email: version: 1.0.2, author: WPChill, Automatische Aktualisierungen deaktiviert
    Disable Gutenberg: version: 2.5.1, author: Jeff Starr, Automatische Aktualisierungen deaktiviert
    Easy Updates Manager: version: 9.0.9, author: Easy Updates Manager Team, Automatische Aktualisierungen deaktiviert
    Essential Addons for Elementor: version: 4.9.0, author: WPDeveloper, Automatische Aktualisierungen deaktiviert
    Essential Addons for Elementor - Pro: version: 4.4.9, author: WPDeveloper, Automatische Aktualisierungen deaktiviert
    Flexible Elementor Panel: version: 2.3.7, author: WebMat, Automatische Aktualisierungen deaktiviert
    Header Footer Code Manager: version: 1.1.13, author: 99robots, Automatische Aktualisierungen deaktiviert
    Heroic Favicon Generator: version: 1.7.0, author: HeroThemes, Automatische Aktualisierungen deaktiviert
    Nested Pages: version: 3.1.16, author: Kyle Phillips, Automatische Aktualisierungen deaktiviert
    Reviews and Rating - Google My Business: version: 3.40, author: Noah Hearle, Design Extreme, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.61, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Fastest Cache: version: 0.9.3, author: Emre Vona, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 50
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 7.4.21-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.34-37-log
    client_version: mysqlnd 7.4.21-he.0
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content
    WP_PLUGIN_DIR: /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von Hans-Gerd Gerhards. Grund: Code korrigiert
    Thread-Ersteller n.funky

    (@signmanufaktur)

    @pixolin

    Ja Du hast natürlich recht, die Aussage „ist reichlich vorhanden“ ist sehr ungenau. Hier mal eine genauere Info:

    „Verfügbarer Web-Speicherplatz 100.000,00 MB
    Daten im Web-/FTP-Verzeichnis 2.119,67 MB“

    Ich denke das der Arbeitsspeicher ausreichen müsste, da auf der Website kein Shop installiert wird / ist.

    Ich hatte heute auch schon mit dem Provider telefoniert, auf dem Server gibt es anscheinend keine Probleme! Ich hatte heute die Error Logfile Funktion eingestellt, diese war nicht aktiviert. Schaue gleich noch mal ob ich da was finde.

    Ohne dir zu nahe treten zu wollen (ich weiß nicht, wie gut du dich auskennst und will das auch nicht beurteilen), ist häufig die Ursache, dass bei mehreren vorhandenen Installationen an der falschen Stelle gelöscht wurde. Prüf das doch bitte vorsichtshalber nochmal.

    Es ist nun nicht so das dies nicht meine erste Website ist und auch nicht der erste Fehler. Mit FTP kann ich schon um 🙂 Allerdings ist das ein Problem was ich so auch noch nie hatte.

    @pixolin & @hage
    Vielen vielen Dank für Euren Support, echt Mega

    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von n.funky.
    Thread-Ersteller n.funky

    (@signmanufaktur)

    Error LogFils beim Provider:

    [Thu Sep 09 01:53:20 2021] [ssl:warn] [pid 13945] [client [host AH01909: vgr-elmshorn.de:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Sep 09 16:03:28 2021] [ssl:warn] [pid 13945] [client [host AH01909: vgr-elmshorn.de:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Sep 09 16:27:09 2021] [php7:warn] [pid 20682] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Warning:  filesize(): stat failed for /wp/wp-content/updraft/backup_2021-09-09-1218_VGR_Nord_24e6d58ec56c-db.gz in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-content/plugins/updraftplus/restorer.php on line 1019
    [Thu Sep 09 16:27:09 2021] [php7:warn] [pid 20682] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Warning:  ftp_rmdir(): /wp/.maintenance: No such file or directory in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/includes/class-wp-filesystem-ftpext.php on line 397
    [Thu Sep 09 16:35:42 2021] [php7:error] [pid 26050] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Fatal error:  Uncaught Error: Call to undefined function wp_add_privacy_policy_content() in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/includes/class-wp-privacy-policy-content.php:694\nStack trace:\n#0 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-includes/class-wp-hook.php(303): WP_Privacy_Policy_Content::add_suggested_content('')\n#1 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-includes/class-wp-hook.php(327): WP_Hook-]apply_filters(NULL, Array)\n#2 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-includes/plugin.php(470): WP_Hook-]do_action(Array)\n#3 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/admin-ajax.php(45): do_action('admin_init')\n#4 {main}\n  thrown in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/includes/class-wp-privacy-policy-content.php on line 694
    [Thu Sep 09 16:35:51 2021] [php7:error] [pid 26250] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Parse error:  syntax error, unexpected end of file in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/includes/deprecated.php on line 607
    [Thu Sep 09 16:36:06 2021] [php7:error] [pid 26638] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Fatal error:  Uncaught Error: Class 'WP' not found in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-settings.php:487\nStack trace:\n#0 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-config.php(116): require_once()\n#1 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-load.php(50): require_once('/is/htdocs/wp13...')\n#2 /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/admin-ajax.php(22): require_once('/is/htdocs/wp13...')\n#3 {main}\n  thrown in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-settings.php on line 487
    [Thu Sep 09 16:41:07 2021] [php7:warn] [pid 18234] [client 2001:16b8:6830:bb00:1027:5476:e1f3:dc5f] [host www.vgr-elmshorn.de] PHP Warning:  ftp_rmdir(): /wp/.maintenance: No such file or directory in /is/htdocs/wp13586533_R0YY3ZL8QR/wp/wp-admin/includes/class-wp-filesystem-ftpext.php on line 397

    total_size: loading…

    Du hast leider nicht so lange gewartet, bis der Bericht komplett war.
    Ich würde mal darauf tippen, dass da die Instanz einige kaputte Dateien enthält.
    Hier noch ein paar Ideen zur Lösung – bitte vorher Daten sichern:

    • Neu installieren: Im Dasboard > Aktualisierungen auf den Button „erneut installieren“
    • Falls das nicht hilft, kannst du versuchen, ein manuelles Update durchzuführen. Hier findest du dazu eine sehr gute Anleitung.
    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von Hans-Gerd Gerhards. Grund: Korrektur Erläuterung

    Im WordPress-Verzeichnis ist keine Datei .maintenance mehr vorhanden?

    Ich würde tatsächlich nochmal die Verzeichnisse wp-admin und wp-includes löschen und dann aus einem frischen Dateien-Satz neu hochladen. Es gibt FTP-Clients, die vorhandene Dateien (egal ob vollständig oder anders) einfach überspringen, deshalb wirklich erst löschen und dann erst neu hochladen.

    Das Verzeichnis wp-content muss unbedingt bestehen bleiben, weil da deine eigenen Uploads drin stecken.

    Thread-Ersteller n.funky

    (@signmanufaktur)

    @hage
    Vielen Dank, das werde ich morgen nochmal ausprobieren.

    @pixolin
    Vielen Dank!

    Im WordPress-Verzeichnis ist keine Datei .maintenance mehr vorhanden?

    Die Datei hatte ich schon gelöscht, und dann nochmal das Update gestartet. Allerdings ist das Update fehlgeschlagen und ich bin dann automatisch wieder in in dem Mode gelandet.

    Versuche Morgen nochmal einen frischen Datensatz auf zu spielen. Gebe dann gerne eine Rückinfo.

    Vielen Dank

    Thread-Ersteller n.funky

    (@signmanufaktur)

    @pixolin

    Guten Morgen, Dein Rat war hier die Lösung! Ich habe die Daten per FTP erst vom Server gelöscht und in Kombination mit einem älteren Backup wieder hochgeladen. Allerdings ging das nur mit dem alten Backup! Ich habe dann alle Plugins deaktiviert und das WP Update vorgenommen. Jetzt ist alles wieder fein 🙂

    Nochmals super vielen Dank an @pixolin und @hage für den tollen Support. Machmal hilft auch schon eine andere Sichtweise auf die Dinge oder kleine Hinweise zum Erfolg.

    Beste Grüße

    Super! Freut mich, dass es nun alles wieder läuft.
    Denkst du demnächst bitte noch daran, Threads als „gelöst“ zu markieren? Wir können dann gleich bei anderen, noch nicht gelösten Problemen weitermachen.

    Den Thread hier markiere ich jetzt als „gelöst“.

    Thread-Ersteller n.funky

    (@signmanufaktur)

    @pixolin OK, merke ich mir für das nächste mal 🙂 Hatte ich vor Freude vergessen!

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)