Support » Installation » WP unter PHP 8 installieren

  • dicker62

    (@dicker62)


    Hallo,

    ich kann WP weder unter PHP 8 noch unter PHP 8.1 installieren.

    Es scheitert bereits bei der Installation der Datenbank.

    Fehlermeldung:
    Es gab einen kritischen Fehler auf deiner Website.
    Erfahre mehr über die Problembehandlung in WordPress.

    Funktioniert das etwa nur mit PHP 7.4?

    Kann man das WP dann wenigstens nach der Installation auf PHP 8.1 umstellen, oder ist WP da nicht fehlerfrei lauffähig?

    Ich nutze die neueste Debian 11 Version mit MariaDB 10.5.12.

    Vielen Dank für die Hilfe.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ich nutze selber WordPress in verschiedenen Installationen unter PHP 8.0 ohne Probleme, aber es gibt noch einige Themes und Plugins, die nicht auf PHP 8.0 umgestellt wurden. Die allgemeine Empfehlung ist, PHP 7.4 noch so lange zu nutzen, wie die Version mit Sicherheitsupdates versorgt wird (November 2022).

    Zu der sehr allgemein gehaltenen Fehlermeldung solltest du weitere Informationen erhalten wenn du in den Error-Log des Webservers schaust.

    @pixolin
    Hast du WordPress auch mit PHP 8 installiert oder die PHP-Version später erhöht?

    Ich habe es auch mal mit PHP 8.1 getestet und bei mir ist die Installation an gleicher Stelle ausgestiegen.

    Moderator Bego Mario Garde

    (@pixolin)

    Gerade nochmal ausprobiert: PHP 8.0.14 läuft, WordPress-Dateien heruntergeladen, in Web-Stammverzeichnis kopiert, im Browser URL aufgerufen, Datenbank-Zugangsdaten eingegeben, Website-Titel und Admin-Zugangsdaten eingegeben, läuft. Keine Fehlermeldungen unter PHP 8.0, Error-Log leer.

    Parallel nochmal in LocalWP probiert – selbes Ergebnis. Läuft alles, Installation ohne Fehlermeldungen.

    Mit PHP 8.0.6 funktioniert es bei mit auch noch, aber mit PHP 8.1.1 nicht mehr.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)